summaryrefslogtreecommitdiff
path: root/app-arch/brotli
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-arch/brotli
reinit the tree, so we can have metadata
Diffstat (limited to 'app-arch/brotli')
-rw-r--r--app-arch/brotli/Manifest4
-rw-r--r--app-arch/brotli/brotli-0.6.0.ebuild61
-rw-r--r--app-arch/brotli/files/brotli-0.6.0-no-rpath.patch32
-rw-r--r--app-arch/brotli/metadata.xml18
4 files changed, 115 insertions, 0 deletions
diff --git a/app-arch/brotli/Manifest b/app-arch/brotli/Manifest
new file mode 100644
index 000000000000..89659ee7a097
--- /dev/null
+++ b/app-arch/brotli/Manifest
@@ -0,0 +1,4 @@
+AUX brotli-0.6.0-no-rpath.patch 1196 SHA256 ae159a8592fdc78d7d9fe53ee643c3fac7e04f658a02eeb0f93234046f6017f7 SHA512 8dddddc2d44bc9af9c4bbe277ece69ac22e6e77661d3982cc67b2a681ce01c03afb63e6796ae3a6c81cd6495bd39e64a0955c189dba1cc4bd43335ab3fc70123 WHIRLPOOL b247c43cde8b521b86c76e6522735de6eff830fb42f3f93586668291445228f68561e89df32beb5f9b0cb080b23ac681286eb2ce5ca57829bc82bce77e27c15b
+DIST brotli-0.6.0.tar.gz 19838761 SHA256 69cdbdf5709051dd086a2f020f5abf9e32519eafe0ad6be820c667c3a9c9ee0f SHA512 36caa277790efeb5bff0fdc090cdcf00fd9995c4e81a60ed31d36af2e13848ec1afe5d84e6926eebbee013525191e9404e112cb7fbede16097221c5bc3dfb5d5 WHIRLPOOL 2ffe1213ca430821dfdf1b21ae4cce91060a93a4a8ff4f867e48c4108373fe319abede11f9a524634997f8789cede11f30b2c7143c254b1da99f00f50b0817fd
+EBUILD brotli-0.6.0.ebuild 1259 SHA256 df496fa3d89312c7e32bdd2c12172f900ae82a0fccf12fe16ffe5ab71178ca34 SHA512 e35ee2605f957fcca40cc892d097f1f80b361fb1b651c1e037fb3f50b6cb6a9ab294d3908066c9d6afdf5511244fed769faa8081a3b8023025059936d7612eda WHIRLPOOL 66d18f5c5b6047b96d03131563b14749343c17b6bae21294bbf5b74b1bb82fc921cdaddd14b20726eae4c17d33e5bbf7864ebe4cfa8ecc8c246069ed513b38d8
+MISC metadata.xml 690 SHA256 c968e1228318cb0962986760204b2ed14151942d1936a6dbf03e4f9a65eb3047 SHA512 8d98e22ce2ac4f69876e378773415f65ab8c5846e6d4952a6ce104b07343a5486abc9b88c49b54a3187bdedf880e0b2a3b6d06448fdd8c10f692718de6355dba WHIRLPOOL b76216d167f825ee1873ccda2676f9406671b9869e225bc940dcb7c6b4208e3eaed5f632526ae4ac87e10db86e0dfecc90a25499e09c6e458f7aa87357116dee
diff --git a/app-arch/brotli/brotli-0.6.0.ebuild b/app-arch/brotli/brotli-0.6.0.ebuild
new file mode 100644
index 000000000000..91daf8320a8c
--- /dev/null
+++ b/app-arch/brotli/brotli-0.6.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+DISTUTILS_OPTIONAL="1"
+
+inherit cmake-utils distutils-r1
+
+DESCRIPTION="Generic-purpose lossless compression algorithm"
+HOMEPAGE="https://github.com/google/brotli"
+SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}"
+
+IUSE="python test"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+LICENSE="MIT python? ( Apache-2.0 )"
+
+DOCS=( README.md CONTRIBUTING.md )
+
+PATCHES=( "${FILESDIR}"/${P}-no-rpath.patch )
+
+src_prepare() {
+ cmake-utils_src_prepare
+ use python && distutils-r1_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ -DBUILD_TESTING="$(usex test)"
+ )
+ cmake-utils_src_configure
+ use python && distutils-r1_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ use python && distutils-r1_src_compile
+}
+
+python_test(){
+ esetup.py test || die
+}
+
+src_test() {
+ cmake-utils_src_test
+ use python && distutils-r1_src_test
+}
+
+src_install() {
+ cmake-utils_src_install
+ use python && distutils-r1_src_install
+}
diff --git a/app-arch/brotli/files/brotli-0.6.0-no-rpath.patch b/app-arch/brotli/files/brotli-0.6.0-no-rpath.patch
new file mode 100644
index 000000000000..28e70d7acfe7
--- /dev/null
+++ b/app-arch/brotli/files/brotli-0.6.0-no-rpath.patch
@@ -0,0 +1,32 @@
+From: Tomasz Buchert <tomasz@debian.org>
+Date: Sat, 24 Jun 2017 14:40:16 +0200
+Subject: Do not set rpath on shared libs.
+
+---
+ CMakeLists.txt | 13 -------------
+ 1 file changed, 13 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index ca612d1..bf70d69 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -27,19 +27,6 @@ CMAKE_DEPENDENT_OPTION(BUILD_SHARED_LIBS "Build shared libraries" ON "NOT BROTLI
+
+ include(GNUInstallDirs)
+
+-# When building shared libraries it is important to set the correct rpath.
+-# See https://cmake.org/Wiki/CMake_RPATH_handling#Always_full_RPATH
+-if (BUILD_SHARED_LIBS)
+- add_definitions(-DBROTLI_SHARED_COMPILATION)
+- set(CMAKE_SKIP_BUILD_RPATH FALSE)
+- set(CMAKE_BUILD_WITH_INSTALL_RPATH FALSE)
+- set(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
+- list(FIND CMAKE_PLATFORM_IMPLICIT_LINK_DIRECTORIES "${CMAKE_INSTALL_LIBDIR}" isSystemDir)
+- if ("${isSystemDir}" STREQUAL "-1")
+- set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_LIBDIR}")
+- endif()
+-endif()
+-
+ # Parse version information from common/version.h. Normally we would
+ # define these values here and write them out to configuration file(s)
+ # (i.e., config.h), but in this case we parse them from
diff --git a/app-arch/brotli/metadata.xml b/app-arch/brotli/metadata.xml
new file mode 100644
index 000000000000..0a0fddcd4ed6
--- /dev/null
+++ b/app-arch/brotli/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bicatali@gentoo.org</email>
+ <name>Sébastien Fabbro</name>
+ </maintainer>
+ <longdescription>
+ Brotli is a generic-purpose lossless compression algorithm that
+ compresses data using a combination of a modern variant of the
+ LZ77 algorithm, Huffman coding and 2nd order context modeling,
+ with a hight compression ratio. It is similar in speed with
+ deflate but offers denser compression.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">google/brotli</remote-id>
+ </upstream>
+</pkgmetadata>