summaryrefslogtreecommitdiff
path: root/app-arch/brotli
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
commita978c074e4272bb901fbe4a10de0a7b2af574f17 (patch)
tree8c764c1cc0576389ce22abd317bceba71ea5732d /app-arch/brotli
parent40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (diff)
gentoo resync : 04.05.2021
Diffstat (limited to 'app-arch/brotli')
-rw-r--r--app-arch/brotli/Manifest3
-rw-r--r--app-arch/brotli/brotli-1.0.9-r2.ebuild85
-rw-r--r--app-arch/brotli/brotli-9999.ebuild5
3 files changed, 90 insertions, 3 deletions
diff --git a/app-arch/brotli/Manifest b/app-arch/brotli/Manifest
index 4e2b877872f7..2c57330099af 100644
--- a/app-arch/brotli/Manifest
+++ b/app-arch/brotli/Manifest
@@ -1,5 +1,6 @@
AUX 1.0.9-linker.patch 1799 BLAKE2B b082af9af7eb8df80bf86717e9b9511952e77afd649de9bfe9cbf445216d4e9d6a6e34dc065008d0129892240c98bcb6e7beb5443d4c459a1bb77eff664f7245 SHA512 04d5505074e042eca46a8dfd9d9a3a2c9af901d9bf7d98c219e8e1f8c9b9071bccbddfa3e17e86800de2606a10b26dc05d69948cd84ddd3075d6c1c51991bcc2
DIST brotli-1.0.9.tar.gz 486984 BLAKE2B 8b9939d5224396ef33b43e019250ba4bc8949903583615e8dc02c85340fc0a1e2d1632161e00b0ee7355d77f05529ac772f482e05d2089afd71a0bf71e803904 SHA512 b8e2df955e8796ac1f022eb4ebad29532cb7e3aa6a4b6aee91dbd2c7d637eee84d9a144d3e878895bb5e62800875c2c01c8f737a1261020c54feacf9f676b5f5
EBUILD brotli-1.0.9-r1.ebuild 1764 BLAKE2B 8b90b73dacd0a643ed34441378026d5e20a5c50797e8dcac32f9627db5b7aebaa65cff74cf30ab6cb4c6cd6c1a5fc529c73fb0d7d2859e486e9a1406b274a0fd SHA512 6becec9055b96298bd5ce44c5af713901febe38db8160a2499bb63e41adb9386dd3b16160f5852e4df4d36bb26aa014dfb59fcc9d0ad37f85c5ac0a77def0c9f
-EBUILD brotli-9999.ebuild 1645 BLAKE2B 9c910229d35e60c5141e51dcefa7d3c7f5e5df9e58a94f6a727e6936d65354b7593fa389658a2f8eb9e948eec676b9ee78ff33830f8bb58fe7b8e1f2764c1272 SHA512 49a056058706f2411dd654f1fd5f093b27798cc6129b16b31c976e5c70c5d422d8a9d540e9cf27c2d1f83c32f88d4ef466a78972f0b56319c72b4620951a8ec8
+EBUILD brotli-1.0.9-r2.ebuild 1844 BLAKE2B 9ab0224a88f895446a0237d083fb85931436c5aac47c26001e9556eed631d15ad166d094e05bb44b73ea00acd38a105469a9e8017a89a48f3aafa7e1d7d14a78 SHA512 0043e2af0bde7cb003cdbdf3e07da80164097c7220ace7666888dacc7a54f8ab8f649758e9a140cbeb354600643b198d1fa4b406331cca419b8eeaecfb487225
+EBUILD brotli-9999.ebuild 1730 BLAKE2B ff641ac49dd29a27469afda38b84dff17a623aa7863e310b03b88723d35483bbdb622d2f9b7a6fb8b363bfacdacb275c8e9cbd29a1bf1d1c051a01c220a5e2c3 SHA512 258cc7962e09c5fe2e4f05b5fe82213f5ba607535b64579178af0661b85a768974061fc4a020920018f8ce1268251820f86277177d5d4cec195454e4eb8dc0f7
MISC metadata.xml 686 BLAKE2B 192c9019f79840dfcc409e8244eac99f3bd793ea91bb8f5f26fcf1a9dbb6ba34273ea2221e0e18322dccec1674929cdf1bfd7ca19628a3e69fc4bdd6f60ba932 SHA512 4057d0834db13baf716500e6d8fa80b9d6ee854f7e9620462ed1162d2bc6ff88d2bb2f81902c6730df337afc38c8eb378fa5b85debd2a5a57597c0faf58132dc
diff --git a/app-arch/brotli/brotli-1.0.9-r2.ebuild b/app-arch/brotli/brotli-1.0.9-r2.ebuild
new file mode 100644
index 000000000000..9f152be136aa
--- /dev/null
+++ b/app-arch/brotli/brotli-1.0.9-r2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_OPTIONAL="1"
+DISTUTILS_IN_SOURCE_BUILD="1"
+
+inherit cmake-multilib distutils-r1
+
+DESCRIPTION="Generic-purpose lossless compression algorithm"
+HOMEPAGE="https://github.com/google/brotli"
+
+SLOT="0/$(ver_cut 1)"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}"
+
+IUSE="python static-libs test"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+LICENSE="MIT python? ( Apache-2.0 )"
+
+DOCS=( README.md CONTRIBUTING.md )
+
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/google/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+ SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+# tests are currently broken, see https://github.com/google/brotli/issues/850
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${PV}-linker.patch"
+)
+
+src_prepare() {
+ use python && distutils-r1_src_prepare
+ cmake-utils_src_prepare
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING="$(usex test)"
+ )
+ cmake-utils_src_configure
+}
+src_configure() {
+ cmake-multilib_src_configure
+ use python && distutils-r1_src_configure
+}
+
+multilib_src_compile() {
+ cmake-utils_src_compile
+}
+src_compile() {
+ cmake-multilib_src_compile
+ use python && distutils-r1_src_compile
+}
+
+python_test() {
+ esetup.py test || die
+}
+
+multilib_src_test() {
+ cmake-utils_src_test
+}
+src_test() {
+ cmake-multilib_src_test
+ use python && distutils-r1_src_test
+}
+
+multilib_src_install() {
+ cmake-utils_src_install
+ use static-libs || rm "${ED}"/usr/$(get_libdir)/*.a || die
+}
+multilib_src_install_all() {
+ use python && distutils-r1_src_install
+}
diff --git a/app-arch/brotli/brotli-9999.ebuild b/app-arch/brotli/brotli-9999.ebuild
index d84bfa85b3e9..87affbe108c9 100644
--- a/app-arch/brotli/brotli-9999.ebuild
+++ b/app-arch/brotli/brotli-9999.ebuild
@@ -17,7 +17,7 @@ SLOT="0/$(ver_cut 1)"
RDEPEND="python? ( ${PYTHON_DEPS} )"
DEPEND="${RDEPEND}"
-IUSE="python test"
+IUSE="python static-libs test"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
LICENSE="MIT python? ( Apache-2.0 )"
@@ -29,7 +29,7 @@ if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/google/${PN}.git"
inherit git-r3
else
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
fi
@@ -73,6 +73,7 @@ src_test() {
multilib_src_install() {
cmake-utils_src_install
+ use static-libs || rm "${ED}"/usr/$(get_libdir)/*.a || die
}
multilib_src_install_all() {
use python && distutils-r1_src_install