summaryrefslogtreecommitdiff
path: root/app-arch/bzip3/bzip3-1.1.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-25 03:53:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-25 03:53:02 +0100
commit1bb02f2ca2710df2358072c9a036ae83d2ece88c (patch)
tree820bd0a18626e1c59cf5db3ff364a95806dd9b61 /app-arch/bzip3/bzip3-1.1.7.ebuild
parent7ae4e1d32a98b596d483a19ed94a21b560eb595d (diff)
gentoo auto-resync : 25:10:2022 - 03:53:02
Diffstat (limited to 'app-arch/bzip3/bzip3-1.1.7.ebuild')
-rw-r--r--app-arch/bzip3/bzip3-1.1.7.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-arch/bzip3/bzip3-1.1.7.ebuild b/app-arch/bzip3/bzip3-1.1.7.ebuild
new file mode 100644
index 000000000000..0d9329da48ca
--- /dev/null
+++ b/app-arch/bzip3/bzip3-1.1.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A better and stronger spiritual successor to BZip2"
+HOMEPAGE="https://github.com/kspalaiologos/bzip3"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kspalaiologos/${PN}.git"
+else
+ SRC_URI="https://github.com/kspalaiologos/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~loong ~x86"
+fi
+
+LICENSE="LGPL-3+"
+SLOT="0"
+
+src_configure() {
+ # ./configure script will default to Clang if it is found on the system,
+ # force the use of CC selected by the user with CC=$(tc-getCC)
+ econf CC=$(tc-getCC)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}