summaryrefslogtreecommitdiff
path: root/app-arch/cfv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-arch/cfv
reinit the tree, so we can have metadata
Diffstat (limited to 'app-arch/cfv')
-rw-r--r--app-arch/cfv/Manifest5
-rw-r--r--app-arch/cfv/cfv-1.18.3-r1.ebuild40
-rw-r--r--app-arch/cfv/metadata.xml17
3 files changed, 62 insertions, 0 deletions
diff --git a/app-arch/cfv/Manifest b/app-arch/cfv/Manifest
new file mode 100644
index 000000000000..9f6a581dacc6
--- /dev/null
+++ b/app-arch/cfv/Manifest
@@ -0,0 +1,5 @@
+DIST cfv-1.18.3.tar.gz 68030 SHA256 ff28a8aa679932b83eb3b248ed2557c6da5860d5f8456ffe24686253a354cff6 SHA512 dbca82df850703ab68a20db9314475025ac2e7012f34a12abbb358677e81cbb29a465adf4a1b002f6cf1c1dd84f1588fc1072791d6bbaad0c02cc563e5fe7d71 WHIRLPOOL 895211c61ff57068f28945fd374d3b9e2f00dc2739e1b884bbdb7cfa0a799d50ee36ff6791bb6457e2eba5f613a8b57b77bd1b3bacc7c4a329f0326d58375b13
+EBUILD cfv-1.18.3-r1.ebuild 810 SHA256 f57c39578068a72e2a6be6bb5a644a55ddc7e035ce5090cfbb95e4381e725796 SHA512 a88789502fc23d53ca977d7afb043a720a3f48d42e0da5e0d2694956c074d8c4b6b58749ec81fc88360db3d14a240bfc01e5a7cbf46de608d6e9b70835ebcc66 WHIRLPOOL 1d40a1e0d1b56b6ebaded049a81747cc90bb0efb88d282972b9f3c5f810e67ff54dd8e2044ed687df633d4481c2ecd2de2d1ba1806fa909de9671d52d8263d04
+MISC ChangeLog 3470 SHA256 93e88c0e5768750dbde5ab807fbc262c2bf8a55b467dead33695f74e6c45c9a8 SHA512 3105698bb01d831f218b5aaaf7c3dcd118c4eb16eb90279856e4145b766c39dbcdbd43c295bcc362f5162c6a72d47e8ed68eb243ea2d517a5f28b4cb797a75b0 WHIRLPOOL 5aa00656bd64c5de5852225a0518ab5e8a72e99a473f74c08219ee5ada3546428f9910839be9dea4f480ccb0f7305cdd1971fcad7b9fe45f488634dfdd1a287a
+MISC ChangeLog-2015 4683 SHA256 1de7b98d39506aea11bd68c15ab42991ef75b2a6c1bb37f33c887f918b92f8d9 SHA512 5ca48517248ef47a3fe4c1ca2b2c7cbc5f37887b6b2400b1a8fc2584ba5acb4c5e76325785d1328bb95862843d9510a4c20be037e41b24b4759a4f397f18f5bc WHIRLPOOL 44df6bb5913690ad0fb02c732e5ed8c11e1462230ffd4aef7740c5503a1e4d97062aa44ca0befe412378930260cf430facbbb648cb5e88df82fc7b926c235634
+MISC metadata.xml 581 SHA256 84d1a0f2af80250f1dc1cf42c20c800b3e299228be2ba4dc50ee0963d3bed07b SHA512 ac57bc554978a1f62b0ecef157853b66a00aa7098be0f5e42e01e5cf9546a8aec259dca9037d6698defea3e2e265ef7827e9e9cc73db98d6584896a3755b9d56 WHIRLPOOL 9de01a791271505ef85d76017566598e54ae44e988ea55599bdb6359922ac962e9f38b8fa58124e75081c0f87e38915d58cd6c2bad69e299c7828314ed5cb22f
diff --git a/app-arch/cfv/cfv-1.18.3-r1.ebuild b/app-arch/cfv/cfv-1.18.3-r1.ebuild
new file mode 100644
index 000000000000..a83d0cfdaf2c
--- /dev/null
+++ b/app-arch/cfv/cfv-1.18.3-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Utility to test and create .sfv, .csv, .crc and md5sum files"
+HOMEPAGE="http://cfv.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cfv/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="bittorrent"
+KEYWORDS="amd64 hppa ~ppc ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+DEPEND=""
+RDEPEND="${PYTHON_DEPS}
+ dev-python/python-fchksum[${PYTHON_USEDEP}]
+ bittorrent? (
+ || (
+ net-p2p/bittorrent[${PYTHON_USEDEP}]
+ net-p2p/bittornado[${PYTHON_USEDEP}]
+ )
+ )"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ python_fix_shebang cfv
+ dobin cfv
+ doman cfv.1
+ dodoc README Changelog
+}
diff --git a/app-arch/cfv/metadata.xml b/app-arch/cfv/metadata.xml
new file mode 100644
index 000000000000..f4989687fc0b
--- /dev/null
+++ b/app-arch/cfv/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <longdescription>
+ cfv is a utility to both test and create .sfv, .csv, .crc,
+ .md5(sfv-like), md5sum, bsd md5, sha1sum, and .torrent files. These
+ files are commonly used to ensure the correct retrieval or storage of
+ data.
+ </longdescription>
+ <use>
+ <flag name="bittorrent">Enable support for checking .torrent files</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">cfv</remote-id>
+ </upstream>
+</pkgmetadata>