summaryrefslogtreecommitdiff
path: root/app-arch/cfv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-05 09:17:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-05 09:17:35 +0000
commit54c42eb42df420f52e032fcba7727c326ef01094 (patch)
tree0dee719f67aa7ad3bfb64c3a46912acad885d738 /app-arch/cfv
parenta8b01fd62375e0df65d5f8f20c5ee142ec6739b6 (diff)
gentoo auto-resync : 05:11:2022 - 09:17:35
Diffstat (limited to 'app-arch/cfv')
-rw-r--r--app-arch/cfv/Manifest3
-rw-r--r--app-arch/cfv/cfv-3.0.0.ebuild48
-rw-r--r--app-arch/cfv/metadata.xml20
3 files changed, 71 insertions, 0 deletions
diff --git a/app-arch/cfv/Manifest b/app-arch/cfv/Manifest
new file mode 100644
index 000000000000..988b76e011e0
--- /dev/null
+++ b/app-arch/cfv/Manifest
@@ -0,0 +1,3 @@
+DIST cfv-3.0.0.gh.tar.gz 91600 BLAKE2B 5a0d53a2b75973967ef976ce55d5262f71af97a8d7c64e8ea94ed9d66fd12778e10321e82bdbc4b8037df3f1a9c9c817694a7cd5e60615fc903127df9057b04f SHA512 9a44bf20f0a4f48a93631353d0b0ab79ea15d19f1da5492296dd4bd4e6208d3f0d71e957165e31d07b5faa7fc75122f0ae5ddbd8d54b9c6b633c43695b362640
+EBUILD cfv-3.0.0.ebuild 1205 BLAKE2B b6d995ccb0fa445726d348eefe2ba36129b60b711f13767a9af2eaff68f2d65a765dce7c0b6008c2f7f05746896519712d3dbbe93092596280d21fd2d028adda SHA512 f912b0f4ad16fc28e84c0e76e3b01266d775697bad2c2486b4a9c8af3e0d59385c4cbb2545caae53dee3a3835c35d906e258307221172c51080e033342b7c401
+MISC metadata.xml 752 BLAKE2B ad109bc840ed5d4b581fa93ed023eb489b2e410d6cfef41756680ae64c6ffb2a1ee4e8a979909d7584844bb8639d26374c00840864ffe380f0446226ab45f63f SHA512 6803dc7d2b3d65cf1586d6d4153280f2f672aa4be914ab80bd693a64282102a3bc59ad213b39830b7421f1764f912920e96cd975cc1929d1878452c87f12ba88
diff --git a/app-arch/cfv/cfv-3.0.0.ebuild b/app-arch/cfv/cfv-3.0.0.ebuild
new file mode 100644
index 000000000000..5b940295d074
--- /dev/null
+++ b/app-arch/cfv/cfv-3.0.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+# Tests fail with pypy3 as of PyPy 7.3.9 / Python 3.9.12
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Command-line File Verify - versatile file checksum creator and verifier"
+HOMEPAGE="https://github.com/cfv-project/cfv/"
+# Tests aren't included in PyPI tarballs
+SRC_URI="https://github.com/cfv-project/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ app-arch/cksfv
+ )
+"
+
+python_prepare_all() {
+ # Remove upstream's attempt to install the man page
+ sed -i '/\sdata_files=/d' setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # In order to run integration tests in addition to unit tests, we can't
+ # just rely on pytest here, we need to use upstream's runner.
+ "${EPYTHON}" "test/test.py" || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman cfv.1
+}
+
+pkg_postinst() {
+ optfeature "the dimension column of JPEG Sheriff crc files" dev-python/pillow
+}
diff --git a/app-arch/cfv/metadata.xml b/app-arch/cfv/metadata.xml
new file mode 100644
index 000000000000..373591c9c7a7
--- /dev/null
+++ b/app-arch/cfv/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sbraz@gentoo.org</email>
+ <name>Louis Sautier</name>
+ </maintainer>
+ <longdescription>
+ cfv is a utility to test and create a wide range of checksum
+ verification files. It currently supports testing and creating sfv,
+ sfvmd5, csv, csv2, csv4, md5, bsdmd5, sha1, sha224, sha256, sha384,
+ sha512, torrent and crc files. Test-only support is available for par,
+ par2.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">cfv</remote-id>
+ <remote-id type="github">cfv-project/cfv</remote-id>
+ <bugs-to>https://github.com/cfv-project/cfv/issues</bugs-to>
+ </upstream>
+</pkgmetadata>