summaryrefslogtreecommitdiff
path: root/app-arch/deb2targz/deb2targz-1-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /app-arch/deb2targz/deb2targz-1-r3.ebuild
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'app-arch/deb2targz/deb2targz-1-r3.ebuild')
-rw-r--r--app-arch/deb2targz/deb2targz-1-r3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-arch/deb2targz/deb2targz-1-r3.ebuild b/app-arch/deb2targz/deb2targz-1-r3.ebuild
new file mode 100644
index 000000000000..ce36ff46f149
--- /dev/null
+++ b/app-arch/deb2targz/deb2targz-1-r3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Convert a .deb file to a .tar.gz archive"
+HOMEPAGE="http://www.miketaylor.org.uk/tech/deb/"
+SRC_URI="http://www.miketaylor.org.uk/tech/deb/${PN}"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~amd64-linux ~arm ~hppa ~ia64 ~ppc ~ppc-aix ~ppc-macos ~ppc64 ~sparc ~sparc-solaris ~x86 ~x86-linux ~x86-macos ~x86-solaris"
+
+RDEPEND="dev-lang/perl"
+
+S=${WORKDIR}
+PATCHES=( "${FILESDIR}/${PN}-any-data.patch" )
+
+src_unpack() {
+ cp "${DISTDIR}/${PN}" "${S}" || die
+}
+
+src_install() {
+ dobin ${PN}
+}