summaryrefslogtreecommitdiff
path: root/app-arch/engrampa
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /app-arch/engrampa
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'app-arch/engrampa')
-rw-r--r--app-arch/engrampa/Manifest2
-rw-r--r--app-arch/engrampa/engrampa-1.24.2-r1.ebuild63
-rw-r--r--app-arch/engrampa/engrampa-1.24.2.ebuild69
3 files changed, 64 insertions, 70 deletions
diff --git a/app-arch/engrampa/Manifest b/app-arch/engrampa/Manifest
index 7b088244873b..b6a2aa2929a4 100644
--- a/app-arch/engrampa/Manifest
+++ b/app-arch/engrampa/Manifest
@@ -1,3 +1,3 @@
DIST engrampa-1.24.2.tar.xz 1687432 BLAKE2B b2ef407aef77f9ecd3f8b06d2e991615a39fa2d4487678292d035a7cab882551bc8c757c6a15037b828cb51aaba14c2ec25e85e891770f6f8c9b453753d87b42 SHA512 1e0acecfe42e3945fe43729283522dfd56dc4cee92a4d5998c995a496f42f41b284ec10f01eb142139c1cec65e3b5a037299b168b73a2e6e828ae3ab4b9c777d
-EBUILD engrampa-1.24.2.ebuild 1706 BLAKE2B 22666f6f6a2c1ccc1171723e8787e1078592f9a1576889608a54f64af215805ff9a0b69b5c2f0f3c12a3f6958d63dff8a3906614b5d4d56c6902b3b7410858cc SHA512 3ba6d1636cd457bcd545c19225d0a4074c835a61ad455e5de5e554ba73f2db9b11f68b0782517e06891093ad29a23fb566e2f7e9ab8c706e1c9b2e6adaee6284
+EBUILD engrampa-1.24.2-r1.ebuild 1562 BLAKE2B 58401e50358f410fc04be43e6491ce95369609374a84a93062370bad19e12979af9a0722ffd5f40bd46363edbfbfe9d91674d5682822511a55aefeb8ad77d65a SHA512 2dd25260a6cc08db597bb3add653c6eecb3986d662ce8f2db0253211b53fb88915a0a9bb4d6f71100768375e7f9778a7c82e94bafc596edbc280749f292754cc
MISC metadata.xml 591 BLAKE2B 9a58776d887b3437f4edccb14ba8cd85139acfadece0e4c7a9c7ed7f5f02d5276fc86d30affeb1b605eba15a8ed34a7c40847564436c320e2a8cef5a313de12f SHA512 b0ae271bbdb0046308b9e06df3259bb5dc9d43e406830e000e4513d817fddccfee4b0af956f1c218ad6800e21d79682deddb4561789a42226ee1afa005cc7b3b
diff --git a/app-arch/engrampa/engrampa-1.24.2-r1.ebuild b/app-arch/engrampa/engrampa-1.24.2-r1.ebuild
new file mode 100644
index 000000000000..8073767c9909
--- /dev/null
+++ b/app-arch/engrampa/engrampa-1.24.2-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit mate optfeature
+
+DESCRIPTION="Engrampa archive manager for MATE"
+
+LICENSE="FDL-1.1+ GPL-2+ LGPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~loong ~riscv x86"
+IUSE="caja magic packagekit"
+
+DEPEND="
+ >=dev-libs/glib-2.50:2
+ >=dev-libs/json-glib-0.14
+ virtual/libintl
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3[X]
+ x11-libs/libSM
+ x11-libs/pango
+ caja? ( >=mate-base/caja-1.17.1 )
+ magic? ( sys-apps/file )
+ packagekit? ( app-admin/packagekit-base )
+"
+RDEPEND="
+ ${DEPEND}
+ virtual/libintl
+"
+BDEPEND="
+ app-text/yelp-tools
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ mate_src_configure \
+ --disable-run-in-place \
+ $(use_enable caja caja-actions) \
+ $(use_enable magic) \
+ $(use_enable packagekit)
+}
+
+pkg_postinst() {
+ mate_pkg_postinst
+
+ optfeature "Support for 7-zip" app-arch/p7zip
+ optfeature "Support for ace" app-arch/unace
+ optfeature "Support for arj" app-arch/arj
+ optfeature "Support for cpio" app-arch/cpio
+ optfeature "Support for deb" app-arch/dpkg
+ optfeature "Support for iso" app-cdr/cdrtools
+ optfeature "Support for jar,zip" app-arch/zip app-arch/unzip
+ optfeature "Support for lha" app-arch/lha
+ optfeature "Support for lzma" app-arch/xz-utils
+ optfeature "Support for lzop" app-arch/lzop
+ optfeature "Support for rar" app-arch/unrar
+ optfeature "Support for rpm" app-arch/rpm
+ optfeature "Support for unstuff" app-arch/stuffit
+ optfeature "Support for zoo" app-arch/zoo
+}
diff --git a/app-arch/engrampa/engrampa-1.24.2.ebuild b/app-arch/engrampa/engrampa-1.24.2.ebuild
deleted file mode 100644
index 1e11f0dc6087..000000000000
--- a/app-arch/engrampa/engrampa-1.24.2.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MATE_LA_PUNT="yes"
-
-inherit mate optfeature readme.gentoo-r1
-
-if [[ ${PV} != 9999 ]]; then
- KEYWORDS="amd64 ~arm ~arm64 ~loong ~riscv x86"
-fi
-
-DESCRIPTION="Engrampa archive manager for MATE"
-LICENSE="FDL-1.1+ GPL-2+ LGPL-2+"
-SLOT="0"
-
-IUSE="caja magic packagekit"
-
-COMMON_DEPEND="
- >=dev-libs/glib-2.50:2
- >=dev-libs/json-glib-0.14
- virtual/libintl
- x11-libs/gdk-pixbuf:2
- >=x11-libs/gtk+-3.22:3[X]
- x11-libs/libSM
- x11-libs/pango
- caja? ( >=mate-base/caja-1.17.1 )
- magic? ( sys-apps/file )
- packagekit? ( app-admin/packagekit-base )
-"
-
-RDEPEND="${COMMON_DEPEND}
- virtual/libintl
- !!app-arch/mate-file-archiver
-"
-
-DEPEND="${COMMON_DEPEND}
- app-text/yelp-tools
- dev-util/glib-utils
- >=sys-devel/gettext-0.19.8
- virtual/pkgconfig
-"
-
-src_configure() {
- mate_src_configure \
- --disable-run-in-place \
- $(use_enable caja caja-actions) \
- $(use_enable magic) \
- $(use_enable packagekit)
-}
-
-pkg_postinst() {
- mate_pkg_postinst
- optfeature "Support for 7-zip" app-arch/p7zip
- optfeature "Support for ace" app-arch/unace
- optfeature "Support for arj" app-arch/arj
- optfeature "Support for cpio" app-arch/cpio
- optfeature "Support for deb" app-arch/dpkg
- optfeature "Support for iso" app-cdr/cdrtools
- optfeature "Support for jar,zip" app-arch/zip app-arch/unzip
- optfeature "Support for lha" app-arch/lha
- optfeature "Support for lzma" app-arch/xz-utils
- optfeature "Support for lzop" app-arch/lzop
- optfeature "Support for rar" app-arch/unrar
- optfeature "Support for rpm" app-arch/rpm
- optfeature "Support for unstuff" app-arch/stuffit
- optfeature "Support for zoo" app-arch/zoo
-}