summaryrefslogtreecommitdiff
path: root/app-arch/lcab/lcab-1.0_beta12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-arch/lcab/lcab-1.0_beta12.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-arch/lcab/lcab-1.0_beta12.ebuild')
-rw-r--r--app-arch/lcab/lcab-1.0_beta12.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-arch/lcab/lcab-1.0_beta12.ebuild b/app-arch/lcab/lcab-1.0_beta12.ebuild
new file mode 100644
index 000000000000..c9cc63e792b5
--- /dev/null
+++ b/app-arch/lcab/lcab-1.0_beta12.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+inherit autotools
+
+MY_PV=${PV/_beta/b}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="CAB file creation tool"
+HOMEPAGE="http://ohnopub.net/lcab/"
+SRC_URI="ftp://mirror.ohnopub.net/mirror/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ sed -i "s:1.0b11:${MY_PV}:" mytypes.h || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ doman ${PN}.1
+}