summaryrefslogtreecommitdiff
path: root/app-arch/libdeflate/libdeflate-1.20.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-26 12:00:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-26 12:00:09 +0100
commitf300354de9fe5d997850456a9e1f400193e6544f (patch)
tree402fd6a7727db790bf57f683894052e8791d389e /app-arch/libdeflate/libdeflate-1.20.ebuild
parent5c42677148c717eb9f4673237db807f74740b4e9 (diff)
gentoo auto-resync : 26:08:2024 - 12:00:09HEADmaster
Diffstat (limited to 'app-arch/libdeflate/libdeflate-1.20.ebuild')
-rw-r--r--app-arch/libdeflate/libdeflate-1.20.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/app-arch/libdeflate/libdeflate-1.20.ebuild b/app-arch/libdeflate/libdeflate-1.20.ebuild
deleted file mode 100644
index 395b2234ceea..000000000000
--- a/app-arch/libdeflate/libdeflate-1.20.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 2019-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake-multilib
-
-DESCRIPTION="Heavily optimized DEFLATE/zlib/gzip (de)compression"
-HOMEPAGE="https://github.com/ebiggers/libdeflate"
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/ebiggers/libdeflate.git"
-else
- SRC_URI="https://github.com/ebiggers/libdeflate/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-# the zlib USE-flag enables support for zlib
-# the test USE-flag programs depend on sys-libs/zlib for comparison tests
-IUSE="+gzip +utils +zlib test"
-
-RESTRICT="
- !test? ( test )
-"
-
-REQUIRED_USE="
- utils? ( gzip )
-"
-
-DEPEND="
- test? ( sys-libs/zlib[${MULTILIB_USEDEP}] )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.19-make-gzip-tests-conditional.patch"
-)
-
-src_configure() {
- local mycmakeargs=(
- -DLIBDEFLATE_BUILD_SHARED_LIB="yes"
- -DLIBDEFLATE_BUILD_STATIC_LIB="no"
- -DLIBDEFLATE_USE_SHARED_LIB="yes"
-
- -DLIBDEFLATE_COMPRESSION_SUPPORT="yes"
- -DLIBDEFLATE_DECOMPRESSION_SUPPORT="yes"
-
- -DLIBDEFLATE_BUILD_GZIP="$(usex gzip "$(usex utils)" )"
- -DLIBDEFLATE_GZIP_SUPPORT="$(usex gzip)"
-
- -DLIBDEFLATE_ZLIB_SUPPORT="$(usex zlib)"
-
- -DLIBDEFLATE_BUILD_TESTS="$(usex test)"
- )
-
- cmake-multilib_src_configure
-}