summaryrefslogtreecommitdiff
path: root/app-arch/lzma
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-arch/lzma
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-arch/lzma')
-rw-r--r--app-arch/lzma/Manifest3
-rw-r--r--app-arch/lzma/lzma-9.20-r1.ebuild35
-rw-r--r--app-arch/lzma/metadata.xml8
3 files changed, 46 insertions, 0 deletions
diff --git a/app-arch/lzma/Manifest b/app-arch/lzma/Manifest
new file mode 100644
index 000000000000..3e0de361c3e9
--- /dev/null
+++ b/app-arch/lzma/Manifest
@@ -0,0 +1,3 @@
+DIST lzma-9.20.tar.bz2 534077 BLAKE2B c1be526d6fb9f68da10b654940a92420b6c708c7aefe213394cf1c7650b3d65c4f54d3ca0663e52be13aa9f996ff9cc87262fac8b76dd0654e839cefc073c374 SHA512 1c495530834107430a675fb48c006093edc301ec7a2c2f273efd62ff260f3056503bb2c3ddef63e82f5ff04b1347381055cf6cacd59eee9d451c4d841c13cd35
+EBUILD lzma-9.20-r1.ebuild 887 BLAKE2B 32ce4e9ca1d660403802f8d5275656acbcfc2e2ca9ff645ac24a00c09f55bf1df1f9dd164b7ac87de77dbf721141b32c3362797667196b944e2781c63c5303a9 SHA512 72bdd25f10cbf4944cf20aef08f5c19d7c16d65179ee99703138bc71524d6e38a64f1aad0443b298919299e1e4acbd1e7fd41cde0c9255ab11e871ba2859b0f4
+MISC metadata.xml 250 BLAKE2B e05a373f0ea02a1a107bb27632d2f6b87bb754d82a7a7c6f56b7bb6041a92a0bea6ef1a6353cd535f5f9d992b10cb68e402c4efa3189d7f65d2c9fc904a4610a SHA512 7bd753e69082bd70f8afe68f12584dd5ee18b9972c27c523570075d4d0168f3e3d8eb638da7ca08ab3969904e39ec2c76f4891fd649a26553abd4115a41b70bb
diff --git a/app-arch/lzma/lzma-9.20-r1.ebuild b/app-arch/lzma/lzma-9.20-r1.ebuild
new file mode 100644
index 000000000000..80cac224e6b3
--- /dev/null
+++ b/app-arch/lzma/lzma-9.20-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+MY_P="${PN}${PV//.}"
+DESCRIPTION="LZMA Stream Compressor from the SDK"
+HOMEPAGE="https://www.7-zip.org/sdk.html"
+SRC_URI="mirror://sourceforge/sevenzip/${MY_P}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~mips ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc"
+
+S=${WORKDIR}
+
+src_compile() {
+ cd CPP/7zip/Bundles/LzmaCon || die
+ emake -f makefile.gcc \
+ CXX="$(tc-getCXX) ${CXXFLAGS} ${CPPFLAGS}" \
+ CXX_C="$(tc-getCC) ${CFLAGS} ${CPPFLAGS}"
+}
+
+src_install() {
+ newbin CPP/7zip/Bundles/LzmaCon/lzma lzmacon || die
+ dodoc lzma.txt history.txt
+ use doc && dodoc 7zC.txt 7zFormat.txt Methods.txt
+}
+
+pkg_postinst() {
+ einfo "The lzma binary is now 'lzmacon' to avoid xz-utils conflicts #218459"
+}
diff --git a/app-arch/lzma/metadata.xml b/app-arch/lzma/metadata.xml
new file mode 100644
index 000000000000..86f4ac1ea62b
--- /dev/null
+++ b/app-arch/lzma/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="sourceforge">sevenzip</remote-id>
+ </upstream>
+</pkgmetadata>