summaryrefslogtreecommitdiff
path: root/app-arch/pack/pack-0.0.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-24 23:32:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-24 23:32:34 +0100
commit83c7eb1835fcfdf7072b953d23ab34f03c7e8ed6 (patch)
treed44aefcc259a6d52e3d3b0c9929f52aedd24d001 /app-arch/pack/pack-0.0.0.1.ebuild
parent7138219e3c9446bf981ff17f5609f42130bec414 (diff)
gentoo auto-resync : 24:09:2022 - 23:32:34
Diffstat (limited to 'app-arch/pack/pack-0.0.0.1.ebuild')
-rw-r--r--app-arch/pack/pack-0.0.0.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-arch/pack/pack-0.0.0.1.ebuild b/app-arch/pack/pack-0.0.0.1.ebuild
new file mode 100644
index 000000000000..e02651bdace9
--- /dev/null
+++ b/app-arch/pack/pack-0.0.0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit haskell-cabal
+
+EGIT_COMMIT="0bd29ccae2662ef9ae1fabe707d84e4f84b36d53"
+MY_P=${PN}-${EGIT_COMMIT}
+DESCRIPTION="Haskell implementation of pack compression from the early 1980s"
+HOMEPAGE="https://github.com/koalaman/pack/"
+SRC_URI="
+ https://github.com/koalaman/pack/archive/${EGIT_COMMIT}.tar.gz
+ -> ${MY_P}.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-lang/ghc:=
+"
+BDEPEND="
+ >=dev-haskell/cabal-1.10
+"
+
+CABAL_FILE=${S}/pack-compression.cabal
+
+src_prepare() {
+ sed -i -e '/base/s:&& <4.10::' "${CABAL_FILE}" || die
+ haskell-cabal_src_prepare
+ cabal-mksetup
+}