summaryrefslogtreecommitdiff
path: root/app-arch/patool
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-12 12:25:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-12 12:25:39 +0100
commit37bccfe5e76c5740c4ef5ba1179e9488d8404075 (patch)
treec0c962a2e83c1f38816a021ecd34c2e8c80db528 /app-arch/patool
parent496ef6155c315ac3628b472dc9b4146fa2684286 (diff)
gentoo auto-resync : 12:07:2024 - 12:25:38
Diffstat (limited to 'app-arch/patool')
-rw-r--r--app-arch/patool/Manifest2
-rw-r--r--app-arch/patool/patool-2.3.0.ebuild128
2 files changed, 130 insertions, 0 deletions
diff --git a/app-arch/patool/Manifest b/app-arch/patool/Manifest
index 81b49808c92f..7ade547f7aae 100644
--- a/app-arch/patool/Manifest
+++ b/app-arch/patool/Manifest
@@ -1,3 +1,5 @@
DIST patool-2.2.0.tar.gz 1995287 BLAKE2B ec7a188abfbfc2198e0171568324cb0e372a5629363aaeabfa404767f08062669028d6a9771e80370eb096677f3668da75923f7def7fbb4525f5ce7418cdf68a SHA512 eae774e7da2be13c7644038dc47457105caff7a51a9d3b99e38962dd26c0ace0129f1c0151c27766708ee9754049aec283873fd4a2e8647015a1a07acd48de60
+DIST patool-2.3.0.tar.gz 1996107 BLAKE2B 8fdb13eee3f60f136a93fad538d9f45b94a7aabe243e33fcd37da27d973a74dd8df8ac7f3daae8d0e8d70da4abb30889c9ea5d60f0de2953d539c316b1107b53 SHA512 0d6cad4b449706f2f5c012a40adf0dda3cbb654c4a7444cff31a755bb3bed8a5221fa4467879d97244922cbdc9789a7a0923d020bfb2e46bdd1345a9fb2f14c3
EBUILD patool-2.2.0.ebuild 2571 BLAKE2B a84d7ceaaa4ba19a51a0538ecd5faf499e5e293f26a4c0859c72bfbc7e6480849b57f65d54874845ef4ec8a43eb01f86438e9f492427202e59ae0603b1061be9 SHA512 12225db3e185ddd2dbb2927e79e2a8970c3612b31b1601f0d70d76f26e3cc3eaa896ee5248b88173183c4e5f27d760e491146f57271260248ddd68323bfd9e53
+EBUILD patool-2.3.0.ebuild 2554 BLAKE2B 841b4b85c155ce6e7b7e7de9026e65c68fc26e1f426323045738185860f73658d2f9a7db55b0bfec373573b9aec957889b5f081f7a5bd2994d1e9333c69a7b65 SHA512 eef6c743f84ace9db290d9e30b1b4303590faf44bfc35209c7812de3103b2169784927cd8a2ff15ef45ba8a3563b360a5c309b6379accbadc22ece3874dd09e9
MISC metadata.xml 539 BLAKE2B b19f1ad36967b42e152a23108851ad6eabcd7f44fd1faeeb4c345ff812b97d4b4079afc83653c1fd0dd005943a152cba44210132389e1ec956a434d24e97486d SHA512 b557ec32ca1211faa72e108a7f769f4ffb3a08075a4010aee2f9ced79a9f7f8c26f60bf26e2587d4a0cbb3cf6d52ea52d9102407ed548cdd41f53c67dd10d7bb
diff --git a/app-arch/patool/patool-2.3.0.ebuild b/app-arch/patool/patool-2.3.0.ebuild
new file mode 100644
index 000000000000..9fcc78d0b714
--- /dev/null
+++ b/app-arch/patool/patool-2.3.0.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Portable archive file manager"
+HOMEPAGE="https://wummel.github.io/patool/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ app-arch/arj
+ app-arch/bzip2
+ app-arch/bzip3
+ app-arch/cabextract
+ app-alternatives/cpio
+ app-arch/dpkg
+ app-arch/gzip
+ app-arch/lbzip2
+ app-arch/lcab
+ app-arch/lha
+ app-arch/libarchive
+ app-arch/lz4
+ app-arch/lzip
+ app-arch/lzop
+ app-arch/ncompress
+ app-arch/p7zip[rar]
+ app-arch/pbzip2
+ app-arch/pdlzip
+ app-arch/pigz
+ app-arch/plzip
+ app-arch/rpm
+ app-arch/rzip
+ app-arch/sharutils
+ app-arch/tar
+ app-arch/unace
+ app-arch/unadf
+ app-arch/unzip
+ app-arch/xdms
+ app-arch/xz-utils
+ app-arch/zip
+ app-arch/zopfli
+ app-arch/zpaq
+ app-arch/zstd
+ app-cdr/cdrtools
+ dev-libs/chmlib
+ media-libs/flac
+ media-sound/shorten
+ sys-apps/diffutils
+ sys-apps/file
+ sys-apps/grep
+ !elibc_musl? ( app-arch/rar )
+ !x86? (
+ app-arch/clzip
+ app-arch/lrzip
+ app-arch/unar
+ )
+ )
+"
+# Test dependencies which are packaged but can't be tested for various reasons.
+# app-arch/arc
+# app-arch/zoo
+# media-sound/mac
+
+# app-arch/rar is masked on musl
+# app-arch/clzip is unkeyworded on x86
+# app-arch/lrzip bug #916317 on x86
+# app-arch/unar is unkeyworded on x86
+
+# Unpackaged testable dependencies
+# archmage
+# genisoimage
+# lhasa
+# nomarch
+# pdzip2
+# py_{bz2,echo,gzip,tarfile,zipfile}
+# rpm2cpio
+# rzip
+# star
+# unalz
+# uncompress.real
+# 7zz ( app-arch/7zip:guru )
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+
+ einstalldocs
+ doman doc/patool.1
+}
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # zoo emits a non-zero exit status on a possibly false consistency check
+ # Zoo: WARNING: Archive header failed consistency check.
+ "tests/archives/test_zoo.py"
+ # Doesn't accept long arguments, such as those that files in ${S} would have.
+ # Too long argument: /var/tmp/portage/app-arch/patool-1.12_p20230424/work/patool-ab64562c8cdac34dfd69fcb6e30c8c0014282d11/tests/data/p.arc.foo
+ "tests/archives/test_arc.py"
+ # Error: 1002 (invalid input file)
+ "tests/archives/test_mac.py"
+ )
+
+ if use elibc_musl; then
+ EPYTEST_IGNORE+=(
+ "tests/archives/test_rar.py"
+ )
+ fi
+
+ if use x86; then
+ EPYTEST_IGNORE+=(
+ "tests/archives/test_clzip.py"
+ # bug #916317
+ "tests/archives/test_lrzip.py::TestLrzip::test_lrzip"
+ )
+ fi
+
+ epytest
+}