summaryrefslogtreecommitdiff
path: root/app-arch/pbzip2/pbzip2-1.1.13.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-arch/pbzip2/pbzip2-1.1.13.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-arch/pbzip2/pbzip2-1.1.13.ebuild')
-rw-r--r--app-arch/pbzip2/pbzip2-1.1.13.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-arch/pbzip2/pbzip2-1.1.13.ebuild b/app-arch/pbzip2/pbzip2-1.1.13.ebuild
new file mode 100644
index 000000000000..abf49d114075
--- /dev/null
+++ b/app-arch/pbzip2/pbzip2-1.1.13.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Parallel bzip2 (de)compressor using libbz2"
+HOMEPAGE="http://compression.ca/pbzip2/ https://launchpad.net/pbzip2"
+SRC_URI="https://launchpad.net/pbzip2/${PV:0:3}/${PV}/+download/${P}.tar.gz"
+
+LICENSE="BZIP2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="static symlink"
+
+LIB_DEPEND="app-arch/bzip2[static-libs(+)]"
+RDEPEND="
+ !static? ( ${LIB_DEPEND//\[static-libs(+)]} )
+ symlink? ( !app-arch/lbzip2[symlink] )"
+DEPEND="${RDEPEND}
+ static? ( ${LIB_DEPEND} )"
+
+src_prepare() {
+ # https://bugs.launchpad.net/pbzip2/+bug/1746369
+ sed -i 's:"PRIuMAX":" PRIuMAX ":g' *.cpp || die
+ epatch "${FILESDIR}"/${PN}-1.1.10-makefile.patch
+ tc-export CXX
+ use static && append-ldflags -static
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+ dodoc AUTHORS ChangeLog README
+
+ if use symlink ; then
+ local s
+ for s in bzip2 bunzip2 bzcat ; do
+ dosym pbzip2 /usr/bin/${s}
+ done
+ fi
+}