summaryrefslogtreecommitdiff
path: root/app-arch/star
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-arch/star
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-arch/star')
-rw-r--r--app-arch/star/Manifest3
-rw-r--r--app-arch/star/metadata.xml11
-rw-r--r--app-arch/star/star-1.5.3.ebuild99
3 files changed, 113 insertions, 0 deletions
diff --git a/app-arch/star/Manifest b/app-arch/star/Manifest
new file mode 100644
index 000000000000..af735dcccc39
--- /dev/null
+++ b/app-arch/star/Manifest
@@ -0,0 +1,3 @@
+DIST star-1.5.3.tar.bz2 889881 BLAKE2B d5d21a99d78c877d422bb6326ec0833d11c35dbe591ba1b892b267f811ae7f6108d9e34c14925b873a53b0f12c703f7c646012010d79d841e0e7be04a5c9dfed SHA512 622032a0e87f3df06ab1091af0af99d0362f478f70351cfe3d47195eec0fcc96f458fb6e50cae3531183984b1d390b598176ce008bcc5f29764795f66436efef
+EBUILD star-1.5.3.ebuild 2699 BLAKE2B 5b5bec4befa27d2a87e13c4d1a4d61681281736695cd9e5af3ecbee194de6b50f1ad5d59bd5219c76a50137aa9d00d2a990f0f8c142cf3e3e5a8c0c8ab3d1ab0 SHA512 457ea7ff0caba696702e0d754598d9e368e374db959a264a50742fa483b6325c3eb250a6044736df0ccd3adf0f15f6a46f75ba8fdb40404ebed3386f7ae73e4f
+MISC metadata.xml 350 BLAKE2B 9ca6ab6c8bcb830e9635e148dfc550ae71d785bd4e7f3620bc4a81e27dce3f9a7cb3ad5b2321ca0bdb7dae5082725ea75dfb73ed36e2507129c6937c7f3ef06f SHA512 2e9d3fb7c591893162b2518657d39d6c0a53e80b666b5aa4b307cc80bdb47a5c2f9f300abb42e99b8216be8f09ee407571ca39d2b5ea2dbdf427ba350db457bf
diff --git a/app-arch/star/metadata.xml b/app-arch/star/metadata.xml
new file mode 100644
index 000000000000..5e16a72b054f
--- /dev/null
+++ b/app-arch/star/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>shell-tools@gentoo.org</email>
+ <name>Gentoo Shell Tools Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">s-tar</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-arch/star/star-1.5.3.ebuild b/app-arch/star/star-1.5.3.ebuild
new file mode 100644
index 000000000000..f841e026ddc1
--- /dev/null
+++ b/app-arch/star/star-1.5.3.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="An enhanced (world's fastest) tar, as well as enhanced mt/rmt"
+HOMEPAGE="http://s-tar.sourceforge.net/"
+SRC_URI="mirror://sourceforge/s-tar/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1 CDDL-Schily"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="acl xattr"
+
+DEPEND="
+ acl? ( sys-apps/acl )
+ xattr? ( sys-apps/attr )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P/_alpha[0-9][0-9]}
+
+src_prepare() {
+ find -type f -exec chmod -c u+w '{}' + || die
+ sed \
+ -e "s:/opt/schily:${EPREFIX}/usr:g" \
+ -e 's:bin:root:g' \
+ -e "s:/usr/src/linux/include:${EPREFIX}/usr/include:" \
+ -i DEFAULTS/Defaults.linux || die
+
+ # Disable libacl autodependency (hacky build system, hacky fix...)
+ if use acl; then
+ sed \
+ -e 's:[$]ac_cv_header_sys_acl_h:disable acl:' \
+ -i "${S}/autoconf/configure" || die
+ fi
+
+ if use xattr; then
+ sed \
+ -e 's:[$]ac_cv_header_attr_xattr_h:disable xattr:' \
+ -i "${S}/autoconf/configure" || die
+ fi
+
+ # Create additional symlinks needed for some archs.
+ pushd "${S}/RULES" > /dev/null
+ local t
+ for t in ppc64 s390x ; do
+ ln -s i586-linux-cc.rul ${t}-linux-cc.rul || die
+ ln -s i586-linux-gcc.rul ${t}-linux-gcc.rul || die
+ done
+ popd > /dev/null
+}
+
+src_configure() { :; } #avoid ./configure run
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ COPTX="${CFLAGS}" \
+ CPPOPTX="${CPPFLAGS}" \
+ COPTGPROF= \
+ COPTOPT= \
+ LDOPTX="${LDFLAGS}"
+}
+
+src_install() {
+ # Joerg Schilling suggested to integrate star into the main OS using call:
+ # make INS_BASE=/usr DESTDIR="${D}" install
+
+ dobin \
+ star/OBJ/*-*-cc/star \
+ tartest/OBJ/*-*-cc/tartest \
+ star_sym/OBJ/*-*-cc/star_sym \
+ mt/OBJ/*-*-cc/smt
+
+ newsbin rmt/OBJ/*-*-cc/rmt rmt.star
+ newman rmt/rmt.1 rmt.star.1
+
+ # Note that we should never install gnutar, tar or rmt in this package.
+ # tar and rmt are provided by app-arch/tar. gnutar is not compatible with
+ # GNU tar and breakes compilation, or init scripts. bug #33119
+ dosym {star,/usr/bin/ustar}
+ dosym {star,/usr/bin/spax}
+ dosym {star,/usr/bin/scpio}
+ dosym {star,/usr/bin/suntar}
+
+ # match is needed to understand the pattern matcher, if you wondered why ;)
+ doman man/man1/match.1 tartest/tartest.1 \
+ star/{star.4,star.1,spax.1,scpio.1,suntar.1}
+
+ insinto /etc/default
+ newins star/star.dfl star
+ newins rmt/rmt.dfl rmt
+
+ dodoc star/{README.ACL,README.crash,README.largefiles,README.otherbugs} \
+ star/{README.pattern,README.pax,README.posix-2001,README,STARvsGNUTAR} \
+ rmt/default-rmt.sample TODO AN-* Changelog CONTRIBUTING
+}