summaryrefslogtreecommitdiff
path: root/app-arch/stenc/stenc-1.0.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /app-arch/stenc/stenc-1.0.8.ebuild
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'app-arch/stenc/stenc-1.0.8.ebuild')
-rw-r--r--app-arch/stenc/stenc-1.0.8.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-arch/stenc/stenc-1.0.8.ebuild b/app-arch/stenc/stenc-1.0.8.ebuild
new file mode 100644
index 000000000000..1f9c5860f701
--- /dev/null
+++ b/app-arch/stenc/stenc-1.0.8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/scsitape/stenc.git"
+ S="${WORKDIR}/${P}/src"
+else
+ SRC_URI="https://github.com/scsitape/stenc/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="SCSI Tape Encryption Manager enables AES support for LTO drives."
+HOMEPAGE="https://github.com/scsitape/stenc/"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}