summaryrefslogtreecommitdiff
path: root/app-arch/tarsync/tarsync-0.2.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /app-arch/tarsync/tarsync-0.2.1-r1.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'app-arch/tarsync/tarsync-0.2.1-r1.ebuild')
-rw-r--r--app-arch/tarsync/tarsync-0.2.1-r1.ebuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/app-arch/tarsync/tarsync-0.2.1-r1.ebuild b/app-arch/tarsync/tarsync-0.2.1-r1.ebuild
index c9db986bc6c6..f2048606800d 100644
--- a/app-arch/tarsync/tarsync-0.2.1-r1.ebuild
+++ b/app-arch/tarsync/tarsync-0.2.1-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Delta compression suite for using/generating binary patches"
HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
@@ -12,22 +12,22 @@ SRC_URI="mirror://gentoo/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~hppa ppc x86 ~amd64-linux"
-IUSE=""
DEPEND=">=dev-util/diffball-0.7"
RDEPEND="${DEPEND}"
-S=${WORKDIR}/${PN}
+S="${WORKDIR}/${PN}"
-pkg_setup() {
- tc-export CC
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-make.patch
+ "${FILESDIR}"/${P}-gcc5.patch
+)
-src_prepare() {
- epatch "${FILESDIR}"/${P}-make.patch
- epatch "${FILESDIR}"/${P}-gcc5.patch
+src_configure() {
+ tc-export CC
}
src_install() {
- dobin "${PN}" #make install doesn't support prefix
+ dobin tarsync #make install doesn't support prefix
+ einstalldocs
}