summaryrefslogtreecommitdiff
path: root/app-arch/unace/unace-2.5-r5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-31 15:47:53 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-10-31 15:47:53 +0000
commitd950fa39dbe16d164ed0cb8e3036fd5d0d896a4c (patch)
tree04f92d5d1070a7aedb970ce4539dc6d60253c4df /app-arch/unace/unace-2.5-r5.ebuild
parentbd7908c6630f38067350d396ac5d18c3cc2434a0 (diff)
gentoo resync : 31.10.2017
Diffstat (limited to 'app-arch/unace/unace-2.5-r5.ebuild')
-rw-r--r--app-arch/unace/unace-2.5-r5.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-arch/unace/unace-2.5-r5.ebuild b/app-arch/unace/unace-2.5-r5.ebuild
new file mode 100644
index 000000000000..a100ec59b45a
--- /dev/null
+++ b/app-arch/unace/unace-2.5-r5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+DEB_VER="9"
+DESCRIPTION="ACE unarchiver"
+HOMEPAGE="http://www.winace.com/"
+SRC_URI="mirror://debian/pool/non-free/u/unace-nonfree/unace-nonfree_${PV}.orig.tar.gz
+ mirror://debian/pool/non-free/u/unace-nonfree/unace-nonfree_${PV}-${DEB_VER}.debian.tar.xz"
+
+LICENSE="freedist"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~s390 ~x86 ~amd64-linux ~x86-linux ~sparc-solaris"
+IUSE=""
+
+PATCHES=( "${WORKDIR}"/debian/patches/ )
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dobin unace
+ doman "${WORKDIR}"/debian/manpage/unace.1
+}