summaryrefslogtreecommitdiff
path: root/app-arch/vimball/vimball-0.5.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-09 23:35:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-09 23:35:30 +0100
commit47d5e233005d470dbd431a280e64ce6073fc7149 (patch)
tree135efe53d72c541429f68d7ed82186f2b34fcdb6 /app-arch/vimball/vimball-0.5.1-r1.ebuild
parentbac9556f73da9ac333933778ce81c053bd989a26 (diff)
gentoo auto-resync : 09:04:2023 - 23:35:30
Diffstat (limited to 'app-arch/vimball/vimball-0.5.1-r1.ebuild')
-rw-r--r--app-arch/vimball/vimball-0.5.1-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-arch/vimball/vimball-0.5.1-r1.ebuild b/app-arch/vimball/vimball-0.5.1-r1.ebuild
new file mode 100644
index 000000000000..368e668cb296
--- /dev/null
+++ b/app-arch/vimball/vimball-0.5.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/radhermit/vimball.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ inherit pypi
+fi
+
+DESCRIPTION="A command-line vimball archive extractor"
+HOMEPAGE="
+ https://github.com/radhermit/vimball/
+ https://pypi.org/project/vimball/
+"
+
+LICENSE="MIT"
+SLOT="0"
+
+distutils_enable_tests pytest