summaryrefslogtreecommitdiff
path: root/app-arch/xarchiver
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-24 00:31:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-24 00:31:53 +0000
commit72e4c0bc86eea366d063d15b3d5611e8f82ffd05 (patch)
treebe4116935e605807f4a03de97c876e050718881a /app-arch/xarchiver
parentadd1c3acddd7a3f49fdb230135725463d2662921 (diff)
gentoo auto-resync : 24:03:2025 - 00:31:53
Diffstat (limited to 'app-arch/xarchiver')
-rw-r--r--app-arch/xarchiver/Manifest2
-rw-r--r--app-arch/xarchiver/xarchiver-0.5.4.25.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/app-arch/xarchiver/Manifest b/app-arch/xarchiver/Manifest
index 35ae692e2e5d..2b77ea007061 100644
--- a/app-arch/xarchiver/Manifest
+++ b/app-arch/xarchiver/Manifest
@@ -1,5 +1,7 @@
DIST xarchiver-0.5.4.23.tar.gz 1126908 BLAKE2B 09d2217aa77d553fd9f8436e1336f95160c366318b43ed22b9693f5dd510c59544d95f1cf643046ba443b44de84792a71d6eb115ad5bd04ab33e03c91e00afd4 SHA512 7459b14772205872de275c855c26a992a6a59e773cdaef25f95a44528baf1d1db7b1d1ef8540e0508babd35468f46c96db9610cc12746947ecccd9332bb69a71
DIST xarchiver-0.5.4.24.tar.gz 1164481 BLAKE2B 53260b62274684e76033a96c83039c16b017f96bcec88ec78dd27fffa8fb00e2e4487aa10c33eb6594606a6ffea5bcd4056b043db137e582a65e4e1875ed1f25 SHA512 8d49dc0ecbe0db1679cf0453ed18e5779832011a93dd185250fa631ec0e732e68a75390606dc498c3902a6f255f0649f1a509aed44645df8b3f676849e4d2b3a
+DIST xarchiver-0.5.4.25.tar.gz 1164484 BLAKE2B ba1ee8399bf69f394a3d1755cdf51e12189868860c7c20f8fd53023ec01a21233d6f590b2be417a74504fac437438704739515d2fb94701ec969808085350f32 SHA512 127f0c7993163d0e48180b23080686d82dd8c971f1108c5f80c704df55e65bdbaa750a6468f0de65bffe6f307d7b3b6d7b1635c3740eb20f37b780e60b8bf668
EBUILD xarchiver-0.5.4.23.ebuild 1199 BLAKE2B 78505f50b274fd2c91f1e3cebfa3ff03632cc853d9dd51fcd88964f61e352e856a54941302e065ff10d6ea82e853f6b47daa1033590721d4a8e0d58d22c35441 SHA512 faae8323f032b3e9e60c0e324d3539410a9da3a8ff4706452f9c3138251b98efbfcfea4dcf8b52be805d45a3f530285a09f96544976b56913b2821ceb4ddcf4b
EBUILD xarchiver-0.5.4.24.ebuild 1205 BLAKE2B 9ce51ff9cb01cd8ae1247becf45f2473eacfaf57462ba91a3158c3542b8fbe47365399f7d468d13ff4dabdfc7402b2716b46c84b574c6cd5c6234a2b5921679d SHA512 ba767f8cb9442121fdb01dc9b5c5ef894bc167de534058742d0eaf7214aa90aece7c9819071fda7c121223e1d415455654db4fed1687aa6eb0db63fb94bba91c
+EBUILD xarchiver-0.5.4.25.ebuild 1205 BLAKE2B 9ce51ff9cb01cd8ae1247becf45f2473eacfaf57462ba91a3158c3542b8fbe47365399f7d468d13ff4dabdfc7402b2716b46c84b574c6cd5c6234a2b5921679d SHA512 ba767f8cb9442121fdb01dc9b5c5ef894bc167de534058742d0eaf7214aa90aece7c9819071fda7c121223e1d415455654db4fed1687aa6eb0db63fb94bba91c
MISC metadata.xml 448 BLAKE2B 5eb8d55f09ade402a421e0a40bdcea04b72fb284c6a705c03be6454e7862253344d5c8e91adc37510759745eccfe68ccd4945192e7a24beae0ad881b04f68337 SHA512 240dc27cb546ec70d0b85db8d9b8c77a38ca4773389caaaba3bc52e9dc823803c330d5a83213c6ec6a6cf3a56ffb8eb09692c446df7af42f3ecf844cbd6b13a4
diff --git a/app-arch/xarchiver/xarchiver-0.5.4.25.ebuild b/app-arch/xarchiver/xarchiver-0.5.4.25.ebuild
new file mode 100644
index 000000000000..0bc2a0c8688b
--- /dev/null
+++ b/app-arch/xarchiver/xarchiver-0.5.4.25.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A GTK+ archive manager that can be used with Thunar"
+HOMEPAGE="https://github.com/ib/xarchiver/"
+SRC_URI="
+ https://github.com/ib/xarchiver/archive/${PV}.tar.gz -> ${P}.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+DEPEND="
+ >=dev-libs/glib-2:=
+ x11-libs/gtk+:3=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? (
+ app-text/docbook-xml-dtd
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxml2
+ dev-libs/libxslt
+ )
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable doc)
+ )
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+
+ elog "You need external programs for some formats, including:"
+ elog "7zip - app-arch/p7zip"
+ elog "arj - app-arch/arj"
+ elog "lha - app-arch/lha"
+ elog "lzop - app-arch/lzop"
+ elog "rar - app-arch/unrar app-arch/rar"
+ elog "zip - app-arch/unzip app-arch/zip"
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}