summaryrefslogtreecommitdiff
path: root/app-arch/xdms/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /app-arch/xdms/files
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'app-arch/xdms/files')
-rw-r--r--app-arch/xdms/files/xdms-1.3.2-dont-compress-man-pages.patch13
-rw-r--r--app-arch/xdms/files/xdms-1.3.2-fix-build-with-gcc-10.patch80
-rw-r--r--app-arch/xdms/files/xdms-1.3.2-respect-DESTDIR.patch22
3 files changed, 115 insertions, 0 deletions
diff --git a/app-arch/xdms/files/xdms-1.3.2-dont-compress-man-pages.patch b/app-arch/xdms/files/xdms-1.3.2-dont-compress-man-pages.patch
new file mode 100644
index 000000000000..3396b59a309c
--- /dev/null
+++ b/app-arch/xdms/files/xdms-1.3.2-dont-compress-man-pages.patch
@@ -0,0 +1,13 @@
+From: Sam James <sam@gentoo.org>
+Subject: [PATCH 2/2] Don't compress man pages
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -11,5 +11,4 @@ install: xdms
+ install xdms.txt COPYING ChangeLog.txt ${DESTDIR}{PREFIX}/share/doc/xdms-{VERSION}/
+ chmod og+rx ${DESTDIR}{PREFIX}/bin ${DESTDIR}{PREFIX}/bin/xdms
+ chmod -R og+rX ${DESTDIR}{PREFIX}/share/doc/xdms-{VERSION}
+- gzip < xdms.1 > xdms.1.gz
+- install xdms.1.gz ${DESTDIR}{PREFIX}/share/man/man1/
++ install xdms.1 ${DESTDIR}{PREFIX}/share/man/man1/
+--
+
diff --git a/app-arch/xdms/files/xdms-1.3.2-fix-build-with-gcc-10.patch b/app-arch/xdms/files/xdms-1.3.2-fix-build-with-gcc-10.patch
new file mode 100644
index 000000000000..dad00addead3
--- /dev/null
+++ b/app-arch/xdms/files/xdms-1.3.2-fix-build-with-gcc-10.patch
@@ -0,0 +1,80 @@
+https://sources.debian.org/patches/xdms/1.3.2-7/0002-Fix-build-with-gcc-10.patch/
+
+From: Jeff Law <law@redhat.com>
+Date: Sat, 9 May 2020 15:16:39 +0200
+Subject: Fix build with gcc-10
+--- a/src/u_deep.c
++++ b/src/u_deep.c
+@@ -17,9 +17,9 @@
+ #include "getbits.h"
+
+
+-INLINE USHORT DecodeChar(void);
+-INLINE USHORT DecodePosition(void);
+-INLINE void update(USHORT c);
++static INLINE USHORT DecodeChar(void);
++static INLINE USHORT DecodePosition(void);
++static INLINE void update(USHORT c);
+ static void reconst(void);
+
+
+@@ -98,7 +98,7 @@ USHORT Unpack_DEEP(UCHAR *in, UCHAR *out, USHORT origsize){
+
+
+
+-INLINE USHORT DecodeChar(void){
++static INLINE USHORT DecodeChar(void){
+ USHORT c;
+
+ c = son[R];
+@@ -117,7 +117,7 @@ INLINE USHORT DecodeChar(void){
+
+
+
+-INLINE USHORT DecodePosition(void){
++static INLINE USHORT DecodePosition(void){
+ USHORT i, j, c;
+
+ i = GETBITS(8); DROPBITS(8);
+@@ -171,7 +171,7 @@ static void reconst(void){
+
+ /* increment frequency of given code by one, and update tree */
+
+-INLINE void update(USHORT c){
++static INLINE void update(USHORT c){
+ USHORT i, j, k, l;
+
+ if (freq[R] == MAX_FREQ) {
+diff --git a/src/u_heavy.c b/src/u_heavy.c
+index fff93d3..8557b71 100644
+--- a/src/u_heavy.c
++++ b/src/u_heavy.c
+@@ -30,8 +30,8 @@ USHORT heavy_text_loc;
+
+ static USHORT read_tree_c(void);
+ static USHORT read_tree_p(void);
+-INLINE USHORT decode_c(void);
+-INLINE USHORT decode_p(void);
++static INLINE USHORT decode_c(void);
++static INLINE USHORT decode_p(void);
+
+
+
+@@ -74,7 +74,7 @@ USHORT Unpack_HEAVY(UCHAR *in, UCHAR *out, UCHAR flags, USHORT origsize){
+
+
+
+-INLINE USHORT decode_c(void){
++static INLINE USHORT decode_c(void){
+ USHORT i, j, m;
+
+ j = c_table[GETBITS(12)];
+@@ -96,7 +96,7 @@ INLINE USHORT decode_c(void){
+
+
+
+-INLINE USHORT decode_p(void){
++static INLINE USHORT decode_p(void){
+ USHORT i, j, m;
+
+ j = pt_table[GETBITS(8)];
diff --git a/app-arch/xdms/files/xdms-1.3.2-respect-DESTDIR.patch b/app-arch/xdms/files/xdms-1.3.2-respect-DESTDIR.patch
new file mode 100644
index 000000000000..3db969932084
--- /dev/null
+++ b/app-arch/xdms/files/xdms-1.3.2-respect-DESTDIR.patch
@@ -0,0 +1,22 @@
+From: Sam James <sam@gentoo.org>
+Subject: [PATCH 1/2] Respect DESTDIR
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -6,10 +6,10 @@ clean:
+ $(MAKE) -C src clean
+
+ install: xdms
+- mkdir -p {PREFIX}/bin {PREFIX}/share/doc/xdms-{VERSION} {PREFIX}/share/man/man1
+- install src/xdms {PREFIX}/bin/
+- install xdms.txt COPYING ChangeLog.txt {PREFIX}/share/doc/xdms-{VERSION}/
+- chmod og+rx {PREFIX}/bin {PREFIX}/bin/xdms
+- chmod -R og+rX {PREFIX}/share/doc/xdms-{VERSION}
++ mkdir -p ${DESTDIR}{PREFIX}/bin ${DESTDIR}{PREFIX}/share/doc/xdms-{VERSION} ${DESTDIR}{PREFIX}/share/man/man1
++ install src/xdms ${DESTDIR}{PREFIX}/bin/
++ install xdms.txt COPYING ChangeLog.txt ${DESTDIR}{PREFIX}/share/doc/xdms-{VERSION}/
++ chmod og+rx ${DESTDIR}{PREFIX}/bin ${DESTDIR}{PREFIX}/bin/xdms
++ chmod -R og+rX ${DESTDIR}{PREFIX}/share/doc/xdms-{VERSION}
+ gzip < xdms.1 > xdms.1.gz
+- install xdms.1.gz {PREFIX}/share/man/man1/
++ install xdms.1.gz ${DESTDIR}{PREFIX}/share/man/man1/
+--