summaryrefslogtreecommitdiff
path: root/app-arch/zopfli/zopfli-1.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-arch/zopfli/zopfli-1.0.2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-arch/zopfli/zopfli-1.0.2.ebuild')
-rw-r--r--app-arch/zopfli/zopfli-1.0.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-arch/zopfli/zopfli-1.0.2.ebuild b/app-arch/zopfli/zopfli-1.0.2.ebuild
new file mode 100644
index 000000000000..9cedbfeb2e43
--- /dev/null
+++ b/app-arch/zopfli/zopfli-1.0.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Very good, but slow, deflate or zlib compression"
+HOMEPAGE="https://github.com/google/zopfli/"
+SRC_URI="https://github.com/google/zopfli/archive/${P}.tar.gz"
+
+S="${WORKDIR}/${PN}-${P}"
+
+LICENSE="Apache-2.0"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DOCS=( CONTRIBUTORS README README.zopflipng )
+
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
+
+# zopflipng statically links an exact version of LodePNG (https://github.com/lvandeve/lodepng)
+
+src_prepare() {
+ default
+ tc-export CC CXX
+}
+
+# The Makefile has no install phase
+src_install() {
+ dolib.so libzopfli.so*
+ doheader src/zopfli/zopfli.h
+
+ dobin ${PN}
+
+ # This version was erroneously not bumped to match ${PV}
+ dolib.so libzopflipng.so*
+ doheader src/zopflipng/zopflipng_lib.h
+
+ dobin zopflipng
+}