summaryrefslogtreecommitdiff
path: root/app-arch/zpaq/zpaq-7.15.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-arch/zpaq/zpaq-7.15.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-arch/zpaq/zpaq-7.15.ebuild')
-rw-r--r--app-arch/zpaq/zpaq-7.15.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-arch/zpaq/zpaq-7.15.ebuild b/app-arch/zpaq/zpaq-7.15.ebuild
new file mode 100644
index 000000000000..e4c812dd9a58
--- /dev/null
+++ b/app-arch/zpaq/zpaq-7.15.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic pax-utils toolchain-funcs
+
+MY_P=${PN}${PV/./}
+DESCRIPTION="Journaling incremental deduplicating archiving compressor"
+HOMEPAGE="http://mattmahoney.net/dc/zpaq.html"
+SRC_URI="http://mattmahoney.net/dc/${MY_P}.zip"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +jit"
+
+# perl for pod2man
+DEPEND="
+ app-arch/unzip
+ dev-lang/perl"
+
+S=${WORKDIR}
+
+src_compile() {
+ use debug || append-cppflags -DNDEBUG
+ use jit || append-cppflags -DNOJIT
+ emake CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS}"
+}
+
+src_test() {
+ use jit && pax-mark m zpaq
+ default
+}
+
+src_install() {
+ emake install PREFIX="${ED%/}"/usr
+ use jit && pax-mark m "${ED%/}"/usr/bin/zpaq
+ einstalldocs
+}
+
+pkg_postinst() {
+ if ! has_version app-arch/zpaq-extras; then
+ elog "You may also want to install app-arch/zpaq-extras package which provides"
+ elog "few additional configs and preprocessors for use with zpaq."
+ fi
+}