summaryrefslogtreecommitdiff
path: root/app-arch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-13 00:01:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-13 00:01:18 +0100
commita25cc082a26782e5d39ded4559c91ff11bc3c299 (patch)
tree6cd0802dd248058d540f1f5f472c5df98216f154 /app-arch
parentd72a987a342949e200b5e9decbd71f246da53788 (diff)
gentoo auto-resync : 13:05:2024 - 00:01:18
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/Manifest.gzbin18253 -> 18256 bytes
-rw-r--r--app-arch/cfv/Manifest4
-rw-r--r--app-arch/cfv/cfv-3.0.0.ebuild11
-rw-r--r--app-arch/cfv/files/cfv-3.0.0-fix-removed-assertequal.patch39
-rw-r--r--app-arch/cfv/files/cfv-3.0.0-fix-removed-imp.patch39
5 files changed, 90 insertions, 3 deletions
diff --git a/app-arch/Manifest.gz b/app-arch/Manifest.gz
index 51be9959ed42..31431c8f2f9e 100644
--- a/app-arch/Manifest.gz
+++ b/app-arch/Manifest.gz
Binary files differ
diff --git a/app-arch/cfv/Manifest b/app-arch/cfv/Manifest
index 8a13c34c6750..9c504c26a9ce 100644
--- a/app-arch/cfv/Manifest
+++ b/app-arch/cfv/Manifest
@@ -1,3 +1,5 @@
+AUX cfv-3.0.0-fix-removed-assertequal.patch 1685 BLAKE2B 57448c6fe9ea46de5bb21ddfa58ee89e562cd8aed414e85a9195be5c9eb6cb089c9dd7a6d25d42cf522eae29a357718d78ebcdf21e17deb53d353dfab7b8a2b9 SHA512 82c843e4df3bc16dd59c08a937a7118b528aa44d0b5efcd69a6732c4ab3111d71c1a811e26045599fcc937376a16acd1d40b73aea23a55bb56297d1482f3adcf
+AUX cfv-3.0.0-fix-removed-imp.patch 1463 BLAKE2B 25b960a6df1e03b4397759d85078408ef7c38e3c80b41de1f4c5e2939ee3b25c4b2541093ccb2b03a0fb53dbfa36862c3c669a2f175e54a243e8ce667d2a7476 SHA512 4fd662500afb205ba68868ef1ea1454a26f7aa4e68240c3e6b5be7abdee51871ab12f7eeca942115ff18bb6a18a341d60b9b84f90444bc18b46cb6209da688b7
DIST cfv-3.0.0.gh.tar.gz 91600 BLAKE2B 5a0d53a2b75973967ef976ce55d5262f71af97a8d7c64e8ea94ed9d66fd12778e10321e82bdbc4b8037df3f1a9c9c817694a7cd5e60615fc903127df9057b04f SHA512 9a44bf20f0a4f48a93631353d0b0ab79ea15d19f1da5492296dd4bd4e6208d3f0d71e957165e31d07b5faa7fc75122f0ae5ddbd8d54b9c6b633c43695b362640
-EBUILD cfv-3.0.0.ebuild 1205 BLAKE2B 10d049170b71bbe789a984caa8c449eb377385a2b1ef47290aef823386cde688434ecafe25f7c4812666713ca882605b8f82ec2e280f693c33a55ea5749a5576 SHA512 5e59aedfc6c4573c1a7569c43ed9b5c857016236100a825fcb90cf733c1eb58de6ac5e3dafa7f4ac50d44924805ca1b53524c06a58e91453b48f511b07e7cd6e
+EBUILD cfv-3.0.0.ebuild 1463 BLAKE2B a27a1762e136a740a9aeda75b69ee3d009daacd5391d4d54642c16c15cb9776d5c4cbfe104242b0e9bb956c5ce4436cca1b7c87ec36ee110dca308d45e447fcb SHA512 4b18f197ca3e7039daf8befd4c3af1887c18d52de5f9ef2dc2dde7cb521517a5cb06847e5cb14207160069f11d84b615787fa60895a963a3a257051526fe6853
MISC metadata.xml 752 BLAKE2B ad109bc840ed5d4b581fa93ed023eb489b2e410d6cfef41756680ae64c6ffb2a1ee4e8a979909d7584844bb8639d26374c00840864ffe380f0446226ab45f63f SHA512 6803dc7d2b3d65cf1586d6d4153280f2f672aa4be914ab80bd693a64282102a3bc59ad213b39830b7421f1764f912920e96cd975cc1929d1878452c87f12ba88
diff --git a/app-arch/cfv/cfv-3.0.0.ebuild b/app-arch/cfv/cfv-3.0.0.ebuild
index 02f12d0e670c..239956198afc 100644
--- a/app-arch/cfv/cfv-3.0.0.ebuild
+++ b/app-arch/cfv/cfv-3.0.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
# Tests fail with pypy3 as of PyPy 7.3.9 / Python 3.9.12
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 optfeature
@@ -26,6 +26,13 @@ BDEPEND="
)
"
+PATCHES=(
+ # Backported from https://github.com/cfv-project/cfv/commit/5259bcbe3434c6974f7a65cc435dd0b4cfc3f864
+ "${FILESDIR}/${P}-fix-removed-assertequal.patch"
+ # See https://github.com/cfv-project/cfv/pull/53
+ "${FILESDIR}/${P}-fix-removed-imp.patch"
+)
+
python_prepare_all() {
# Remove upstream's attempt to install the man page
sed -i '/\sdata_files=/d' setup.py || die
diff --git a/app-arch/cfv/files/cfv-3.0.0-fix-removed-assertequal.patch b/app-arch/cfv/files/cfv-3.0.0-fix-removed-assertequal.patch
new file mode 100644
index 000000000000..aa7820d03a92
--- /dev/null
+++ b/app-arch/cfv/files/cfv-3.0.0-fix-removed-assertequal.patch
@@ -0,0 +1,39 @@
+commit 5259bcbe3434c6974f7a65cc435dd0b4cfc3f864
+Author: Louis Sautier <sautier.louis@gmail.com>
+Date: Tue Nov 1 15:48:21 2022 +0100
+
+ tests: use assertEqual instead of assertEquals
+
+ The latter is deprecated and causes warnings when running tests.
+
+--- a/test/test_caching.py
++++ b/test/test_caching.py
+@@ -136,18 +136,18 @@ class RelPathKeyTest(RelTestCase):
+ self.mkfile('aAaA/Aaa2', '2')
+ self.mkfile('aAaA/AAa2', '3')
+
+- self.assertEquals(a1, cache.nocase_findfile(self.mkpath('aaAA/aaa1')))
++ self.assertEqual(a1, cache.nocase_findfile(self.mkpath('aaAA/aaa1')))
+ with self.assertRaises(IOError) as cm:
+ cache.nocase_findfile(self.mkpath('aaAb/aaa1'))
+- self.assertEquals(errno.ENOENT, cm.exception.errno)
++ self.assertEqual(errno.ENOENT, cm.exception.errno)
+
+ with self.assertRaises(IOError) as cm:
+ cache.nocase_findfile(self.mkpath('aaAA/aab1'))
+- self.assertEquals(errno.ENOENT, cm.exception.errno)
++ self.assertEqual(errno.ENOENT, cm.exception.errno)
+
+ with self.assertRaises(IOError) as cm:
+ cache.nocase_findfile(self.mkpath('aaAA/aaa2'))
+- self.assertEquals(errno.EEXIST, cm.exception.errno)
++ self.assertEqual(errno.EEXIST, cm.exception.errno)
+
+ def test_nocase_findfile_parent(self):
+ cache = FileInfoCache()
+@@ -159,4 +159,4 @@ class RelPathKeyTest(RelTestCase):
+ # one.
+ with self.assertRaises(IOError) as cm:
+ cache.nocase_findfile(self.mkpath('aaAA/aaa2'))
+- self.assertEquals(errno.EEXIST, cm.exception.errno)
++ self.assertEqual(errno.EEXIST, cm.exception.errno)
diff --git a/app-arch/cfv/files/cfv-3.0.0-fix-removed-imp.patch b/app-arch/cfv/files/cfv-3.0.0-fix-removed-imp.patch
new file mode 100644
index 000000000000..d4fa6e9aeb29
--- /dev/null
+++ b/app-arch/cfv/files/cfv-3.0.0-fix-removed-imp.patch
@@ -0,0 +1,39 @@
+commit ecf720058f63930d53075584a59cf42e035347eb
+Author: Louis Sautier <sautier.louis@gmail.com>
+Date: Sun May 12 15:44:26 2024 +0200
+
+ Fix tests for Python 3.12: remove "imp", fixes #21, #44
+
+ The "imp" module was removed in Python 3.12.
+ The replacement functions were added in Python 3.5, see
+ https://docs.python.org/3/library/importlib.html#importlib.util.spec_from_file_location
+ https://docs.python.org/3/library/importlib.html#importlib.util.module_from_spec
+
+--- a/test/cfvtest.py
++++ b/test/cfvtest.py
+@@ -23,8 +23,8 @@ from builtins import map
+ from builtins import object
+
+ import fnmatch
+-import imp
+ import importlib
++import importlib.util
+ import os
+ import shlex
+ import sys
+@@ -201,8 +201,14 @@ def setcfv(fn=None, internal=None):
+ cfv_compiled = compile(_cfv_code, cfvfn, 'exec')
+
+ with open(cfvfn, 'rt') as f:
++ # For spec_from_file_location to accept a file without the .py suffix ("cfv")
++ importlib.machinery.SOURCE_SUFFIXES.append('')
++ spec = importlib.util.spec_from_file_location('cfvwrapper', cfvfn)
++ module = importlib.util.module_from_spec(spec)
+ # This is so that the sys.path modification of the wrapper (if it has one) will be executed..
+- imp.load_source('cfvwrapper', cfvfn, f)
++ spec.loader.exec_module(module)
++ # Restore SOURCE_SUFFIXES to its default value
++ importlib.machinery.SOURCE_SUFFIXES.pop()
+
+ get_version_flags()
+