summaryrefslogtreecommitdiff
path: root/app-arch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-23 08:52:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-23 08:52:39 +0100
commitc9aaa2ff911ee95adca22bcd9264e8ecfa3d5149 (patch)
tree32153e53b9929840fafd6a0bf95110df4c2885df /app-arch
parentbc8e1f28a81cb6ef9bc3fd1103842690c4320ce4 (diff)
gentoo auto-resync : 23:07:2023 - 08:52:38
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/Manifest.gzbin17412 -> 17412 bytes
-rw-r--r--app-arch/dump/Manifest2
-rw-r--r--app-arch/dump/dump-0.4.47-r3.ebuild100
-rw-r--r--app-arch/dump/files/dump-fix-incompatible-pointer-to-integer-conversion.patch25
4 files changed, 127 insertions, 0 deletions
diff --git a/app-arch/Manifest.gz b/app-arch/Manifest.gz
index f06e48388755..5f2423bb98f5 100644
--- a/app-arch/Manifest.gz
+++ b/app-arch/Manifest.gz
Binary files differ
diff --git a/app-arch/dump/Manifest b/app-arch/dump/Manifest
index 0cb19a025302..2216f8042b58 100644
--- a/app-arch/dump/Manifest
+++ b/app-arch/dump/Manifest
@@ -1,4 +1,6 @@
+AUX dump-fix-incompatible-pointer-to-integer-conversion.patch 697 BLAKE2B 1421bcef6686762a63843ded51ca88c7c9f5513968c6a828073629ec6bd81e610c4c1a2ab0b60fb26fdd13a5e65ce255dd2116fbd8eefe63eae840e7c09ab94f SHA512 8af857045c9d364f05121b6ed284e45a307185e0360c01510276e91e2124157a0f000311522a7e0d03ea7453b15bc9ce87887ce027701ce5eb72fbd33488d2ec
DIST dump-0.4b47.tar.gz 583380 BLAKE2B a5a6c507fc67451e6ce5117b28b9e97e45783059358c357e1f6d4b268437c8340f13e0d77e97631112824eca8205c49d206a8a7904bc3e00b1f0d5abb31418f7 SHA512 e9c567fe2ffad196b9657c551d83f7607758f3704cad6cb407514bbe2bc765c16968997dc3a5bc92b9eb5900fa5bd6e7cebc92c81afff53339fca92891a5259d
EBUILD dump-0.4.47-r1.ebuild 2171 BLAKE2B 45518c50773251da809311f41f4c0245660e023ffbf54b0a985d47e5668a57bfe66b73362e7244e2ba4a139034aa32aa754a0cd6a18d1c661b74ee459c69086d SHA512 e9e0a48ac2e2b30b243cc134543be272975dc8309ba8f2389ba6897b1c76a03801e22af11db2c064aa14b6c5d90869624f28549374d5659568d840dd894fa802
EBUILD dump-0.4.47-r2.ebuild 2423 BLAKE2B 6ecac7f91fb600be878c96242936fb151142fde140043e1c36aaadd1fd5db087ba2f3359e6f5ae21068ca6d388af88c483dddc49d8dcbb63a38e0a8524cba627 SHA512 bd16f6f9224a6b4b801775e1f6c0f6e4d126ef50f69989b2526c62f4833ea3c3890ad1a0342853a75102291c7e67f3254e4c44073846a7b2e21cf72fd4b9d91c
+EBUILD dump-0.4.47-r3.ebuild 2510 BLAKE2B c5efb7b7d8dc060069aff474f0e918504eff87c31a3a8de5c2a6860f82d44ad9458a7a91d97911e866b60edc6a0365d7f130fb294179805a1c3fe3c5280aa982 SHA512 bd80307d2a67cbd4fda7a0e77784420ae3f46f36ea6f0db18c490c233a3b7077116fc1323876b077aed9cb844c79308625aaea36bb5ff6adbbeb60b14a412d9e
MISC metadata.xml 443 BLAKE2B a993a4c9e17125bd2da2e0002c55443402e0873613f37f0c97ea62ea12ae3b97c6364546e8a06b539cd98df9edcc750daa2f99c2696fc78c06870e21df5b6e0f SHA512 5aca723c5ae7925c19f8f2c4839d560b4859691b25b646bec1fba0a9e98fe5aef88ee718f16c7095d046d3667052d09a40bbbb6c35bda8d7c73fea8af8ea8439
diff --git a/app-arch/dump/dump-0.4.47-r3.ebuild b/app-arch/dump/dump-0.4.47-r3.ebuild
new file mode 100644
index 000000000000..c4d086432c12
--- /dev/null
+++ b/app-arch/dump/dump-0.4.47-r3.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit readme.gentoo-r1
+
+MY_P="${PN}-$(ver_rs 2 b)"
+
+DESCRIPTION="Dump/restore ext2fs backup utilities"
+HOMEPAGE="https://dump.sourceforge.io/"
+SRC_URI="mirror://sourceforge/dump/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+# We keep uuid USE flag default dsiabled for this version. Don't forget
+# to default enable it for later versions as this is the upstream default.
+IUSE="bzip2 debug ermt lzo readline selinux sqlite ssl static test uuid zlib"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="
+ ermt? ( ssl )
+ ssl? ( zlib )
+ test? ( sqlite? ( uuid ) )"
+
+RDEPEND="
+ >=sys-fs/e2fsprogs-1.27:=
+ sys-apps/util-linux
+ bzip2? (
+ app-arch/bzip2:=
+ static? ( app-arch/bzip2[static-libs] )
+ )
+ zlib? ( >=sys-libs/zlib-1.1.4:= )
+ lzo? (
+ dev-libs/lzo:2=
+ static? ( dev-libs/lzo:2[static-libs] )
+ )
+ sqlite? ( dev-db/sqlite:3= )
+ ermt? ( dev-libs/openssl:0= )
+ ssl? ( dev-libs/openssl:0= )
+ readline? (
+ sys-libs/readline:0=
+ sys-libs/ncurses:=
+ static? ( sys-libs/ncurses:=[static-libs] )
+ )"
+DEPEND="${RDEPEND}
+ virtual/os-headers"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-fix-incompatible-pointer-to-integer-conversion.patch
+)
+
+src_configure() {
+ local myeconfargs=(
+ --with-dumpdatespath=/etc/dumpdates
+ --with-rmtpath='$(sbindir)/rmt'
+ --enable-blkid
+ $(use_enable bzip2)
+ $(use_enable debug)
+ $(use_enable ermt)
+ $(use_enable lzo)
+ $(use_enable readline)
+ $(use_enable selinux)
+ $(use_enable sqlite)
+ $(use_enable ssl)
+ $(use_enable static static-progs)
+ $(use_enable uuid)
+ $(use_enable zlib)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ mv "${ED}"/usr/sbin/{,dump-}rmt || die
+ mv "${ED}"/usr/share/man/man8/{,dump-}rmt.8 || die
+ use ermt && newsbin rmt/ermt dump-ermt
+
+ dodoc KNOWNBUGS MAINTAINERS REPORTING-BUGS
+ dodoc -r examples
+
+ # Don't install pre-compressed files
+ gunzip "${ED}"/usr/share/doc/${PF}/examples/cron_dump_to_disk/backupskel.tar.gz \
+ || die
+
+ local DOC_CONTENTS="dump has serious bugs
+ (see https://sourceforge.net/p/dump/bugs/162/ and
+ https://sourceforge.net/p/dump/bugs/174/). This tool should only
+ be used for restoring old backups, not for creating new ones.
+ \n\n${CATEGORY}/${PN} installs 'rmt' as 'dump-rmt'.
+ This is to avoid conflicts with app-arch/tar 'rmt'."
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/app-arch/dump/files/dump-fix-incompatible-pointer-to-integer-conversion.patch b/app-arch/dump/files/dump-fix-incompatible-pointer-to-integer-conversion.patch
new file mode 100644
index 000000000000..220e37bb7f57
--- /dev/null
+++ b/app-arch/dump/files/dump-fix-incompatible-pointer-to-integer-conversion.patch
@@ -0,0 +1,25 @@
+From: listout <listout@protonmail.com>
+Date: Mon, 17 Apr 2023 12:36:40 +0530
+Subject: [PATCH] Fix incompatible pointer to integer conversion
+
+transformation_null was initializing one of it's elements with NULL
+which is zero type casted to void. Hence, instead of initializing with
+NULL, now we are initializing that element with zero.
+
+Refer: https://bugs.gentoo.org/874675
+
+Signed-off-by: listout <listout@protonmail.com>
+--- a/common/transformation_null.c
++++ b/common/transformation_null.c
+@@ -81,7 +81,7 @@ null_decompress(Transformation *xform, struct tapebuf *tpbin, unsigned long *des
+ Transformation transformation_null =
+ {
+ 0,
+- NULL,
++ 0,
+ "null",
+ 0,
+ &null_initialize,
+--
+2.39.2
+