summaryrefslogtreecommitdiff
path: root/app-backup/borgmatic
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /app-backup/borgmatic
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'app-backup/borgmatic')
-rw-r--r--app-backup/borgmatic/Manifest2
-rw-r--r--app-backup/borgmatic/borgmatic-1.5.1-r2.ebuild (renamed from app-backup/borgmatic/borgmatic-1.5.1.ebuild)39
2 files changed, 25 insertions, 16 deletions
diff --git a/app-backup/borgmatic/Manifest b/app-backup/borgmatic/Manifest
index eb887c25b095..49317bdae8ad 100644
--- a/app-backup/borgmatic/Manifest
+++ b/app-backup/borgmatic/Manifest
@@ -2,5 +2,5 @@ AUX borgmatic-1.5.1-no_test_coverage.patch 284 BLAKE2B 91e041cb2d3d15b65c47075b0
AUX borgmatic-1.5.1-systemd_service_bin_path.patch 446 BLAKE2B bad832573f35e832e5a111a12d6c61cf2e2b1111e91252923e841ae5ec6661ed4f1c4d1e4cc94fe31887d8ee0b2a54aac7d79f8bd0e6f27a2e89f1ff0484c091 SHA512 299791d5079522270954a6742669f3031c0d6164ad7037387dad7f7dccebbe20b83f21f1e30ee61915c2703a370ba9987ab66989c4a99c1706ddf2b17bc2c718
DIST borgmatic-1.5.1.tar.gz 67401 BLAKE2B c11f4b9f9acc7d7bf4e482953968dbaabc33f1513ec8f20868518bca22ffcafee90569c06ec603be919d47d724dd4a3a904e44fbb40c2309d8cb78e9277b5cc7 SHA512 9ded9bd5d6db866d196fedee88737f3d3eef6cb0e61c5f55ac543602c4429adcb57608d7f6c798edfd6ac1ecd14aadd9a88fdf94ef1f0eab4c26a9d2a29c5e38
EBUILD borgmatic-1.5.1-r1.ebuild 1873 BLAKE2B f55f268e70e90a7ccdedfd03ff4a3577adbca5a61ad60db4a4f40089dbfc35b2b56581b042609f7a9c662d8c7ad31b4bf8426aa2a83deefeb6028db491bd7146 SHA512 e20d608e96ea7e04567d680a1332842b21361833f206a7cac5c352861c02d96a84505d302f0c17c40a28ba4dead9b1e1cb7b9e7248bed9543c88e6dda9a4cae1
-EBUILD borgmatic-1.5.1.ebuild 1715 BLAKE2B b192f98ec20435f2d9e6e4e2dee76d5f2819b2aba661cebde5fb2223e092e22082a32925336d023ff6460edcb891e128c5117a1770c305ce430d0c727d9f570e SHA512 76b841403a2ca739ec65952e0974962f12d0e912e9b8e417ff7a5c27519827ebf154a09cfc5ec15fbc6133a25454e555a11cadc07c0be15d8b86aa00ccc307e2
+EBUILD borgmatic-1.5.1-r2.ebuild 2139 BLAKE2B e24c54b69913fda078ca2c1233e92307d72c254168e1dc47075a23bd38902c53e6330ff848d5be403522944dee313c0d8754ebb1ae22f707e7b455acc21549b7 SHA512 758dfe7f7d9de9fbdb30839ff170716f4f4a30f10801027c4bc7bca12bfa79eecdaf7eb4fdbc0ca6a1d512fd6731d62e27a8bbe6de6ed878fe61992b731ed3e9
MISC metadata.xml 365 BLAKE2B 6fceb22a831c0ee0669e3545737da7a6fe778e9b188fba0c72f8e70988404ad444b2b75cd7e6001012cd2226d5f6f7a7096b3f837de905e559e94badf649d412 SHA512 72be8c3e4d69e9c33307d20b3ec2b05b134787fde7e015fa70f0dbea365163f235f21490500d68fe19b771528f813cf3257d1df175d5d009f6e9414ba5ea4db1
diff --git a/app-backup/borgmatic/borgmatic-1.5.1.ebuild b/app-backup/borgmatic/borgmatic-1.5.1-r2.ebuild
index 754e0f063c96..02359afde23e 100644
--- a/app-backup/borgmatic/borgmatic-1.5.1.ebuild
+++ b/app-backup/borgmatic/borgmatic-1.5.1-r2.ebuild
@@ -4,9 +4,10 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7} )
-
+DISTUTILS_SINGLE_IMPL=1
DISTUTILS_USE_SETUPTOOLS="rdepend"
-inherit distutils-r1
+
+inherit distutils-r1 systemd
DESCRIPTION="Automatically create, prune and verify backups with borgbackup"
HOMEPAGE="https://torsion.org/borgmatic/"
@@ -16,19 +17,23 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
-DEPEND="${PYTHON_DEPS}
- dev-python/colorama[${PYTHON_USEDEP}]
- >=dev-python/pykwalify-1.6.0[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- <dev-python/ruamel-yaml-0.17.0"[${PYTHON_USEDEP}]
-RDEPEND="${DEPEND}
- app-backup/borgbackup"
-BDEPEND="test? (
- ${DEPEND}
- dev-python/flexmock[${PYTHON_USEDEP}]
+# borg is called as an external tool, hence no pythonic stuff
+RDEPEND="app-backup/borgbackup
+ $(python_gen_cond_dep '
+ dev-python/colorama[${PYTHON_USEDEP}]
+ >=dev-python/pykwalify-1.6.0[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ <dev-python/ruamel-yaml-0.17.0[${PYTHON_USEDEP}]
+ ')"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/flexmock[${PYTHON_USEDEP}]
+ ')
)"
PATCHES=(
+ "${FILESDIR}"/${PN}-1.5.1-systemd_service_bin_path.patch
"${FILESDIR}"/${PN}-1.5.1-no_test_coverage.patch
)
@@ -39,16 +44,18 @@ src_prepare() {
# Unlike the other two test files in integration/commands, which use the
# relevant modules' respective APIs, test_borgmatic.py tries to call the
- # 'borgmatic' executable - which has not even been created by now.
- # Seeing as the only test run from this file as of 2020-03-25 is the
+ # 'borgmatic' executable - which by the time we execute src_test will
+ # not have been created yet. distutils_install_for_testing would likely
+ # take care of this - but between the aforementioned behaviour inconsistency
+ # and the fact the only test run from this file as of version 1.5.1 is the
# parsing of contents of 'borgmatic --version', just skip it for now.
rm -f "${S}"/tests/integration/commands/test_borgmatic.py
}
src_install() {
distutils-r1_src_install
+ systemd_dounit sample/systemd/borgmatic.{service,timer}
keepdir /etc/borgmatic
- # TODO: install systemd units (and explain them in postinst); need patching
}
pkg_postinst() {
@@ -59,4 +66,6 @@ pkg_postinst() {
elog "To upgrade your configuration file to the current version, run:"
elog " upgrade-borgmatic-config"
fi
+ elog
+ elog "Systemd users wishing to periodically run borgmatic can use the provided timer and service units."
}