summaryrefslogtreecommitdiff
path: root/app-backup/borgweb/borgweb-0.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-07 11:42:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-07 11:42:03 +0100
commitf70601e0934acd62f6c5d06c5ede4cc607179514 (patch)
tree0b337390375de04b950fc4b45edc0f895a4701a4 /app-backup/borgweb/borgweb-0.3.0.ebuild
parentb2be182d49eea46686b5cf2680d457df61e89dc4 (diff)
gentoo resync : 07.07.2018
Diffstat (limited to 'app-backup/borgweb/borgweb-0.3.0.ebuild')
-rw-r--r--app-backup/borgweb/borgweb-0.3.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/app-backup/borgweb/borgweb-0.3.0.ebuild b/app-backup/borgweb/borgweb-0.3.0.ebuild
new file mode 100644
index 000000000000..557cdea733a2
--- /dev/null
+++ b/app-backup/borgweb/borgweb-0.3.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Browser-based user interface for BorgBackup"
+HOMEPAGE="https://pypi.org/project/borgweb/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="app-backup/borgbackup[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]"