summaryrefslogtreecommitdiff
path: root/app-backup/btrbk/btrbk-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-13 21:03:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-13 21:03:07 +0100
commit8fbd420dce8836e6503b162092e07b6a77a89f1d (patch)
tree071c621ef44d7c1b24a430ac7671d68963b5a4cf /app-backup/btrbk/btrbk-9999.ebuild
parent12d78242dec4f785d0a0bfb1c00eee2d8996c53b (diff)
gentoo resync : 13.10.2017
Diffstat (limited to 'app-backup/btrbk/btrbk-9999.ebuild')
-rw-r--r--app-backup/btrbk/btrbk-9999.ebuild21
1 files changed, 17 insertions, 4 deletions
diff --git a/app-backup/btrbk/btrbk-9999.ebuild b/app-backup/btrbk/btrbk-9999.ebuild
index 8718b6220261..78df68d02414 100644
--- a/app-backup/btrbk/btrbk-9999.ebuild
+++ b/app-backup/btrbk/btrbk-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -6,13 +6,13 @@ EAPI=6
inherit systemd
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://dev.tty0.ch/btrbk.git"
+ EGIT_REPO_URI="https://github.com/digint/btrbk.git"
inherit git-r3
SRC_URI=""
KEYWORDS=""
else
SRC_URI="https://digint.ch/download/btrbk/releases/${P}.tar.xz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~amd64 ~arm ~x86"
fi
DESCRIPTION="Tool for creating snapshots and remote backups of btrfs subvolumes"
@@ -21,7 +21,9 @@ LICENSE="GPL-3+"
SLOT="0"
IUSE="+pv"
-DEPEND=""
+DEPEND=">=app-text/asciidoc-8.6.0
+ app-text/xmlto"
+
RDEPEND="dev-lang/perl
net-misc/openssh
pv? ( sys-apps/pv )
@@ -30,3 +32,14 @@ RDEPEND="dev-lang/perl
src_install() {
emake DESTDIR="${D}" DOCDIR="/usr/share/doc/${PF}" SYSTEMDDIR="$(systemd_get_systemunitdir)" install
}
+pkg_preinst() {
+ if has_version "<${CATEGORY}/${PN}-0.26.0" ; then
+ upgrade_0_26_0_warning="1"
+ fi
+}
+pkg_postinst() {
+ if [[ "${upgrade_0_26_0_warning}" == "1" ]]; then
+ ewarn "If you are using raw targets, make sure to run the"
+ ewarn "\"raw_suffix2sidecar\" utility in each target directory."
+ fi
+}