summaryrefslogtreecommitdiff
path: root/app-backup/dar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-07 22:48:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-07 22:48:01 +0000
commitc3bc61051d7f12b4c682efa7a5460bbc8815649e (patch)
treeb6d19e96ba3c397fb8278eeb9b68170db92630ba /app-backup/dar
parent3517852e3b8a68d1e997770fc0650c5053bafc6c (diff)
gentoo resync : 07.01.2022
Diffstat (limited to 'app-backup/dar')
-rw-r--r--app-backup/dar/Manifest2
-rw-r--r--app-backup/dar/dar-2.7.3.ebuild91
2 files changed, 93 insertions, 0 deletions
diff --git a/app-backup/dar/Manifest b/app-backup/dar/Manifest
index a2973345525e..138869ac0bcc 100644
--- a/app-backup/dar/Manifest
+++ b/app-backup/dar/Manifest
@@ -1,3 +1,5 @@
DIST dar-2.7.2.tar.gz 2294187 BLAKE2B 6422f40aea9fe07195359d9e8d5a947fe20d1ec4d6bd866eb8e9240c153d069b5df75018c25b9e8ce6b7acbf4ce4259b50b0768cd391d8b9b1c7be72f03a56b6 SHA512 7e41adc0102806c07d644da41960b1e5bcb6b7872e6a5789506c1f2a001ffb4e3607cae6f76ccc2339d90cf4387b7645e9de6dbc4eed1306827a46e4b7c9d09d
+DIST dar-2.7.3.tar.gz 2398624 BLAKE2B 9d34d233968efcd390db6a1afa1bb93477b6dcbb4bb8c6beb315e927f7ae624bdf23b77f32233a63e3ddd437701fbbd1ee19e5c7ab4f0366ef7e646bacdab46c SHA512 a8a930cd39cae66199e402e61fc48609fe22b821c12407ab7922b8bc8f43f9b11b2f0732baf8198b41d193442a1f82d18536a0d6a7fd7282aaed3600342c7d48
EBUILD dar-2.7.2.ebuild 2227 BLAKE2B 3b2c94f212a3b83753ff1187098d820f776745b7ed20f78fd0f1d5a20682faff9d193b0d5966e7c032626b60906f0ff94fe0b1b908dc936c7c15537b1587ea5e SHA512 b5621fa636ee83fdaf47b86ffb123157a43b73f983857b7d165077a19a22726b9ddebc1b8b123f19d126528b38f34b17b2de50e7303ac464d07f81923592d47a
+EBUILD dar-2.7.3.ebuild 2231 BLAKE2B d7e50735545a3c395e28f01d151d303ac7f74965291525c1492e578d66320cdc617e38d38e4e3fb0d01db4c60a0f62ccebe4f84abb39f3b0f64c7dfcd7e38311 SHA512 ce56985869e84f9918f81c223954333d9e31f1672f5188cd208f9f9b75820d18e32fda3c9642ea3a241526c5e4b92ecce9daaa24b5b4c0d31bb52895e1a9d31b
MISC metadata.xml 1284 BLAKE2B b70f06ea13076c3de9470fa1b65d9a17de048db8f52ade94246c62241828be74f308dcc39067b27ed99ff963c3554e371611aba0bb04ed6d57d14d4f7fd7f9dc SHA512 5cbbbff7e0652a85f717f2eb6a574d6fe52d478e049fa81e1c25b1bbe034086d433558952be1bc56ea4492c9c43f6da1e0968cc9132d18e7342890434c0a19d6
diff --git a/app-backup/dar/dar-2.7.3.ebuild b/app-backup/dar/dar-2.7.3.ebuild
new file mode 100644
index 000000000000..4a8b7a53f19b
--- /dev/null
+++ b/app-backup/dar/dar-2.7.3.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="A full featured backup tool, aimed for disks"
+HOMEPAGE="http://dar.linux.free.fr/"
+SRC_URI="mirror://sourceforge/dar/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux"
+IUSE="argon2 curl dar32 dar64 doc gcrypt gpg lz4 lzo nls rsync threads xattr"
+
+REQUIRED_USE="?? ( dar32 dar64 )
+ gpg? ( gcrypt )"
+
+RESTRICT="test" # need to be run as root
+
+RDEPEND="
+ app-arch/bzip2:=
+ app-arch/xz-utils
+ app-arch/zstd:=
+ sys-libs/libcap
+ >=sys-libs/zlib-1.2.3:=
+ argon2? ( app-crypt/argon2:= )
+ curl? ( net-misc/curl )
+ gcrypt? (
+ dev-libs/libgcrypt:0=
+ dev-libs/libgpg-error
+ )
+ gpg? ( app-crypt/gpgme:1= )
+ lz4? ( app-arch/lz4:= )
+ lzo? ( dev-libs/lzo:2 )
+ nls? ( virtual/libintl )
+ rsync? ( net-libs/librsync:= )
+ threads? ( dev-libs/libthreadar )
+ xattr? ( sys-apps/attr )
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ doc? ( app-doc/doxygen )
+ nls? ( sys-devel/gettext )
+"
+
+src_configure() {
+ # configure.ac is totally funked up regarding the AC_ARG_ENABLE
+ # logic.
+ # For example "--enable-dar-static" causes configure to DISABLE
+ # static builds of dar.
+ # Do _not_ use $(use_enable) until you have verified that the
+ # logic has been fixed by upstream.
+ local myconf=(
+ --disable-dar-static
+ --disable-python-binding
+ --disable-upx
+ $(usev !argon2 --disable-libargon2-linking)
+ $(usev !curl --disable-libcurl-linking)
+ $(usev dar32 --enable-mode=32)
+ $(usev dar64 --enable-mode=64)
+ $(usev !doc --disable-build-html)
+ $(usev !gcrypt --disable-libgcrypt-linking)
+ $(usev !gpg --disable-gpgme-linking)
+ $(usev !lz4 --disable-liblz4-linking)
+ $(usev !lzo --disable-liblzo2-linking)
+ $(usev !nls --disable-nls)
+ $(usev !rsync --disable-librsync-linking)
+ $(usev !threads --disable-threadar)
+ $(usev !xattr --disable-ea-support)
+ )
+
+ # Bug 103741
+ filter-flags -fomit-frame-pointer
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" pkgdatadir="${EPREFIX}"/usr/share/doc/${PF}/html install
+
+ einstalldocs
+
+ find "${ED}" -name "*.la" -delete || die
+
+ # Bug 729150
+ rm "${ED}/usr/share/doc/${PF}/html/samples/MyBackup.sh.tar.gz" || die
+}