summaryrefslogtreecommitdiff
path: root/app-backup/hdup/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-backup/hdup/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-backup/hdup/files')
-rw-r--r--app-backup/hdup/files/hdup-2.0.14-fix-build-system.patch53
1 files changed, 53 insertions, 0 deletions
diff --git a/app-backup/hdup/files/hdup-2.0.14-fix-build-system.patch b/app-backup/hdup/files/hdup-2.0.14-fix-build-system.patch
new file mode 100644
index 000000000000..75ed0254c4ed
--- /dev/null
+++ b/app-backup/hdup/files/hdup-2.0.14-fix-build-system.patch
@@ -0,0 +1,53 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -11,7 +11,7 @@
+
+ hdup:
+ @echo hdup version: ${VERSION}
+- @(cd src ; $(MAKE) all)
++ $(MAKE) -C src all
+
+ clean: tarclean docclean
+ @rm -f Makefile
+@@ -32,7 +32,7 @@
+ @echo "done"
+
+ uninstall:
+- @(cd src ; make uninstall )
++ $(MAKE) -C src uninstall
+
+ install:
+- @(cd src ; make install )
++ $(MAKE) -C src install
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -11,9 +11,9 @@
+ sysconfdir = @sysconfdir@
+ hdup_config = $(sysconfdir)/hdup/hdup.conf
+
+-GCC = @CC@
++CC = @CC@
+ GLIB_CFLAGS = @GLIB_CFLAGS@
+-GLIB_LIBS = @GLIB_LIBS@
++LDLIBS = @GLIB_LIBS@
+ CFLAGS =-Wall @CFLAGS@ @DEFS@ -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -Wpointer-arith -Wstrict-prototypes -DETCFILE=\"$(hdup_config)\"
+ INSTALL = ../install-sh -c
+ INSTALL_PROG = $(INSTALL)
+@@ -22,14 +22,12 @@
+ ######################################
+ ######################################
+ .PHONY: clean install all uninstall
+-%.o: %.c ${HDR}
+- ${GCC} ${CFLAGS} ${GLIB_CFLAGS} -c $<
++.c.o:
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(GLIB_CFLAGS) -c $< -o $@
+
+ all: hdup Makefile.in
+
+-hdup: ${OBJ} ${HDR} Makefile.in
+- ${GCC} ${GLIB_LIBS} ${OBJ} -o hdup
+- ${STRIP}
++hdup: $(OBJ)
+
+ hdup.h: hdup.h.in Makefile.in
+ @(cd .. ; ./configure)