summaryrefslogtreecommitdiff
path: root/app-backup/restic
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /app-backup/restic
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'app-backup/restic')
-rw-r--r--app-backup/restic/Manifest2
-rw-r--r--app-backup/restic/restic-0.9.6.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/app-backup/restic/Manifest b/app-backup/restic/Manifest
index 6ba449a6599c..ca9d24140dc4 100644
--- a/app-backup/restic/Manifest
+++ b/app-backup/restic/Manifest
@@ -1,5 +1,7 @@
DIST restic-0.9.4.tar.gz 26211163 BLAKE2B 950a8da8217500a910f0e5966787b668417f1168e81365ecda70469ef42c24fed876e97b6a44ed9dda89c07760db4678d791960d78760d68c8f1846c827cf340 SHA512 8e75a1da6ee9a364c2bf53ce8f9b014549e7065eae349dc6baf68b0e8a8e9736f83c0495b822aac87480751f448bd42da34c440290b5f0967aea7becda5c448b
DIST restic-0.9.5.tar.gz 26933971 BLAKE2B 7e6cb87c7ce0f860ed884a631b791d0dc44e770ffabf298f20c60197b32961a2a78380e2933ce3851215ec2e32bee95da67566bf7d2d30c3bb0dddda2c6ca804 SHA512 2541b4d70d23d28360c4398427d65ed08a5eea8c171b93be7b7d54baa7b06099f5473ff2fbe3d6b3d6691592300062ba1b240cc03772868d2a0adb1217c8a85f
+DIST restic-0.9.6.tar.gz 27008812 BLAKE2B 4c8982800d39bcd4c29067f2bad15df44b92758b009f5831efb16d211ea28cbb8cda94b9f6cc41a685942145fcfb71c59d0aa10fcb4bd1cd22d15ca812af4fd0 SHA512 f6f7797dc17644e8f0217d81f7194e8e6416f6e740bad0eb11bcf83ab72d1729025e59fd1b81eb9d57bdd60e98b3324026ddb2325c654eb1b51f8f30ed247089
EBUILD restic-0.9.4.ebuild 1230 BLAKE2B 29b8fe9c77bbb950cca765d86a020060ef091f48e4ad11d135955937041a1bb3a5ccca854d2f6869d181101cd040274e4f79143435edd53808838611e72b9154 SHA512 b9781a325fd40210b995f0d244e1c0c64febdb6e7147e1eac360000150281a80ed58f8e791ce75def867bc0906cbe6c8187c6b8f451558784c32415604c0836d
EBUILD restic-0.9.5.ebuild 1229 BLAKE2B 65568ebd28d6493522ae60b5e45026e81479bfd3cc4a562f047ecad19fef5d8459ac558230e52cf2d6678da9e02066b686e221ab0251744ea3e90bf4552d90dc SHA512 b95d92d8a36b4aebefec3c1078120def3176bc74fb04a91e0e03826690913b5116e4354b596e2c9545924eb653091abf1d6a4d65cbd2f25f82c3507d51561201
+EBUILD restic-0.9.6.ebuild 1229 BLAKE2B 31063ee39ebd8c67a850ee25ed54673a662159cb5c8788ec68b0bb36b8b5acbeb491feb20c3b3c3e90bebd6a7f7ce2d61c2de964acb0376f2311443ecb0fd659 SHA512 5c191484b22e87569251090f6040eca4111c57959e6265c0ce08daa7af4ebd01de9a2d7e216a5037288af1257324b5088b36ffa519a56eaa35178405705df557
MISC metadata.xml 444 BLAKE2B f9cc0e8188fbd02a7bacc258eac4052b88fcd3d3b878ce336f7f4635bd4fa94abdfa5112b35bbf6913dcbbfb64833d5f3a4d372c202b2f2488d5d0c750ce2f52 SHA512 8dbd7df10769ff8d0271588be8c97402d5917a4c0dbafa5daad2090245ee4b022193a6c271f71c342540d7599b029998c91c10364eae7d55de0275276342c0f4
diff --git a/app-backup/restic/restic-0.9.6.ebuild b/app-backup/restic/restic-0.9.6.ebuild
new file mode 100644
index 000000000000..4896858176fa
--- /dev/null
+++ b/app-backup/restic/restic-0.9.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 golang-vcs-snapshot
+
+DESCRIPTION="A backup program that is fast, efficient and secure"
+HOMEPAGE="https://restic.github.io/"
+SRC_URI="https://github.com/restic/restic/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+EGO_PN="github.com/restic/restic"
+
+LICENSE="Apache-2.0 BSD BSD-2 LGPL-3-with-linking-exception MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="sys-fs/fuse:0"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P}/src/${EGO_PN}"
+
+src_compile() {
+ local mygoargs=(
+ -v
+ -work
+ -x
+ -tags release
+ -ldflags "-X main.version=${PV}"
+ -asmflags "-trimpath=${S}"
+ -gcflags "-trimpath=${S}"
+ -o restic ${EGO_PN}/cmd/restic
+ )
+
+ GO111MODULE=off GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" \
+ go build "${mygoargs[@]}" || die
+}
+
+src_test() {
+ GO111MODULE=off GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" \
+ go test -timeout 30m -v -work -x ${EGO_PN}/cmd/... ${EGO_PN}/internal/... || die
+}
+
+src_install() {
+ dobin restic
+
+ newbashcomp doc/bash-completion.sh "${PN}"
+
+ insinto /usr/share/zsh/site-functions
+ newins doc/zsh-completion.zsh _restic
+
+ doman doc/man/*
+ dodoc doc/*.rst
+}