summaryrefslogtreecommitdiff
path: root/app-backup/spideroak-bin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-backup/spideroak-bin
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-backup/spideroak-bin')
-rw-r--r--app-backup/spideroak-bin/Manifest4
-rw-r--r--app-backup/spideroak-bin/metadata.xml12
-rw-r--r--app-backup/spideroak-bin/spideroak-bin-7.2.0.ebuild104
3 files changed, 120 insertions, 0 deletions
diff --git a/app-backup/spideroak-bin/Manifest b/app-backup/spideroak-bin/Manifest
new file mode 100644
index 000000000000..374f97a64b7c
--- /dev/null
+++ b/app-backup/spideroak-bin/Manifest
@@ -0,0 +1,4 @@
+DIST spideroak-bin-7.2.0_amd64.deb 24854982 BLAKE2B 9eab89f2c7713f9edbf97da986744c605113830efa971b5327794aa05640ab6386d76d4473cd3a5f6373611bdf7f2ee5ec8eb59d1b9914de48a7b2f724ce4c4e SHA512 9edaf0a7e6e6e985dd7ae1e969c43373393ea6293b8895d74be48f364513a992865ca5cb3150e5fce23eb49635a3442f5162a2606d8fac1ab1036ed922c214cb
+DIST spideroak-bin-7.2.0_x86.deb 24773806 BLAKE2B 4c4c778f50efa8b77c6d0b2ff522ce3ccacc9c0b6fba5b9acb8e6ea25816b303b34751e47f3e27f6b014c03e02473d22b1eba280618cdd9b6c639b82f2425d70 SHA512 758bdaefe307c4c7b7eebc47ebbb835e66c0a57350e34a2cd818212de1d800ae432459933d9613af60b877889724fe90726dd6705fa152b2478bd55552e541ba
+EBUILD spideroak-bin-7.2.0.ebuild 2664 BLAKE2B fc53873462c7f98e69ac926273c6c62bf19e4d47d3028ad5eed684417dd0827505b1960b30005714fd564a52ebee59e3da2f44ad101312fa680e85409968b1d4 SHA512 75ad609ca59dfc51da9feac1953314c15b5914e56b8d7c89d3ee91e66536b37e1b5ae0d48c47d34536403aa4cf164b1568e44d97242b5598e2d5341fb55e173e
+MISC metadata.xml 352 BLAKE2B d51f327fe859d894ae43eebfeac7b983b9b450ebd190352dedaaa95f844d1df86c6e8ea6b7478dafbc419af1fa273760b0c53c02280050947058ba052650f53b SHA512 fd3c4eea494c4e8e5f093e5cc099577c2f944d0f05c6376798a1e7680e9b194c45719e09a6cec755054b174dd6f9039c69d10e863f0bec72b6a15420d0c9bd7b
diff --git a/app-backup/spideroak-bin/metadata.xml b/app-backup/spideroak-bin/metadata.xml
new file mode 100644
index 000000000000..bdf371a8df29
--- /dev/null
+++ b/app-backup/spideroak-bin/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>lucianposton@pm.me</email>
+ <name>Lucian Poston</name>
+</maintainer>
+<maintainer type="person">
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+</maintainer>
+</pkgmetadata>
diff --git a/app-backup/spideroak-bin/spideroak-bin-7.2.0.ebuild b/app-backup/spideroak-bin/spideroak-bin-7.2.0.ebuild
new file mode 100644
index 000000000000..b50355c676a7
--- /dev/null
+++ b/app-backup/spideroak-bin/spideroak-bin-7.2.0.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit eutils unpacker
+
+DESCRIPTION="Secure free online backup, storage, and sharing system"
+HOMEPAGE="https://spideroak.com"
+
+SRC_URI_BASE="https://spideroak.com/release/spideroak"
+SRC_URI="x86? ( ${SRC_URI_BASE}/deb_x86 -> ${P}_x86.deb )
+ amd64? ( ${SRC_URI_BASE}/deb_x64 -> ${P}_amd64.deb )"
+
+RESTRICT="mirror strip"
+
+LICENSE="spideroak"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus X"
+
+DEPEND="dev-util/patchelf"
+RDEPEND="
+ app-crypt/mit-krb5[keyutils]
+ media-libs/libpng:1.2
+ dbus? ( sys-apps/dbus )
+ X? (
+ media-libs/fontconfig
+ media-libs/freetype:2
+ dev-libs/glib:2
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXrender
+ x11-libs/libXt
+ )
+"
+
+S=${WORKDIR}
+
+QA_PREBUILT="*"
+
+src_prepare() {
+ # Set RPATH for preserve-libs handling (bug #400979).
+ cd "${S}/opt/SpiderOakONE/lib" || die
+ local x
+ for x in `find` ; do
+ # Use \x7fELF header to separate ELF executables and libraries
+ [[ -f ${x} && $(od -t x1 -N 4 "${x}") == *"7f 45 4c 46"* ]] || continue
+ patchelf --set-rpath '$ORIGIN' "${x}" || \
+ die "patchelf failed on ${x}"
+ done
+
+ #Remove the libraries that break compatibility in modern systems
+ #SpiderOak will use the system libs instead
+ rm -f "${S}/opt/SpiderOakONE/lib/libstdc++.so.6"
+ rm -f "${S}/opt/SpiderOakONE/lib/libgcc_s.so.1"
+ rm -f "${S}/opt/SpiderOakONE/lib/libpng12.so.0"
+ rm -f "${S}/opt/SpiderOakONE/lib/libz.so.1"
+
+ eapply_user
+}
+
+src_install() {
+ #install the wrapper script
+ exeinto /usr/bin
+ doexe usr/bin/SpiderOakONE
+
+ # inotify_dir_watcher needs to be marked executable, bug #453266
+ #chmod a+rx opt/SpiderOakONE/lib/inotify_dir_watcher
+
+ #install the executable
+ exeinto /opt/SpiderOakONE/lib
+ doexe opt/SpiderOakONE/lib/SpiderOakONE
+ doexe opt/SpiderOakONE/lib/inotify_dir_watcher
+ rm -f opt/SpiderOakONE/lib/{SpiderOakONE,inotify_dir_watcher}
+
+ #install the prebundled libraries
+ insinto /opt/SpiderOakONE
+ doins -r opt/SpiderOakONE/lib
+
+ #install the config files
+ use dbus || rm -rf etc/dbus-1
+ insinto /
+ doins -r etc
+
+ #install the manpage
+ doman usr/share/man/man1/SpiderOakONE.1.gz
+
+ if use X; then
+ domenu usr/share/applications/SpiderOakONE.desktop
+ doicon usr/share/pixmaps/SpiderOakONE.png
+ fi
+}
+
+pkg_postinst() {
+ if ! use X; then
+ einfo "For instructions on running SpiderOakONE without a GUI, please read the FAQ:"
+ einfo " https://spideroak.com/faq/questions/62/how_do_i_install_spideroak_on_a_headless_linux_server/"
+ einfo " https://spideroak.com/faq/questions/67/how_can_i_use_spideroak_from_the_commandline/"
+ fi
+}