summaryrefslogtreecommitdiff
path: root/app-backup
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-03 03:04:04 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-03 03:04:04 +0000
commit212000bb5eabdfeb9a6e7a9b8f28e2740cae555a (patch)
treedbbe26e892147b95a24336cc44d791dbe0c0ce5f /app-backup
parent37a097af13d675b83911ac006ee9ee22d2163f9a (diff)
gentoo auto-resync : 03:11:2024 - 03:04:03
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/Manifest.gzbin7700 -> 7695 bytes
-rw-r--r--app-backup/dar/Manifest1
-rw-r--r--app-backup/dar/dar-2.7.15-r1.ebuild109
3 files changed, 110 insertions, 0 deletions
diff --git a/app-backup/Manifest.gz b/app-backup/Manifest.gz
index e1ffc60c40ab..17c13a0a4265 100644
--- a/app-backup/Manifest.gz
+++ b/app-backup/Manifest.gz
Binary files differ
diff --git a/app-backup/dar/Manifest b/app-backup/dar/Manifest
index d0fed7b54031..0a080f4630ae 100644
--- a/app-backup/dar/Manifest
+++ b/app-backup/dar/Manifest
@@ -1,3 +1,4 @@
DIST dar-2.7.15.tar.gz 2443741 BLAKE2B 6af22a471dc0b5230843b73b7bddf931c281b8b3f0ea4cf1eb01f37e06651fa90a06b3e45be342ab799960f27460dfa8b95022791b9b471df2834a786784951f SHA512 c35c47c5ef307e3a36394cff44b37de0b9e7ad95d2810de476197897d368fa20401d567b18b763d39663167ec2ca093e54535fb5741c99a8e4bf9b78a460eaba
+EBUILD dar-2.7.15-r1.ebuild 2655 BLAKE2B cad1896582faea50899a43cdbad2d5717d032f48116f36e3759765811f9a124952c64d53c15423f1776cbc80df9de9cf2cb05dcde18ad0cd791b94f6a1c19cf7 SHA512 590a940302d09a2ded90622b5db77c1b9a0b699b0dbb97268eb62e1c51a0a40a0bcec3b92e3950acd32bf798fb90680459bbfb35328277bd05be066b7f0ef4cb
EBUILD dar-2.7.15.ebuild 2321 BLAKE2B 066625f535504d11f59303bf88d5df20712ce59e1c0423a40f85a49de50cec5f41624a94738218e9405bf07e3f4958c0a132301fdcc1ea4e4a68c2819778ff0b SHA512 4bab29f6debe6297d334d1264e392f09588bfdd8de89a57cb844a660e12b271782b8a1e5646b4e6072b3966133beac0d0575be64c4e9f8fbeea484e5f41b8b91
MISC metadata.xml 1180 BLAKE2B d978c1b969e7aeb013862c6b76ceb7b466af7b0a16d334bfbaafcdb49e13b4f07727073ff8a24da0f0422161f48805310b8ed7c0cc97b07190b241ad77cec254 SHA512 f8107b5f81d0d00a1873089b084250c98094625274b9c01f8ca11f6dcfa890278ec89d039849c203ccccc8115d54ee3f9365d9f6afc38cb3411f6292c62c11c0
diff --git a/app-backup/dar/dar-2.7.15-r1.ebuild b/app-backup/dar/dar-2.7.15-r1.ebuild
new file mode 100644
index 000000000000..2810dab39777
--- /dev/null
+++ b/app-backup/dar/dar-2.7.15-r1.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="A full featured backup tool, aimed for disks"
+HOMEPAGE="http://dar.linux.free.fr/"
+SRC_URI="https://downloads.sourceforge.net/project/dar/dar/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux"
+IUSE="argon2 curl dar32 dar64 doc gcrypt gpg lz4 lzo nls rsync xattr"
+
+REQUIRED_USE="
+ ?? ( dar32 dar64 )
+ gpg? ( gcrypt )
+"
+
+RESTRICT="test" # need to be run as root
+
+RDEPEND="
+ app-arch/bzip2:=
+ app-arch/xz-utils
+ app-arch/zstd:=
+ dev-libs/libthreadar
+ sys-libs/libcap
+ >=sys-libs/zlib-1.2.3:=
+ argon2? ( app-crypt/argon2:= )
+ curl? ( net-misc/curl )
+ gcrypt? (
+ dev-libs/libgcrypt:0=
+ dev-libs/libgpg-error
+ )
+ gpg? (
+ app-crypt/gpgme:=
+ dev-libs/libassuan:=
+ )
+ lz4? ( app-arch/lz4:= )
+ lzo? ( dev-libs/lzo:2 )
+ nls? ( virtual/libintl )
+ rsync? ( net-libs/librsync:= )
+ xattr? ( sys-apps/attr )
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ doc? ( app-text/doxygen )
+ nls? ( sys-devel/gettext )
+"
+
+QA_PKGCONFIG_VERSION="" # Bug #862025 - upstream has a different numbering scheme for libdar
+
+src_prepare() {
+ default
+
+ # Remove `check` subdirectory, unused because RESTRICT=test. See bug #942752
+ sed -e 's/\<check\>//' -i src/Makefile.am
+
+ # Add gettext version so autopoint does not fail
+ # Try to keep it in sync with upstream
+ sed -e '/AM_GNU_GETTEXT_VERSION/ s/$/(0.20.2)/' -i configure.ac
+ eautoreconf
+}
+
+src_configure() {
+ # configure.ac is totally funked up regarding the AC_ARG_ENABLE
+ # logic.
+ # For example "--enable-dar-static" causes configure to DISABLE
+ # static builds of dar.
+ # Do _not_ use $(use_enable) until you have verified that the
+ # logic has been fixed by upstream.
+ local myconf=(
+ --disable-dar-static
+ --disable-python-binding
+ --disable-upx
+ $(usev !argon2 --disable-libargon2-linking)
+ $(usev !curl --disable-libcurl-linking)
+ $(usev dar32 --enable-mode=32)
+ $(usev dar64 --enable-mode=64)
+ $(usev !doc --disable-build-html)
+ $(usev !gcrypt --disable-libgcrypt-linking)
+ $(usev !gpg --disable-gpgme-linking)
+ $(usev !lz4 --disable-liblz4-linking)
+ $(usev !lzo --disable-liblzo2-linking)
+ $(usev !nls --disable-nls)
+ $(usev !rsync --disable-librsync-linking)
+ $(usev !xattr --disable-ea-support)
+ )
+
+ # Bug 103741
+ filter-flags -fomit-frame-pointer
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" pkgdatadir="${EPREFIX}"/usr/share/doc/${PF}/html install
+
+ einstalldocs
+
+ find "${ED}" -name "*.la" -delete || die
+
+ # Bug 729150
+ rm "${ED}/usr/share/doc/${PF}/html/samples/MyBackup.sh.tar.gz" || die
+}