summaryrefslogtreecommitdiff
path: root/app-backup
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-29 00:32:16 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-29 00:32:16 +0000
commitad108e7b751d67723534624b94eb0e04250dd1af (patch)
treeb2c2e47b9c23ac5a70d7170b3ba364b32da31944 /app-backup
parentc44ae5c03130467400468d0e9a7f83e723c99f35 (diff)
gentoo auto-resync : 29:03:2025 - 00:32:15
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/Manifest.gzbin7868 -> 7862 bytes
-rw-r--r--app-backup/bacula/Manifest2
-rw-r--r--app-backup/bacula/bacula-15.0.3.ebuild459
3 files changed, 461 insertions, 0 deletions
diff --git a/app-backup/Manifest.gz b/app-backup/Manifest.gz
index eadd7cc95b68..203235983418 100644
--- a/app-backup/Manifest.gz
+++ b/app-backup/Manifest.gz
Binary files differ
diff --git a/app-backup/bacula/Manifest b/app-backup/bacula/Manifest
index f177b7af4799..8ffdfd14722f 100644
--- a/app-backup/bacula/Manifest
+++ b/app-backup/bacula/Manifest
@@ -16,5 +16,7 @@ AUX newscripts/bacula-fd.initd 324 BLAKE2B cfc134247570538fed3aa1a96e51a45704cd7
AUX newscripts/bacula-sd.initd 324 BLAKE2B fe9c1c5893d9e8c80d906e4c31e2645414674b0b26aaca7ec54217ccff90cf2718c5e3fa3dc28079693fb742765178c4d8fd1f7eceac4a205ce4b1995b0f212f SHA512 df6d7b20a8ce8622bf1c4806384a5fae0178e331d5355de2e2d2bfb29204ec627964752a53828cd0aa6a37bd61522638a7267568f86e0b0ebbcdcc12bb176d9a
AUX tray-monitor-pro.patch 651 BLAKE2B 87a75a10fe709ca780ddb721576808b0a5ffe6f489fbe2844e7150586e5a114b4771646ba1b6fd3f1fb0d2a606080e69eff1fadb3fc2eb4a90d3c8fe1d4de2a6 SHA512 0e68e9867307e5fb978f1a54b2efe20a07bebf9d9651cfbf0a0c789751336cf131fd0f07f313b73ed7d0b8f2a26c1fb6c737936a048ad3c0cf8a9e1dd094601b
DIST bacula-15.0.2.tar.gz 6524812 BLAKE2B 1dd0722ce2bb6363936ed9cc9df1b6d842945f17277c77f40884bafc4b0a254c5fdd2c21bd200c6ca8b77c8eb718a319552e50135c9925d2b4ad81a64ab819d2 SHA512 71bd206a2bb0cf3ca0f2cb6547b63946bc2a8a5f70c5506b9a589e5ed9871bb98b56205da7d12e54a41c9ab3539fe1114bc94d926f0f831ee9e15bba36f167f3
+DIST bacula-15.0.3.tar.gz 6539212 BLAKE2B 16af09af709406fce5e05b101c3ab1337e24816b353cc1a00c0efe05ba798fdf21f3a36ca1c3f867ff4bd768822494ba5f45d6555d0978754d30e08cfaa638dc SHA512 1700ac00b41d9e3426f6b7ead5bf44722e2f36e54ddb26a9ea169f6fbf4a61a7863e2e7b81890911d567d653468675d53eb7fc74e77c93358d6f9a52a73c0af8
EBUILD bacula-15.0.2.ebuild 13473 BLAKE2B a6817caefbbc54f6ea4b9031c60e7d37822cab90fc0f6cab1745289ac6f3620c408da5dc28f11984c585b0293449168c156de0571255ab600fea6ec643b3d09a SHA512 acbe0ec9502bf1237ee6740f38b0fc0704fa50a03465b1f96de7ade2c296c02d52123b51c145ae9857e5df908db6cc82556b2811db45ffa82dcefedc5fce745f
+EBUILD bacula-15.0.3.ebuild 13475 BLAKE2B 0dbc77e61184e316ebb5cb2adcedb1f2406cc0e6431d2c1de8cff11980235547fe4b21b36f1025fb3aa23e5838774955cb8ef89bc8b669d3433e98d34fce8120 SHA512 b71b0222c85d8234252017d41fdca6b49c5e3898520d9ae6d9e0684fd4626005c5852c4360c92cc6a5b5f62d636495f48b543fdb003565412f52283c4dfd2d28
MISC metadata.xml 747 BLAKE2B bae193fb0ae5e5e92b0b6e935691f19235a230b0a7e69083aeb344db0e451ca55f16c9f3c163eab390621ab266e0f7f7ee1e75eff69589b2de0c730d2cf0d965 SHA512 df7c2a1296cb7da96928de07347df04f741b8b91de72d39c002dda3e5c9564341a5bc73b60f68752a806175fd5709b35f1eb4ecf00e85e1237c4672c0b948557
diff --git a/app-backup/bacula/bacula-15.0.3.ebuild b/app-backup/bacula/bacula-15.0.3.ebuild
new file mode 100644
index 000000000000..34a397e843ae
--- /dev/null
+++ b/app-backup/bacula/bacula-15.0.3.ebuild
@@ -0,0 +1,459 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop flag-o-matic libtool qmake-utils systemd
+
+MY_PV=${PV/_beta/-b}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Featureful client/server network backup suite"
+HOMEPAGE="https://www.bacula.org/"
+SRC_URI="https://downloads.sourceforge.net/bacula/${MY_P}.tar.gz"
+
+S=${WORKDIR}/${MY_P}
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="acl bacula-clientonly bacula-nodir bacula-nosd +batch-insert examples ipv6 logwatch mysql postgres qt5 readline selinux +sqlite ssl static tcpd vim-syntax X"
+
+DEPEND="
+ !bacula-clientonly? (
+ !bacula-nodir? ( virtual/mta )
+ postgres? ( dev-db/postgresql:=[threads(+)] )
+ mysql? ( || ( dev-db/mysql-connector-c dev-db/mariadb-connector-c ) )
+ sqlite? ( dev-db/sqlite:3 )
+ )
+ dev-libs/gmp:0
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtsvg:5
+ x11-libs/qwt:6
+ )
+ logwatch? ( sys-apps/logwatch )
+ readline? ( sys-libs/readline:0 )
+ static? (
+ dev-libs/lzo[static-libs]
+ sys-libs/ncurses:=[static-libs]
+ sys-libs/zlib[static-libs]
+ acl? ( virtual/acl[static-libs(+)] )
+ ssl? (
+ dev-libs/openssl:0=[static-libs]
+ )
+ )
+ !static? (
+ dev-libs/lzo
+ sys-libs/ncurses:=
+ sys-libs/zlib
+ acl? ( virtual/acl )
+ ssl? (
+ dev-libs/openssl:0=
+ )
+ )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ dev-util/patchelf
+"
+RDEPEND="${DEPEND}
+ acct-user/bacula
+ acct-group/bacula
+ !bacula-clientonly? (
+ !bacula-nosd? (
+ app-arch/mt-st
+ sys-block/mtx
+ )
+ )
+ selinux? ( sec-policy/selinux-bacula )
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
+"
+
+REQUIRED_USE="
+ !bacula-clientonly? ( ^^ ( mysql postgres sqlite ) )
+ static? ( bacula-clientonly )
+"
+
+# suppress warning wrt 'implicit function declaration' in config logs
+# bug 900663
+QA_CONFIG_IMPL_DECL_SKIP=(
+ makedev # designed to check availability in
+ # used header file
+)
+
+pkg_setup() {
+ #XOR and !bacula-clientonly controlled by REQUIRED_USE
+ use mysql && export mydbtype="mysql"
+ use postgres && export mydbtype="postgresql"
+ use sqlite && export mydbtype="sqlite3"
+
+ if use bacula-clientonly && use static && use qt5; then
+ ewarn
+ ewarn "Building statically linked 'bat' is not supported. Ignorig 'qt5' useflag."
+ ewarn
+ fi
+}
+
+src_prepare() {
+ # adjusts default configuration files for several binaries
+ # to /etc/bacula/<config> instead of ./<config>
+ pushd src >&/dev/null || die
+ for f in console/console.c dird/dird.c filed/filed.c \
+ stored/bcopy.c stored/bextract.c stored/bls.c \
+ stored/bscan.c stored/btape.c stored/stored.c \
+ qt-console/main.cpp; do
+ sed -i -e 's|^\(#define CONFIG_FILE "\)|\1/etc/bacula/|g' "${f}" \
+ || die "sed on ${f} failed"
+ done
+ popd >&/dev/null || die
+
+ # bug 466688 drop deprecated categories from Desktop file
+ sed -i -e 's/Application;//' scripts/bat.desktop.in || die
+
+ # bug 466690 Use CXXFLAGS instead of CFLAGS
+ sed -i -e 's/@CFLAGS@/@CXXFLAGS@/' autoconf/Make.common.in || die
+
+ # drop automatic install of unneeded documentation (for bug 356499)
+ eapply -p0 "${FILESDIR}"/7.2.0/${PN}-7.2.0-doc.patch
+
+ # bug #310087
+ eapply "${FILESDIR}"/5.2.3/${PN}-5.2.3-as-needed.patch
+
+ # bug #311161
+ eapply -p0 "${FILESDIR}"/9.0.2/${PN}-9.0.2-lib-search-path.patch
+
+ # bat needs to respect LDFLAGS and CFLAGS
+ eapply -p0 "${FILESDIR}"/9.0.6/${PN}-9.0.6-bat-pro.patch
+
+ # tray-monitor needs to respect LDFLAGS and CFLAGS
+ eapply -p0 "${FILESDIR}"/tray-monitor-pro.patch
+
+ # bug #328701
+ eapply -p0 "${FILESDIR}"/5.2.3/${PN}-5.2.3-openssl-1.patch
+
+ eapply -p0 "${FILESDIR}"/${PN}-15.0.2-fix-static.patch
+
+ # fix soname in libbaccat.so, see bugs #602952, #790140 and #845126
+ eapply "${FILESDIR}/bacula-fix-sonames-new.patch"
+
+ # correct library search path for slibtool usage (bug #914389)
+ eapply -p0 "${FILESDIR}/${PN}-15.0.2-fix_slibtool.patch"
+
+ # do not strip binaries
+ sed -i -e "s/strip /# strip /" src/filed/Makefile.in || die
+ sed -i -e "s/strip /# strip /" src/console/Makefile.in || die
+ sed -i -e "s/+= qt$/+= qt nostrip/" \
+ src/qt-console/tray-monitor/tray-monitor.pro.in || die
+
+ eapply_user
+
+ # Fix systemd unit files:
+ # bug 497748
+ sed -i -e '/Requires/d' platforms/systemd/*.service.in || die
+ sed -i -e '/StandardOutput/d' platforms/systemd/*.service.in || die
+ # bug 504370
+ sed -i -e '/Alias=bacula-dir/d' platforms/systemd/bacula-dir.service.in || die
+ # bug 584442 and 504368
+ sed -i -e 's/@dir_user@/root/g' platforms/systemd/bacula-dir.service.in || die
+
+ # build 'bat' for Qt5
+ export QMAKE="$(qt5_get_bindir)"/qmake
+
+ # adapt to >=Qt-5.9 (see bug #644566)
+ # qmake needs an existing target file to generate install instructions
+ sed -i -e 's#bins.files = bat#bins.files = .libs/bat#g' \
+ src/qt-console/bat.pro.in || die
+ mkdir src/qt-console/.libs || die
+ touch src/qt-console/.libs/bat || die
+ chmod 755 src/qt-console/.libs/bat || die
+
+ # same for tray-monitor (bug #915605)
+ sed -i -e 's#bins.files = bac#bins.files = .libs/bac#g' \
+ src/qt-console/tray-monitor/tray-monitor.pro.in || die
+ mkdir src/qt-console/tray-monitor/.libs || die
+ touch src/qt-console/tray-monitor/.libs/bacula-tray-monitor || die
+ chmod 755 src/qt-console/tray-monitor/.libs/bacula-tray-monitor || die
+
+ eapply -p0 "${FILESDIR}/fix_tray_monitor.patch" || die
+
+ # Don't let program install man pages directly
+ sed -i -e 's/ manpages//' Makefile.in || die
+
+ # correct installation for plugins to mode 0755 (bug #725946)
+ sed -i -e "s/(INSTALL_PROGRAM) /(INSTALL_LIB) /" src/plugins/fd/Makefile ||die
+ sed -i -e "s/(INSTALL_PROGRAM) /(INSTALL_LIB) /" src/plugins/fd/docker/Makefile ||die
+
+ # drop reliance on installed 'which' program (bug #940692)
+ eapply "${FILESDIR}"/${PN}-drop-which.patch
+
+ # fix bundled libtool (bug 466696)
+ # But first move directory with M4 macros out of the way.
+ # It is only needed by autoconf and gives errors during elibtoolize.
+ mv autoconf/libtool autoconf/libtool1 || die
+ elibtoolize
+}
+
+src_configure() {
+ # -Werror=lto-type-mismatch
+ # bug #940695
+ #
+ # common datastructures with partial different components for
+ # different tools of the backup suite
+ filter-lto
+
+ local myconf=''
+
+ if use bacula-clientonly; then
+ myconf="${myconf} \
+ $(use_enable bacula-clientonly client-only) \
+ $(use_enable !static libtool) \
+ $(use_enable static static-cons) \
+ $(use_enable static static-fd)"
+ else
+ myconf="${myconf} \
+ $(use_enable !bacula-nodir build-dird) \
+ $(use_enable !bacula-nosd build-stored)"
+ # bug #311099
+ # database support needed by dir-only *and* sd-only
+ # build as well (for building bscan, btape, etc.)
+ myconf="${myconf}
+ --with-${mydbtype}"
+ fi
+
+ # do not build bat if 'static' clientonly
+ if ! use bacula-clientonly || ! use static; then
+ myconf="${myconf} \
+ $(use_enable qt5 bat)"
+ fi
+
+ myconf="${myconf} \
+ $(use_with X x) \
+ $(use_enable batch-insert) \
+ $(use_enable !readline conio) \
+ $(use_enable readline) \
+ $(use_with ssl openssl) \
+ $(use_enable ipv6) \
+ $(use_enable acl) \
+ $(use_with tcpd tcp-wrappers)"
+
+ econf \
+ --with-pid-dir=/var/run \
+ --sysconfdir=/etc/bacula \
+ --with-archivedir=/var/lib/bacula/tmp \
+ --with-subsys-dir=/var/lock/subsys \
+ --with-working-dir=/var/lib/bacula \
+ --with-logdir=/var/lib/bacula \
+ --with-scriptdir=/usr/libexec/bacula \
+ --with-systemd=$(systemd_get_systemunitdir) \
+ --with-dir-user=bacula \
+ --with-dir-group=bacula \
+ --with-sd-user=root \
+ --with-sd-group=bacula \
+ --with-fd-user=root \
+ --with-fd-group=bacula \
+ --enable-smartalloc \
+ --disable-afs \
+ --without-s3 \
+ --host=${CHOST} \
+ ${myconf}
+}
+
+src_compile() {
+ # Make build log verbose (bug #447806)
+ emake NO_ECHO=""
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ doicon scripts/bacula.png
+ keepdir /var/lib/bacula/tmp
+
+ # remove not needed .la files #840957
+ find "${ED}" -name '*.la' -delete || die
+
+ # install bat icon and desktop file when enabled
+ # (for some reason ./configure doesn't pick this up)
+ if use qt5 && ! use static ; then
+ doicon src/qt-console/images/bat_icon.png
+ domenu scripts/bat.desktop
+ fi
+
+ # remove some scripts we don't need at all
+ rm -f "${D}"/usr/libexec/bacula/{bacula,bacula-ctl-dir,bacula-ctl-fd,bacula-ctl-sd,startmysql,stopmysql}
+
+ # rename statically linked apps
+ if use bacula-clientonly && use static ; then
+ pushd "${D}"/usr/sbin || die
+ mv static-bacula-fd bacula-fd || die
+ mv static-bconsole bconsole || die
+ popd || die
+ fi
+
+ # extra files which 'make install' doesn't cover
+ if ! use bacula-clientonly; then
+ # the database update scripts
+ diropts -m0750
+ insinto /usr/libexec/bacula/updatedb
+ insopts -m0754
+ doins "${S}"/updatedb/*
+ fperms 0640 /usr/libexec/bacula/updatedb/README
+
+ # the logrotate configuration
+ # (now unconditional wrt bug #258187)
+ diropts -m0755
+ insinto /etc/logrotate.d
+ insopts -m0644
+ newins "${S}"/scripts/logrotate bacula
+
+ # the logwatch scripts
+ if use logwatch; then
+ diropts -m0750
+ dodir /usr/share/logwatch/scripts/services
+ dodir /usr/share/logwatch/scripts/shared
+ dodir /etc/logwatch/conf/logfiles
+ dodir /etc/logwatch/conf/services
+ pushd "${S}"/scripts/logwatch >&/dev/null || die
+ emake DESTDIR="${D}" install
+ popd >&/dev/null || die
+ fi
+ fi
+
+ # Install all man pages
+ doman "${S}"/manpages/*.[18]
+
+ if ! use qt5; then
+ rm -vf "${D}"/usr/share/man/man1/bat.1*
+ rm -vf "${D}"/usr/share/man/man1/bacula-tray-monitor.1*
+ fi
+
+ if use bacula-clientonly || use bacula-nodir ; then
+ rm -vf "${D}"/usr/libexec/bacula/create_*_database
+ rm -vf "${D}"/usr/libexec/bacula/drop_*_database
+ rm -vf "${D}"/usr/libexec/bacula/make_*_tables
+ rm -vf "${D}"/usr/libexec/bacula/update_*_tables
+ rm -vf "${D}"/usr/libexec/bacula/drop_*_tables
+ rm -vf "${D}"/usr/libexec/bacula/grant_*_privileges
+ rm -vf "${D}"/usr/libexec/bacula/*_catalog_backup
+ fi
+ if use bacula-clientonly || use bacula-nosd; then
+ rm -vf "${D}"/usr/libexec/bacula/disk-changer
+ rm -vf "${D}"/usr/libexec/bacula/mtx-changer
+ rm -vf "${D}"/usr/libexec/bacula/dvd-handler
+ fi
+
+ # documentation
+ dodoc ChangeLog ReleaseNotes SUPPORT
+
+ # install examples (bug #457504)
+ if use examples; then
+ docinto examples/
+ dodoc -r examples/*
+ fi
+
+ # vim-files
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins scripts/bacula.vim
+ insinto /usr/share/vim/vimfiles/ftdetect
+ newins scripts/filetype.vim bacula_ft.vim
+ fi
+
+ # setup init scripts
+ myscripts="bacula-fd"
+ if ! use bacula-clientonly; then
+ if ! use bacula-nodir; then
+ myscripts="${myscripts} bacula-dir"
+ fi
+ if ! use bacula-nosd; then
+ myscripts="${myscripts} bacula-sd"
+ fi
+ fi
+ for script in ${myscripts}; do
+ # copy over init script and config to a temporary location
+ # so we can modify them as needed
+ cp "${FILESDIR}/${script}".confd "${T}/${script}".confd || die "failed to copy ${script}.confd"
+ cp "${FILESDIR}/newscripts/${script}".initd "${T}/${script}".initd || die "failed to copy ${script}.initd"
+
+ # now set the database dependency for the director init script
+ case "${script}" in
+ bacula-dir)
+ case "${mydbtype}" in
+ sqlite3)
+ # sqlite databases don't have a daemon
+ sed -i -e 's/need "%database%"/:/g' "${T}/${script}".initd || die
+ ;;
+ *)
+ # all other databases have daemons
+ sed -i -e "s:%database%:${mydbtype}:" "${T}/${script}".initd || die
+ ;;
+ esac
+ ;;
+ *)
+ ;;
+ esac
+
+ # install init script and config
+ newinitd "${T}/${script}".initd "${script}"
+ newconfd "${T}/${script}".confd "${script}"
+ done
+
+ systemd_dounit "${S}"/platforms/systemd/bacula-{dir,fd,sd}.service
+
+ # make sure the working directory exists
+ diropts -m0750
+ keepdir /var/lib/bacula
+
+ # make sure bacula group can execute bacula libexec scripts
+ fowners -R root:bacula /usr/libexec/bacula
+}
+
+pkg_postinst() {
+ if use bacula-clientonly; then
+ fowners root:bacula /var/lib/bacula
+ else
+ fowners bacula:bacula /var/lib/bacula
+ fi
+
+ einfo
+ einfo "A group 'bacula' has been created. Any users you add to this"
+ einfo "group have access to files created by the daemons."
+ einfo
+ einfo "A user 'bacula' has been created. Please see the bacula manual"
+ einfo "for information about running bacula as a non-root user."
+ einfo
+
+ if ! use bacula-clientonly && ! use bacula-nodir; then
+ einfo
+ einfo "If this is a new install, you must create the ${mydbtype} databases with:"
+ einfo " /usr/libexec/bacula/create_${mydbtype}_database"
+ einfo " /usr/libexec/bacula/make_${mydbtype}_tables"
+ einfo " /usr/libexec/bacula/grant_${mydbtype}_privileges"
+ einfo
+
+ ewarn "ATTENTION!"
+ ewarn "The format of the database may have changed."
+ ewarn "If you just upgraded from a version below 9.0.0 you must run"
+ ewarn "'update_bacula_tables' now."
+ ewarn "Make sure to have a backup of your catalog before."
+ ewarn
+ fi
+
+ if use sqlite; then
+ einfo
+ einfo "Be aware that Bacula does not officially support SQLite database anymore."
+ einfo "Best use it only for a client-only installation. See Bug #445540."
+ einfo
+ fi
+
+ einfo "Please note that 'bconsole' will always be installed. To compile 'bat'"
+ einfo "you have to enable 'USE=qt5'."
+ einfo
+ einfo "/var/lib/bacula/tmp was configured for archivedir. This dir will be used during"
+ einfo "restores, so be sure to set it to an appropriate in dir in the bacula config."
+
+ einfo
+ einfo "If you adapt the port numbers for baculas components in the config files"
+ einfo "make sure to adapt the file names for the pidfile accordingly"
+ einfo "(see init.d scripts)."
+}