summaryrefslogtreecommitdiff
path: root/app-benchmarks/ioping/ioping-1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-26 14:52:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-26 14:52:16 +0100
commitc3d998909264b1ff687b9c65cae3046443e66f7e (patch)
treeed7aa279f601f6c46fb8b7425bd2a051b72be8d6 /app-benchmarks/ioping/ioping-1.3.ebuild
parentcf91c70bb5a537972156006c46756b9ac75bdb7b (diff)
gentoo auto-resync : 26:08:2022 - 14:52:16
Diffstat (limited to 'app-benchmarks/ioping/ioping-1.3.ebuild')
-rw-r--r--app-benchmarks/ioping/ioping-1.3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-benchmarks/ioping/ioping-1.3.ebuild b/app-benchmarks/ioping/ioping-1.3.ebuild
new file mode 100644
index 000000000000..b9411df0feee
--- /dev/null
+++ b/app-benchmarks/ioping/ioping-1.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simple disk I/0 latency measuring tool"
+HOMEPAGE="https://github.com/koct9i/ioping"
+SRC_URI="https://github.com/koct9i/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+
+ dodoc changelog README.md
+}