summaryrefslogtreecommitdiff
path: root/app-benchmarks/stress-ng/stress-ng-0.11.21.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /app-benchmarks/stress-ng/stress-ng-0.11.21.ebuild
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'app-benchmarks/stress-ng/stress-ng-0.11.21.ebuild')
-rw-r--r--app-benchmarks/stress-ng/stress-ng-0.11.21.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-benchmarks/stress-ng/stress-ng-0.11.21.ebuild b/app-benchmarks/stress-ng/stress-ng-0.11.21.ebuild
new file mode 100644
index 000000000000..3985c5e05705
--- /dev/null
+++ b/app-benchmarks/stress-ng/stress-ng-0.11.21.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit optfeature toolchain-funcs
+
+DESCRIPTION="Stress test for a computer system with various selectable ways"
+HOMEPAGE="https://kernel.ubuntu.com/~cking/stress-ng/"
+SRC_URI="https://kernel.ubuntu.com/~cking/tarballs/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+DEPEND="
+ dev-libs/libaio
+ dev-libs/libbsd
+ dev-libs/libgcrypt:0=
+ sys-apps/attr
+ sys-apps/keyutils:=
+ sys-libs/libcap
+ sys-libs/zlib
+"
+
+RDEPEND="${DEPEND}"
+
+DOCS=( "README" "README.Android" "TODO" "syscalls.txt" )
+
+PATCHES=( "${FILESDIR}/${PN}-0.11.17-makefile.patch" )
+
+src_compile() {
+ tc-export CC
+
+ default
+}
+
+pkg_postinst() {
+ optfeature "AppArmor support" sys-libs/libapparmor
+ optfeature "SCTP support" net-misc/lksctp-tools
+}