summaryrefslogtreecommitdiff
path: root/app-benchmarks/sysbench/sysbench-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
commitd87262dd706fec50cd150aab3e93883b6337466d (patch)
tree246b44c33ad7a57550430b0a60fa0df86a3c9e68 /app-benchmarks/sysbench/sysbench-9999.ebuild
parent71bc00c87bba1ce31de0dac6c3b7fd1aee6917fc (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-benchmarks/sysbench/sysbench-9999.ebuild')
-rw-r--r--app-benchmarks/sysbench/sysbench-9999.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/app-benchmarks/sysbench/sysbench-9999.ebuild b/app-benchmarks/sysbench/sysbench-9999.ebuild
deleted file mode 100644
index 6873945f546c..000000000000
--- a/app-benchmarks/sysbench/sysbench-9999.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit git-r3
-
-DESCRIPTION="System performance benchmark"
-HOMEPAGE="https://github.com/akopytov/sysbench"
-
-EGIT_REPO_URI="https://github.com/akopytov/sysbench.git"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS=""
-IUSE="aio mysql postgres test"
-
-RDEPEND="aio? ( dev-libs/libaio )
- mysql? ( virtual/libmysqlclient )
- postgres? ( dev-db/postgresql:= )
- dev-lang/luajit:="
-DEPEND="${RDEPEND}
- app-editors/vim-core
- dev-libs/concurrencykit
- dev-libs/libxslt
- sys-devel/libtool
- virtual/pkgconfig
- test? ( dev-util/cram )"
-
-src_prepare() {
- default
-
- # remove bundled libs
- rm -r third_party/luajit/luajit third_party/concurrency_kit/ck third_party/cram || die
-
- ./autogen.sh || die
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_enable aio aio)
- $(use_with mysql mysql)
- $(use_with postgres pgsql)
- --without-attachsql
- --without-drizzle
- --without-oracle
- --with-system-luajit
- --with-system-ck
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_test() {
- emake check test
-}