summaryrefslogtreecommitdiff
path: root/app-cdr/bashburn/bashburn-3.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-cdr/bashburn/bashburn-3.1.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-cdr/bashburn/bashburn-3.1.0.ebuild')
-rw-r--r--app-cdr/bashburn/bashburn-3.1.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-cdr/bashburn/bashburn-3.1.0.ebuild b/app-cdr/bashburn/bashburn-3.1.0.ebuild
new file mode 100644
index 000000000000..ad701420c84e
--- /dev/null
+++ b/app-cdr/bashburn/bashburn-3.1.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+MY_P=BashBurn-${PV}
+
+DESCRIPTION="A shell script for burning optical media"
+HOMEPAGE="http://bashburn.dose.se/"
+SRC_URI="http://bashburn.dose.se/index.php?s=file_download&id=25 -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 sparc x86"
+IUSE=""
+
+DEPEND="app-shells/bash"
+RDEPEND="${DEPEND}
+ app-cdr/cdrdao
+ app-cdr/dvd+rw-tools
+ media-libs/flac
+ || ( dev-libs/libcdio-paranoia media-sound/cdparanoia )
+ media-sound/lame
+ || ( media-sound/mpg123 media-sound/mpg321 )
+ media-sound/normalize
+ media-sound/vorbis-tools
+ virtual/cdrtools
+ virtual/eject"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # Fix for "warning: jobserver unavailable: using -j1."
+ sed -i -e 's:make -C:$(MAKE) -C:' Makefile || die
+}
+
+src_install() {
+ ./Install.sh --prefix="${D}"/usr || die
+
+ # Remove /var/tmp/portage from installed script
+ sed -i \
+ -e "/BBROOTDIR=/s:'.*':'/usr/lib/Bashburn/lib':" \
+ "${ED}"/usr/lib/Bashburn/lib/BashBurn.sh || die
+
+ rm -rf "${ED}"/usr/lib/Bashburn/lib/docs
+ dodoc docs/{ChangeLog,CREDITS,FAQ,HOWTO,README,TODO,TRANSLATION_RULE}
+}