summaryrefslogtreecommitdiff
path: root/app-cdr/burn-cd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-cdr/burn-cd
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-cdr/burn-cd')
-rw-r--r--app-cdr/burn-cd/Manifest5
-rw-r--r--app-cdr/burn-cd/burn-cd-1.8.0-r1.ebuild31
-rw-r--r--app-cdr/burn-cd/burn-cd-1.8.1.ebuild27
-rw-r--r--app-cdr/burn-cd/metadata.xml17
4 files changed, 80 insertions, 0 deletions
diff --git a/app-cdr/burn-cd/Manifest b/app-cdr/burn-cd/Manifest
new file mode 100644
index 000000000000..ec2d80287b45
--- /dev/null
+++ b/app-cdr/burn-cd/Manifest
@@ -0,0 +1,5 @@
+DIST burn-cd-1.8.0.gz 14977 BLAKE2B 3cc72d908f86affd8c6fef1144ece00ea00ef4cf63858c5a3a01ff83640bd9b513feddf590c774538de6621611bfc842077ef60f28bde6db906aefd0eaa46ccb SHA512 d052d6bd909af3f3c96cee727e222e179d913aa42c2d2afe8104c57b5263b06f318d6ec870ad2862779d757c4d522b7d82892eb0725255261a28243c919b82cf
+DIST burn-cd-1.8.1.tar.gz 153586 BLAKE2B 7762bfe7bb497752c0f78ddc2dba2a00423db2e3ef3dcd02ecb36a60eb6a4ecab69d04bc85971531443b8820cb8320e22349817540d95c694b9861261e6e821f SHA512 2da40c703351e97d164eeef7c5662cad66292b71a97f47ae4ddcbcf11a09fb298c6c9e8160da53b0908434e64048c2397beaa988b1cbc1513660f73d8f2fe1fe
+EBUILD burn-cd-1.8.0-r1.ebuild 581 BLAKE2B eb577476b615782cd97e9ac12cb412d0e38c6469c28d0b2b1b31ab487422716d6160a340afe9faa900adaa64a0629631650b9d2754f58a2d09829d76d3ddaa2d SHA512 316c9c623639f89c7a0cf59ef9bd31acd48f0d2c1bb63356e44137a4271263088031854b6b7bd735a74087da6c952c6641365688d3a8dfa8b53cc6c9e5068d90
+EBUILD burn-cd-1.8.1.ebuild 625 BLAKE2B 9c94dd42b9cc8e076665a6309a4fa297b7b37b588607185bd55bb6d9afea3998a8b83f2ef420802af9c1db4abfafeb715bec69398005c9439dab0331d093cbba SHA512 ea01a64d3859c2a707ea6c84e580a73ac09bbbb924c41ecea644facb289fe56a2e244013de05853b894d38b1ffbbff0aff2eca35f99e49dd3b0e71269c4067ab
+MISC metadata.xml 591 BLAKE2B 9b54a0ade9fd72fbee30ea4250fb72588580d5515efcba62862b1096b3fe98cbdbb3eec58ac245b92e798b12b22e265d9ffea34fb35562f6bdd576e2a902b654 SHA512 faa26f95c90f49757434682dbe3a309123a67e3bb95b11408a99849dd7935ed0037d5c6de022ede67fa2056cde3ead181c3d6797864f6842a4bb8c980b631eae
diff --git a/app-cdr/burn-cd/burn-cd-1.8.0-r1.ebuild b/app-cdr/burn-cd/burn-cd-1.8.0-r1.ebuild
new file mode 100644
index 000000000000..2a72ea5bedb0
--- /dev/null
+++ b/app-cdr/burn-cd/burn-cd-1.8.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Smart console frontend for virtual/cdrtools and dvd+rw-tools"
+HOMEPAGE="http://burn-cd.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+ virtual/cdrtools
+ app-cdr/dvd+rw-tools"
+DEPEND=""
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+S=${WORKDIR}
+
+src_install() {
+ python_fix_shebang ${P}
+ newbin ${P} ${PN}
+}
diff --git a/app-cdr/burn-cd/burn-cd-1.8.1.ebuild b/app-cdr/burn-cd/burn-cd-1.8.1.ebuild
new file mode 100644
index 000000000000..9ae863226c5c
--- /dev/null
+++ b/app-cdr/burn-cd/burn-cd-1.8.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-r1
+
+DESCRIPTION="Smart console frontend for the cdrkit/cdrtools & dvd+rw-tools"
+HOMEPAGE="https://github.com/aglyzov/burn-cd/"
+SRC_URI="https://github.com/aglyzov/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ virtual/cdrtools
+ app-cdr/dvd+rw-tools"
+
+src_install() {
+ newbin ${P} ${PN}
+ insinto /etc
+ newins dotburn-cd.conf burn-cd.conf
+}
diff --git a/app-cdr/burn-cd/metadata.xml b/app-cdr/burn-cd/metadata.xml
new file mode 100644
index 000000000000..d1c04c8d0488
--- /dev/null
+++ b/app-cdr/burn-cd/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>canutethegreat@gmail.com</email>
+ <name>Ronald Farrer</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>CD and DVD command line recording and ripping tools.</longdescription>
+ <upstream>
+ <remote-id type="github">aglyzov/burn-cd</remote-id>
+ <remote-id type="sourceforge">burn-cd</remote-id>
+ </upstream>
+</pkgmetadata>