summaryrefslogtreecommitdiff
path: root/app-cdr/cddetect/cddetect-2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-cdr/cddetect/cddetect-2.1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-cdr/cddetect/cddetect-2.1.ebuild')
-rw-r--r--app-cdr/cddetect/cddetect-2.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-cdr/cddetect/cddetect-2.1.ebuild b/app-cdr/cddetect/cddetect-2.1.ebuild
new file mode 100644
index 000000000000..5de6bf19692a
--- /dev/null
+++ b/app-cdr/cddetect/cddetect-2.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit toolchain-funcs
+
+DESCRIPTION="A tool for detecting the type of a CD/DVD without mounting it"
+HOMEPAGE="http://www.bellut.net/projects.html"
+SRC_URI="http://www.bellut.net/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}
+
+src_prepare() {
+ sed -i -e '1i#include <limits.h>' ${PN}.c || die #337628
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="-Wall ${CFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+}