summaryrefslogtreecommitdiff
path: root/app-cdr/cuegen/cuegen-1.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-cdr/cuegen/cuegen-1.2.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-cdr/cuegen/cuegen-1.2.0.ebuild')
-rw-r--r--app-cdr/cuegen/cuegen-1.2.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-cdr/cuegen/cuegen-1.2.0.ebuild b/app-cdr/cuegen/cuegen-1.2.0.ebuild
new file mode 100644
index 000000000000..7fbb0a2d7049
--- /dev/null
+++ b/app-cdr/cuegen/cuegen-1.2.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="CUEgen is a FLAC-compatible cuesheet generator for Linux"
+HOMEPAGE="http://www.cs.man.ac.uk/~slavinp/cuegen.html"
+SRC_URI="http://www.cs.man.ac.uk/~slavinp/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ sed -i -e 's:\(\${CFLAGS}\):\1 \${LDFLAGS}:g' Makefile
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin cuegen || die "install failed"
+ dodoc README
+}