summaryrefslogtreecommitdiff
path: root/app-cdr/cuegen/cuegen-1.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-30 01:11:30 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-30 01:11:30 +0000
commit76dfef0cec9170000357d2f354e412daf48941fc (patch)
tree56647120c0ee20ab3494475c86722034cd194b02 /app-cdr/cuegen/cuegen-1.2.0.ebuild
parentccf84bcd604130256d1377cd58f0a634ae6ee20f (diff)
gentoo resync : 30.12.2017
Diffstat (limited to 'app-cdr/cuegen/cuegen-1.2.0.ebuild')
-rw-r--r--app-cdr/cuegen/cuegen-1.2.0.ebuild22
1 files changed, 9 insertions, 13 deletions
diff --git a/app-cdr/cuegen/cuegen-1.2.0.ebuild b/app-cdr/cuegen/cuegen-1.2.0.ebuild
index 7fbb0a2d7049..2f72c4191258 100644
--- a/app-cdr/cuegen/cuegen-1.2.0.ebuild
+++ b/app-cdr/cuegen/cuegen-1.2.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
+EAPI=6
-inherit eutils toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="CUEgen is a FLAC-compatible cuesheet generator for Linux"
HOMEPAGE="http://www.cs.man.ac.uk/~slavinp/cuegen.html"
@@ -14,18 +14,14 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND=""
-RDEPEND=""
+PATCHES=( "${FILESDIR}"/${PN}-1.2.0-fix-build-system.patch )
-src_prepare() {
- sed -i -e 's:\(\${CFLAGS}\):\1 \${LDFLAGS}:g' Makefile
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
+src_configure() {
+ append-cflags -W -Wall -Wstrict-prototypes -Wmissing-prototypes
+ tc-export CC
}
src_install() {
- dobin cuegen || die "install failed"
- dodoc README
+ dobin cuegen
+ einstalldocs
}