summaryrefslogtreecommitdiff
path: root/app-cdr/dolphin-plugins-mountiso
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /app-cdr/dolphin-plugins-mountiso
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'app-cdr/dolphin-plugins-mountiso')
-rw-r--r--app-cdr/dolphin-plugins-mountiso/Manifest2
-rw-r--r--app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-20.12.0.ebuild65
2 files changed, 67 insertions, 0 deletions
diff --git a/app-cdr/dolphin-plugins-mountiso/Manifest b/app-cdr/dolphin-plugins-mountiso/Manifest
index b14a4ae31cb1..4a25d9be4005 100644
--- a/app-cdr/dolphin-plugins-mountiso/Manifest
+++ b/app-cdr/dolphin-plugins-mountiso/Manifest
@@ -1,3 +1,5 @@
DIST dolphin-plugins-20.08.3.tar.xz 230272 BLAKE2B 1978ffebe88d95350cac0892c56e127507b6ddd6d5675bca8f420990552e20ff271e6f5742a2bdeff685c82464e70177ac83e5e9368547eb175a3e8133d77624 SHA512 2010be567ef025375caac92e90c0259faea1eb58bdbc55e441e42a10af68b6313391707a7f6b6b10285ba80dcbdee92468fa5088970eb98d4ea8afea145976d9
+DIST dolphin-plugins-20.12.0.tar.xz 236436 BLAKE2B ed8b525c8934b3f1b41f53a9c22a1db211632b58a015e93d507eb46943920fc22e245b81e360bf30d75fe066a2a6ed36857bd3b446faf07b32132ef5755c1eb1 SHA512 a5ed5ae83ba8d2f0af5521f2219191acee2693aae656d829d425a8f9d7d21857511fdda3730dcc88e910ab5a2b6b76817a324498cffa390be3fa616bc57dd106
EBUILD dolphin-plugins-mountiso-20.08.3.ebuild 1533 BLAKE2B 48540c43db4b2317dcf456d1d62c149145e1791c018147076c7ea4da1df178bcac205a4702e4a812fdda4bd7b4b74018717c3247101bcc4293c875f088c4a5be SHA512 3fcccd613b05a494fd32e65a98a7dd4af4f1c863aa38a23a8de3a4438533bb1e421007c4d63e1f30100e4a178645c05f2d0af5680c81534ff14bbb7d464f8e2d
+EBUILD dolphin-plugins-mountiso-20.12.0.ebuild 1536 BLAKE2B 2cca5b0af9688f7ab90b6ab6060c135a5ca4809026106ea030ce79a306dc336accd4d516f2e479f91d5aeb3a0d076dd3f50b6a1f48cf2dd405f4e38a967335e4 SHA512 b1e8eed38e7a1bd9cfdcf3ed43d4c0bf0a5397257a2f02a6bb206b053b4d9381f15852beeed8e3a538a938033378067d712311f8a00c4a190eef79dc7558abd6
MISC metadata.xml 249 BLAKE2B ad415db89e5dee1627aa77f44ded9d4e1e5b8217d06c7ca25bbaa3fe92ce67c2b1090957c45a821b407d7927e5af798498aa6a5b903895ee1af8ee20a446c7f7 SHA512 76a5a340b13f0053ca3c5e94ed24380ea8d29b45ac8655419e22eaadb1e4a827c04d2e7e36b65145c4964e6526f656618fc6ac144e277ef53cb7373e6239e3c3
diff --git a/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-20.12.0.ebuild b/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-20.12.0.ebuild
new file mode 100644
index 000000000000..8382f72ba861
--- /dev/null
+++ b/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-20.12.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="false"
+KDE_RELEASE_SERVICE="true"
+KDE_ORG_CATEGORY="sdk"
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="mountiso"
+KFMIN=5.75.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.1
+inherit ecm kde.org
+
+DESCRIPTION="Dolphin plugin for ISO loopback device mounting"
+HOMEPAGE="https://apps.kde.org/en/dolphin_plugins"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-apps/dolphin-${PVCUT}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/solid-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ ecm_src_prepare
+ # kxmlgui, qtnetwork only required by dropbox
+ ecm_punt_bogus_dep Qt5 Network
+ ecm_punt_bogus_dep KF5 XmlGui
+ # delete non-${PN} translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_git=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ rm "${D}"/usr/share/metainfo/org.kde.dolphin-plugins.metainfo.xml || die
+}