summaryrefslogtreecommitdiff
path: root/app-cdr/sync2cd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-cdr/sync2cd
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-cdr/sync2cd')
-rw-r--r--app-cdr/sync2cd/Manifest3
-rw-r--r--app-cdr/sync2cd/metadata.xml13
-rw-r--r--app-cdr/sync2cd/sync2cd-1.3-r1.ebuild27
3 files changed, 43 insertions, 0 deletions
diff --git a/app-cdr/sync2cd/Manifest b/app-cdr/sync2cd/Manifest
new file mode 100644
index 000000000000..92bcf3cd7dff
--- /dev/null
+++ b/app-cdr/sync2cd/Manifest
@@ -0,0 +1,3 @@
+DIST sync2cd-1.3.tar.gz 39663 BLAKE2B 79f5051155252dc820a2632feba048e5323aca94dc9f14afba39a3c5d7bf606540bdf7b479bd2e4663c78a4c0fff6ed41f2865d7c1711b87cadbfed2fdc1b343 SHA512 a80c00e4a5e1eccf12750e7c6bae606fb1befeba1ad6510e887c931e3bdecef28864053a9a8933f55073204577e173b8109456051e47bce5f26d35be24052c4a
+EBUILD sync2cd-1.3-r1.ebuild 593 BLAKE2B 0e159e84a17e8448d07457525c80207c648f5391f07b6395124f420786b8628aeadae97b650a2a254201dd4138057fc0047a8483ba109548e608b887662b0570 SHA512 877b9fc5f7c3c075985bb32e06c2eea9e7bd4417f1147a4b895538212b25b85f9dd5a45166b74c3f29adba227f50ff3bc85482d6805b50a198b49e3ce093506d
+MISC metadata.xml 579 BLAKE2B 9339557a34401b5c1395a77cbafd6e8e500c3450a88bf694e90e2adb59badb384cd4544512fbd83070cc3ae18cb6522c2e08a8872f50e03dee4a4047f28577cf SHA512 8c04a85eb827adc76cc742c4ddb77bd0b547000a64657e5836ca612950d592c8c51138217af51405c345bb2af8cb6e1d5bb92ed825e7cfe785c3d0ee14daac09
diff --git a/app-cdr/sync2cd/metadata.xml b/app-cdr/sync2cd/metadata.xml
new file mode 100644
index 000000000000..c083f24ac45a
--- /dev/null
+++ b/app-cdr/sync2cd/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+<longdescription>
+sync2cd is an incremental archiving tool. It allows backing up complete filesystem hierarchies to multiple backup
+media (e.g. CD-R). Files are archived incrementally, i.e. only new or changed files are stored during an archive
+operation.
+
+All entity types are supported: directories, files, symlinks, named pipes, sockets, block and character devices.
+(copyied off ref url)
+</longdescription>
+</pkgmetadata>
diff --git a/app-cdr/sync2cd/sync2cd-1.3-r1.ebuild b/app-cdr/sync2cd/sync2cd-1.3-r1.ebuild
new file mode 100644
index 000000000000..87620150944c
--- /dev/null
+++ b/app-cdr/sync2cd/sync2cd-1.3-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="An incremental archiving tool to CD/DVD"
+HOMEPAGE="http://www.calins.ch/software/sync2cd.html"
+SRC_URI="http://www.calins.ch/download/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="cdr dvdr"
+
+RDEPEND="virtual/eject
+ cdr? ( virtual/cdrtools )
+ dvdr? ( app-cdr/dvd+rw-tools )"
+DEPEND=""
+
+python_test() {
+ cd tests || die
+ "${PYTHON}" run.py || die "Unit tests failed for ${EPYTHON}"
+}