summaryrefslogtreecommitdiff
path: root/app-containers/buildah/buildah-1.27.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-27 02:53:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-27 02:53:16 +0100
commitf1aa825b8483db57bf28d0772acfa10aeebe83c3 (patch)
treed56ade77461ea49cbbb4943bd2e100eb6b97bb76 /app-containers/buildah/buildah-1.27.0.ebuild
parent0e83ee97d831abe38c8e764fb9bbfef9de04daf2 (diff)
gentoo auto-resync : 27:08:2022 - 02:53:16
Diffstat (limited to 'app-containers/buildah/buildah-1.27.0.ebuild')
-rw-r--r--app-containers/buildah/buildah-1.27.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-containers/buildah/buildah-1.27.0.ebuild b/app-containers/buildah/buildah-1.27.0.ebuild
new file mode 100644
index 000000000000..76b4d6de3789
--- /dev/null
+++ b/app-containers/buildah/buildah-1.27.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit bash-completion-r1 go-module
+GIT_COMMIT=db8d5921
+
+DESCRIPTION="A tool that facilitates building OCI images"
+HOMEPAGE="https://github.com/containers/buildah"
+SRC_URI="https://github.com/containers/buildah/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="selinux"
+
+RDEPEND="app-crypt/gpgme:=
+ app-containers/skopeo
+ dev-libs/libgpg-error:=
+ dev-libs/libassuan:=
+ sys-apps/shadow:=
+ sys-fs/lvm2:=
+ sys-libs/libseccomp:=
+ selinux? ( sys-libs/libselinux:= )"
+DEPEND="${RDEPEND}"
+
+RESTRICT+=" test"
+
+src_prepare() {
+ default
+ [[ -f selinux_tag.sh ]] || die
+ use selinux || { echo -e "#!/bin/sh\ntrue" > \
+ selinux_tag.sh || die; }
+ sed -i -e 's/make -C/$(MAKE) -C/' Makefile || die 'sed failed'
+}
+
+src_compile() {
+ emake GIT_COMMIT=${GIT_COMMIT} all
+}
+
+src_install() {
+ dodoc CHANGELOG.md CONTRIBUTING.md README.md install.md troubleshooting.md
+ doman docs/*.1
+ dodoc -r docs/tutorials
+ dobin bin/{${PN},imgtype}
+ dobashcomp contrib/completions/bash/buildah
+}
+
+src_test() {
+ emake test-unit
+}