summaryrefslogtreecommitdiff
path: root/app-containers/cri-o
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-08 07:29:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-08 07:29:33 +0100
commit4cc852b4016d8aa1fa4d7a8b3911bebe1ed1da50 (patch)
tree63c3a168bb59a510954fae0dc96a9f4658d22b31 /app-containers/cri-o
parentad75ca50360f9590325f0f709c091832b70eab1d (diff)
gentoo auto-resync : 08:10:2022 - 07:29:32
Diffstat (limited to 'app-containers/cri-o')
-rw-r--r--app-containers/cri-o/Manifest2
-rw-r--r--app-containers/cri-o/cri-o-1.25.1.ebuild101
2 files changed, 103 insertions, 0 deletions
diff --git a/app-containers/cri-o/Manifest b/app-containers/cri-o/Manifest
index 4f427e83a052..a267f655b82e 100644
--- a/app-containers/cri-o/Manifest
+++ b/app-containers/cri-o/Manifest
@@ -1,5 +1,7 @@
AUX cri-o.logrotated 81 BLAKE2B f17d96920c3e9bbfe68a38fcae49be999c0edcea085ebbc1f09585284c5b7930c185d5cd0ef6c2f7de5db2a6af80355518628a050c1cb0639ccf3b53c6c338da SHA512 1115228546a696eeebeb6d4b3e5c3152af0c99a2559097fc5829d8b416d979c457b4b1789e0120054babf57f585d3f63cbe49949d40417ae7aab613184bf4516
AUX crio.initd 846 BLAKE2B 844400d3cd706d4f78616edb3c8a50a9819ee21aecc7fc33f7d3d00871fde86b59e4b604ccc7cdb0058b10ccd28277f19dbdce34c83b2529c14e063126318617 SHA512 29561e95398975748236217bbd9df64997f6e3de6c0555d007306bd0535895a648368385a13079eb7d52c06249a91980523a73b6563e86d0575d9cd9c3fa4ee9
DIST cri-o-1.25.0.tar.gz 27673668 BLAKE2B 5231f1b00781233ddf82827a580100055fefb97e768d871a845506ee28ebc122f20f6c8dff64b9dd8d991ed6ed761a72e96d607354f7e8d4182daff36ef3c253 SHA512 783c2f019ef65079dbb838e58acde5a24bda282ba8298d7b95491356e46fc208a14bcc4c65e3183001f0fb275d8ec5d7b5c795300e6424096f84fb9130721cba
+DIST cri-o-1.25.1.tar.gz 27675134 BLAKE2B 76220f63f5d9c146d6afc15b8afba2ef590faf8916ea3e7f38daeaa58dd6e039ae1a3e607c3e3a194e27f45e67a95a50ca8404f1e457aee89442fbe3505d3c67 SHA512 73b3267583b049e6aa51c1f208512d8e77bc296c34b3ad37977ee57e085b208496e11957c5cc4b55a6b4e2cc728599ce65624233d4d5a4bdc837f0dddb569323
EBUILD cri-o-1.25.0.ebuild 2722 BLAKE2B a82323f0abbb66eec87d490128f12ee02e61e818232c5fa3965c5e1d9c20998834d4fd94bca80c435371a34bff2d2c69fde844302bf4ac038cf8bf39a01b5e3e SHA512 e7a3684fd2d1f2396722e8dc89380b575f4f53d70c2194f4d300b24b8601ef6d2b59caa1b3b87b5f5c83e87c6520a938715c07b773ee428eb329e15a91bf18b4
+EBUILD cri-o-1.25.1.ebuild 2722 BLAKE2B 4fe35318a2763aa0e5a2a9a0ce6e9bbb4b07fd76880c6d8cb219474c0d4c128f0199d0c5ae842ef221be50ac4894d781c6f2e698b3dc1a1cfed7b532c1719227 SHA512 543099f012fd56daa95bd3f18b0e2779c4b3eae6b8df3763fa24b7640d68d435956ce46e68ce02fab5af2fc0249dbfcace596321d08fc37e1063b6fbc0b2e229
MISC metadata.xml 908 BLAKE2B ff6e1663f563dff74dbdeeb5d5c778a70fe2395ff0c0836e31b538f0009215a74946384a1429f2cf8e65bccc26d4b357233f1aab1a2c70ca3f544653d79cf999 SHA512 0fe5ad9f9f1c3b7386f361febbedddb690fcf83145f80da05d77be72bf04f84d9106d46ff6962ed6cc99d7b12f3792263eb7b1711763a2cd2f8a7dac08ed5c09
diff --git a/app-containers/cri-o/cri-o-1.25.1.ebuild b/app-containers/cri-o/cri-o-1.25.1.ebuild
new file mode 100644
index 000000000000..65ab0adb604d
--- /dev/null
+++ b/app-containers/cri-o/cri-o-1.25.1.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_COMMIT=afa0c576fcafc095e2827261e412fadabb016874
+
+inherit go-module
+
+DESCRIPTION="OCI-based implementation of Kubernetes Container Runtime Interface"
+HOMEPAGE="https://cri-o.io/"
+SRC_URI="https://github.com/cri-o/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="btrfs +device-mapper selinux systemd"
+
+COMMON_DEPEND="
+ app-crypt/gpgme:=
+ app-containers/conmon
+ app-containers/runc
+ dev-libs/glib:=
+ dev-libs/libassuan:=
+ dev-libs/libgpg-error:=
+ net-firewall/conntrack-tools
+ net-firewall/iptables
+ app-containers/cni-plugins
+ net-misc/socat
+ sys-apps/iproute2
+ sys-libs/libseccomp:=
+ btrfs? ( sys-fs/btrfs-progs )
+ device-mapper? ( sys-fs/lvm2:= )
+ selinux? ( sys-libs/libselinux:= )
+ systemd? ( sys-apps/systemd:= )"
+DEPEND="
+ ${COMMON_DEPEND}
+ dev-go/go-md2man"
+RDEPEND="${COMMON_DEPEND}
+ !<app-containers/podman-1.3.2-r1"
+
+src_prepare() {
+ default
+
+ sed -e '/^export GOPROXY=/d' \
+ -e '/^GIT_.*/d' \
+ -e '/ git diff --exit-code/d' \
+ -e 's/$(GO) build -i/$(GO) build -v -work -x/' \
+ -e 's/\${GIT_COMMIT}/'${EGIT_COMMIT}'/' \
+ -e "s|^GIT_COMMIT := .*|GIT_COMMIT := ${EGIT_COMMIT}|" \
+ -e "s|^COMMIT_NO := .*|COMMIT_NO := ${EGIT_COMMIT}|" \
+ -i Makefile || die
+
+ echo ".NOTPARALLEL: binaries docs" >> Makefile || die
+
+ sed -e 's:/usr/local/bin:/usr/bin:' \
+ -i contrib/systemd/* || die
+}
+
+src_compile() {
+ [[ -f hack/btrfs_installed_tag.sh ]] || die
+ use btrfs || { echo -e "#!/bin/sh\necho exclude_graphdriver_btrfs" > \
+ hack/btrfs_installed_tag.sh || die; }
+
+ [[ -f hack/libdm_installed.sh ]] || die
+ use device-mapper || { echo -e "#!/bin/sh\necho exclude_graphdriver_devicemapper" > \
+ hack/libdm_installed.sh || die; }
+
+ [[ -f hack/selinux_tag.sh ]] || die
+ use selinux || { echo -e "#!/bin/sh\ntrue" > \
+ hack/selinux_tag.sh || die; }
+
+ mkdir -p bin || die
+ emake all \
+ GOBIN="${S}/bin" \
+ GO_BUILD="go build ${GOFLAGS}" \
+ GO_MD2MAN="$(which go-md2man)"
+}
+
+src_install() {
+ emake install install.config install.systemd \
+ DESTDIR="${D}" \
+ GO_MD2MAN="$(which go-md2man)" \
+ PREFIX="${D}${EPREFIX}/usr"
+ keepdir /etc/crio
+ mv "${ED}/etc/crio/crio.conf"{,.example} || die
+
+ newinitd "${FILESDIR}/crio.initd" crio
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}.logrotated" "${PN}"
+
+ # Suppress crio log error messages triggered if these don't exist.
+ keepdir /etc/containers/oci/hooks.d
+ keepdir /usr/share/containers/oci/hooks.d
+
+ # Suppress crio "Missing CNI default network" log message.
+ keepdir /etc/cni/net.d
+ insinto /etc/cni/net.d
+ doins contrib/cni/99-loopback.conf
+}