summaryrefslogtreecommitdiff
path: root/app-containers/cri-o
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-07 06:41:06 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-07 06:41:06 +0000
commitd69399c7befdd98cda62d6a1788ae2aa7f104c5e (patch)
treeeac7184f4cfe7d67580c1d0a0d9942a91e6cb4ee /app-containers/cri-o
parente4d9d6796d5018e338f0b27a3bc97716195bf0b8 (diff)
gentoo auto-resync : 07:01:2025 - 06:41:06
Diffstat (limited to 'app-containers/cri-o')
-rw-r--r--app-containers/cri-o/Manifest2
-rw-r--r--app-containers/cri-o/cri-o-1.31.4.ebuild103
2 files changed, 105 insertions, 0 deletions
diff --git a/app-containers/cri-o/Manifest b/app-containers/cri-o/Manifest
index b3453f9baa60..6e824d5bdc63 100644
--- a/app-containers/cri-o/Manifest
+++ b/app-containers/cri-o/Manifest
@@ -1,5 +1,7 @@
AUX cri-o.logrotated 81 BLAKE2B f17d96920c3e9bbfe68a38fcae49be999c0edcea085ebbc1f09585284c5b7930c185d5cd0ef6c2f7de5db2a6af80355518628a050c1cb0639ccf3b53c6c338da SHA512 1115228546a696eeebeb6d4b3e5c3152af0c99a2559097fc5829d8b416d979c457b4b1789e0120054babf57f585d3f63cbe49949d40417ae7aab613184bf4516
AUX crio.initd 846 BLAKE2B 844400d3cd706d4f78616edb3c8a50a9819ee21aecc7fc33f7d3d00871fde86b59e4b604ccc7cdb0058b10ccd28277f19dbdce34c83b2529c14e063126318617 SHA512 29561e95398975748236217bbd9df64997f6e3de6c0555d007306bd0535895a648368385a13079eb7d52c06249a91980523a73b6563e86d0575d9cd9c3fa4ee9
DIST cri-o-1.31.2.tar.gz 19921920 BLAKE2B 4e60c15d73691dabab8f7f1229b0b8e534393128a53cd31639509454286ec237cf5e6bf258c8e06478b76b872b6e1e8d3481b19a277be4c0bf756b1a6d858d95 SHA512 be42d08ee2a9d030d9279dee269d121822de5c74aafa765688c91383a284cda890aa969a5a2b0649835893bd3b382e6bf2a1f81991710b479b4159877e0626aa
+DIST cri-o-1.31.4.tar.gz 19919611 BLAKE2B b9c2a855c8f8b780e4f77172dab0070cf9fa96216c1b03d1c06b42ac1385dbd9e57e4dadd88a54c4c0dde8366dda95293c1763c3fec554b79573ddd8da02aa6e SHA512 c10cb633a2bbc7c3d0fdbae7b5541fc948804ca797a71532e0dcd783d0e56158650ea93d3cce36995922e04f9f22c27c4255bc40a81930e263ebb0c710372a06
EBUILD cri-o-1.31.2.ebuild 2789 BLAKE2B a638b6a4dcb840683bdc900c41951d86c4ea1d29e507834cfa9ce7971153d8a915af14692fab51450dc03f35bb412f1fa62bb0b9b8d668d675bcde8437c67a93 SHA512 f2ed5a575cbdbc5c552b3c7265aa69ee346c8ec6b62a10a5310e2b093ca9e14059db97e2e5dc698b265e0bfd72db71cee0df0b4850311bfdf285a1ddfbd4172c
+EBUILD cri-o-1.31.4.ebuild 2789 BLAKE2B 908944f4e7e19de07c1e76b8c0262bc521baade82b17d448eacb9e4a13e3253d336c7c0c79ae1f7d3f9c26f2203e7823bae121e86ef839fef9b14a82f46ce527 SHA512 d65e59acca4e349b47c58e2cdc5a565582a1a71bd3f6510e48784c469eb3a5845343be4b21fd74fc8fa2040ce1119bc4b80b6fc0a4b95201e207cdee0c0370f6
MISC metadata.xml 908 BLAKE2B ff6e1663f563dff74dbdeeb5d5c778a70fe2395ff0c0836e31b538f0009215a74946384a1429f2cf8e65bccc26d4b357233f1aab1a2c70ca3f544653d79cf999 SHA512 0fe5ad9f9f1c3b7386f361febbedddb690fcf83145f80da05d77be72bf04f84d9106d46ff6962ed6cc99d7b12f3792263eb7b1711763a2cd2f8a7dac08ed5c09
diff --git a/app-containers/cri-o/cri-o-1.31.4.ebuild b/app-containers/cri-o/cri-o-1.31.4.ebuild
new file mode 100644
index 000000000000..3bc77ec3ed72
--- /dev/null
+++ b/app-containers/cri-o/cri-o-1.31.4.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+EGIT_COMMIT=33d75981bee230f791709975125d7386fe2c530a
+
+inherit go-module
+
+DESCRIPTION="OCI-based implementation of Kubernetes Container Runtime Interface"
+HOMEPAGE="https://cri-o.io/"
+SRC_URI="https://github.com/cri-o/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="btrfs +device-mapper selinux systemd"
+
+COMMON_DEPEND="
+ app-crypt/gpgme:=
+ app-containers/conmon
+ app-containers/runc
+ dev-libs/glib:=
+ dev-libs/libassuan:=
+ dev-libs/libgpg-error:=
+ net-firewall/conntrack-tools
+ net-firewall/iptables
+ app-containers/cni-plugins
+ net-misc/socat
+ sys-apps/iproute2
+ sys-libs/libseccomp:=
+ btrfs? ( sys-fs/btrfs-progs )
+ device-mapper? ( sys-fs/lvm2:= )
+ selinux? ( sys-libs/libselinux:= )
+ systemd? ( sys-apps/systemd:= )"
+DEPEND="
+ ${COMMON_DEPEND}
+ dev-go/go-md2man"
+RDEPEND="${COMMON_DEPEND}
+ !<app-containers/podman-1.3.2-r1
+ selinux? ( sec-policy/selinux-crio )"
+BDEPEND="sys-apps/which"
+
+src_prepare() {
+ default
+
+ sed -e '/^export GOPROXY=/d' \
+ -e '/^GIT_.*/d' \
+ -e '/ git diff --exit-code/d' \
+ -e 's/$(GO) build -i/$(GO) build -v -work -x/' \
+ -e 's/\${GIT_COMMIT}/'${EGIT_COMMIT}'/' \
+ -e "s|^GIT_COMMIT := .*|GIT_COMMIT := ${EGIT_COMMIT}|" \
+ -e "s|^COMMIT_NO := .*|COMMIT_NO := ${EGIT_COMMIT}|" \
+ -i Makefile || die
+
+ echo ".NOTPARALLEL: binaries docs" >> Makefile || die
+
+ sed -e 's:/usr/local/bin:/usr/bin:' \
+ -i contrib/systemd/* || die
+}
+
+src_compile() {
+ [[ -f hack/btrfs_installed_tag.sh ]] || die
+ use btrfs || { echo -e "#!/bin/sh\necho exclude_graphdriver_btrfs" > \
+ hack/btrfs_installed_tag.sh || die; }
+
+ [[ -f hack/libdm_installed.sh ]] || die
+ use device-mapper || { echo -e "#!/bin/sh\necho exclude_graphdriver_devicemapper" > \
+ hack/libdm_installed.sh || die; }
+
+ [[ -f hack/selinux_tag.sh ]] || die
+ use selinux || { echo -e "#!/bin/sh\ntrue" > \
+ hack/selinux_tag.sh || die; }
+
+ mkdir -p bin || die
+ emake all \
+ GOBIN="${S}/bin" \
+ GO_BUILD="go build ${GOFLAGS}" \
+ GO_MD2MAN="$(which go-md2man)"
+}
+
+src_install() {
+ emake install install.config install.systemd \
+ DESTDIR="${D}" \
+ GO_MD2MAN="$(which go-md2man)" \
+ PREFIX="${D}${EPREFIX}/usr"
+ keepdir /etc/crio
+ mv "${ED}/etc/crio/crio.conf"{,.example} || die
+
+ newinitd "${FILESDIR}/crio.initd" crio
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}.logrotated" "${PN}"
+
+ # Suppress crio log error messages triggered if these don't exist.
+ keepdir /etc/containers/oci/hooks.d
+ keepdir /usr/share/containers/oci/hooks.d
+
+ # Suppress crio "Missing CNI default network" log message.
+ keepdir /etc/cni/net.d
+ insinto /etc/cni/net.d
+ doins contrib/cni/99-loopback.conflist
+}