summaryrefslogtreecommitdiff
path: root/app-containers/earthly
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-05 21:20:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-05 21:20:55 +0100
commit2092ebe8b45cc45ad3357e2ccb2c37d5c1eaba2a (patch)
tree25c07bf0e025915c671c69127e02b8d201967e16 /app-containers/earthly
parent2fc12e1ffd37b655f78c4277bd595010e18a8447 (diff)
gentoo auto-resync : 05:08:2023 - 21:20:55
Diffstat (limited to 'app-containers/earthly')
-rw-r--r--app-containers/earthly/Manifest3
-rw-r--r--app-containers/earthly/earthly-0.7.15.ebuild74
2 files changed, 77 insertions, 0 deletions
diff --git a/app-containers/earthly/Manifest b/app-containers/earthly/Manifest
index 0f0adb5c36a5..fa3aec72fb2c 100644
--- a/app-containers/earthly/Manifest
+++ b/app-containers/earthly/Manifest
@@ -1,4 +1,7 @@
DIST earthly-0.7.14-deps.tar.xz 152887572 BLAKE2B a5cb8940b863d1f0ef6caf976a59b03cc6cbb422c66ed30eff3597631073caeeb09397a81116ff5d0c70d7c10c98d8016379b079c95a83ef0e06557e08b7e166 SHA512 8d7014b67cdf55311fad0be48c068b2338136d21ab1b98df571c38b74cd1f8b5711b5c3d9e52fc2d2365bfb1cd3fe4a5a39c4955a176f1cce07d6d59f7f7da24
DIST earthly-0.7.14.tar.gz 7750445 BLAKE2B 7333342c85fe2c7efb0bd5222e2ce1e820886b851f43945098bff0f0326ac1f881305fe5b909bcc1c14f427dfdcb3ace2e32aa299cd38d94c9b0a7c8bd95e82f SHA512 a739bb1d2eb46285a545e831f9f40ebc6d3954e791687bb79bef8ff02a719ec72d970860de9319bb825a917a83b621e7745eb34dbe11bd66239c819a9fc46840
+DIST earthly-0.7.15-deps.tar.xz 152884116 BLAKE2B 69f937981605da5db306cdd7f06cdeb106bf907e85ea83f29a77c719d662003b562e7263a5eeb9e478682c019a3d7a265d4cf4ab1c5bcf2f37efbaa42e9ae326 SHA512 368700ce71c8791069d8c14abc6e1d4bf7c356d770641c4172e3e8910c176f0ba8cd5c5738e639da2905385d5d4a961f52b84d8e228fc3e323876f1cda16265e
+DIST earthly-0.7.15.tar.gz 7750609 BLAKE2B b727c6cde93abb3b3e39addc9e79c07fb21232902bca61b5a2b843d1c92b4b6628a1122eced0141b6be6c6678d80a7e473efc6513af07a416b3d6972e210defb SHA512 975d1c1c0055ed6e2884102f4d785833aea4c9257ba3f34e70eeea95c1215eb1dc769a036bdf036682d95dfa6bb30c35b897ff337b2af8b5d9d459f14ecc7cc4
EBUILD earthly-0.7.14.ebuild 1805 BLAKE2B 64610bd4ef3d051089ad7afe27c08ac50ea7277f08a5293b6787b37fd0a06eccf1f1faff8c5a80df779568ad98f9788be35a76e3131249c45cede2c68843e3a3 SHA512 6ee12bd99611e2d064af628f122d630df28ec3088cad6916979c072473e36cf368306879e4ade774bb8300321c3ca616b4d973ff74210e4a23ae342fd8045773
+EBUILD earthly-0.7.15.ebuild 1805 BLAKE2B f3ec5c9ecefe0adc831aff49bf7e816ead47a4d7311f01fe4765183079312a44348a45b529f923b9f3403d477c721a5c273c9ef83320817ccaa4b0239019a586 SHA512 26ca0cdeb4135174915b201d6c2f60cbdfc9d017f5daf0c63642238d004e676282637a85007890b034967f43168ee429151bcf07d1a6bfa423a902eeeec2c720
MISC metadata.xml 927 BLAKE2B b7d5184df16f39603bf6df8b503e701d737fec188d1d97673e4ca59babd990c1b872784c91db04c74d9a08dbffa76f4e7530d8b021cbbe9ae51fd9966f709522 SHA512 f7f49eb583b2b5a9939c26e9eaff3917392525c3a94e5f8274c89b69e172547ad02fa4ed1b078e7d778f765659e1b9a7cf99d88042034cfbfbef54e685c8b6dd
diff --git a/app-containers/earthly/earthly-0.7.15.ebuild b/app-containers/earthly/earthly-0.7.15.ebuild
new file mode 100644
index 000000000000..8df3700e87c3
--- /dev/null
+++ b/app-containers/earthly/earthly-0.7.15.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Build automation tool that executes in containers"
+HOMEPAGE="https://earthly.dev/
+ https://github.com/earthly/earthly/"
+SRC_URI="
+ https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+ https://dev.gentoo.org/~xgqt/distfiles/deps/${P}-deps.tar.xz
+"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ || (
+ app-containers/docker
+ app-containers/podman
+ )
+"
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
+
+src_compile() {
+ mkdir -p bin || die
+
+ # Git SHA is needed at runtime by earthly to pull and bootstrap images.
+ local git_sha
+ if [[ ${PV} == 0.7.15 ]] ; then
+ git_sha=ae8f65528ad37a278985de2e234deb42b91e308f
+ else
+ die 'Could not detect "git_sha", please update the ebuild.'
+ fi
+
+ local go_tags="dfrunmount,dfrunsecurity,dfsecrets,dfssh,dfrunnetwork,dfheredoc,forceposix"
+ local go_ldflags="
+ -X main.DefaultBuildkitdImage=docker.io/earthly/buildkitd:v${PV}
+ -X main.GitSha=${git_sha}
+ -X main.Version=v${PV}
+ "
+ local -a go_buildargs=(
+ -tags "${go_tags}"
+ -ldflags "${go_ldflags}"
+ -o bin
+ )
+ ego build "${go_buildargs[@]}" ./cmd/...
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe bin/earthly
+ newexe bin/debugger earthly-debugger
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ if has_version "app-containers/podman" ; then
+ ewarn "Podman is supported but not recommended."
+ ewarn "If issues arise, then please try running earthly with docker."
+ fi
+
+ if has_version "app-containers/podman[rootless]" ; then
+ ewarn "Running podman in rootless mode is not supported because"
+ ewarn "earthly/dind and earthly/buildkit require privileged access."
+ ewarn "For more info see: https://docs.earthly.dev/docs/guides/podman/"
+ fi
+}