summaryrefslogtreecommitdiff
path: root/app-containers/go-secbench/go-secbench-0.1.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /app-containers/go-secbench/go-secbench-0.1.0-r1.ebuild
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'app-containers/go-secbench/go-secbench-0.1.0-r1.ebuild')
-rw-r--r--app-containers/go-secbench/go-secbench-0.1.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-containers/go-secbench/go-secbench-0.1.0-r1.ebuild b/app-containers/go-secbench/go-secbench-0.1.0-r1.ebuild
new file mode 100644
index 000000000000..bbc7926f7164
--- /dev/null
+++ b/app-containers/go-secbench/go-secbench-0.1.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/qnib/go-secbench"
+inherit golang-build golang-vcs-snapshot
+
+DESCRIPTION="run and evaluate the docker security benchmark"
+HOMEPAGE="https://github.com/qnib/go-secbench"
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test"
+
+DEPEND="dev-lang/go"
+RDEPEND="app-containers/docker"
+
+src_compile() {
+ GOPATH="${S}" go build -o bin/go-secbench src/${EGO_PN}/cmd/main.go || die
+}
+
+src_install() {
+ dobin bin/${PN}
+dodoc "src/${EGO_PN}/README.md"
+}