summaryrefslogtreecommitdiff
path: root/app-containers/lxc/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-18 14:34:47 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-18 14:34:47 +0100
commit3a1b8b124a5b405562b6e0ccf04e7bd2ddc131a4 (patch)
tree586b06fa140c17c92f004998807e894c1874db27 /app-containers/lxc/files
parente0d23d9d2468ec36070ef9fa63bd814db6a653da (diff)
gentoo auto-resync : 18:07:2022 - 14:34:47
Diffstat (limited to 'app-containers/lxc/files')
-rw-r--r--app-containers/lxc/files/lxc-5.0.0-dont-depend-on-static-libcap.patch27
-rw-r--r--app-containers/lxc/files/lxc-monitord.service.5.0.011
-rw-r--r--app-containers/lxc/files/lxc-net.service.5.0.015
-rw-r--r--app-containers/lxc/files/lxc.service-5.0.019
-rw-r--r--app-containers/lxc/files/lxc_at.service.5.0.019
5 files changed, 91 insertions, 0 deletions
diff --git a/app-containers/lxc/files/lxc-5.0.0-dont-depend-on-static-libcap.patch b/app-containers/lxc/files/lxc-5.0.0-dont-depend-on-static-libcap.patch
new file mode 100644
index 000000000000..74f3d353c561
--- /dev/null
+++ b/app-containers/lxc/files/lxc-5.0.0-dont-depend-on-static-libcap.patch
@@ -0,0 +1,27 @@
+From 7d72354898feac15bc4082130bcbe638bae02450 Mon Sep 17 00:00:00 2001
+From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+Date: Thu, 14 Jul 2022 17:03:40 +0200
+Subject: [PATCH] meson.build: fix build with -Dcapabilities=false
+
+Define libcap_static to an empty array to avoid the following build
+failure with -Dcapabilities=false:
+
+output/build/lxc-5.0.0/src/lxc/cmd/meson.build:64:4: ERROR: Unknown variable "libcap_static".
+
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+---
+ meson.build | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/meson.build b/meson.build
+index 992fa08c72..4ed57a655b 100644
+--- a/meson.build
++++ b/meson.build
+@@ -443,6 +443,7 @@ int main(int argc, char *argv[]) { return 0; };
+ srcconf.set10('HAVE_STATIC_LIBCAP', false)
+ endif
+ else
++ libcap_static = []
+ srcconf.set10('HAVE_LIBCAP', false)
+ srcconf.set10('HAVE_STATIC_LIBCAP', false)
+ endif
diff --git a/app-containers/lxc/files/lxc-monitord.service.5.0.0 b/app-containers/lxc/files/lxc-monitord.service.5.0.0
new file mode 100644
index 000000000000..ff4a201152c0
--- /dev/null
+++ b/app-containers/lxc/files/lxc-monitord.service.5.0.0
@@ -0,0 +1,11 @@
+[Unit]
+Description=LXC Container Monitoring Daemon
+After=syslog.service network.target
+Documentation=man:lxc
+
+[Service]
+Type=simple
+ExecStart=/usr/libexec/lxc/lxc-monitord --daemon
+
+[Install]
+WantedBy=multi-user.target
diff --git a/app-containers/lxc/files/lxc-net.service.5.0.0 b/app-containers/lxc/files/lxc-net.service.5.0.0
new file mode 100644
index 000000000000..8a037fcb7614
--- /dev/null
+++ b/app-containers/lxc/files/lxc-net.service.5.0.0
@@ -0,0 +1,15 @@
+[Unit]
+Description=LXC network bridge setup
+After=network-online.target
+Before=lxc.service
+Documentation=man:lxc
+ConditionVirtualization=!lxc
+
+[Service]
+Type=oneshot
+RemainAfterExit=yes
+ExecStart=/usr/libexec/lxc/lxc-net start
+ExecStop=/usr/libexec/lxc/lxc-net stop
+
+[Install]
+WantedBy=multi-user.target
diff --git a/app-containers/lxc/files/lxc.service-5.0.0 b/app-containers/lxc/files/lxc.service-5.0.0
new file mode 100644
index 000000000000..35d0dff241d0
--- /dev/null
+++ b/app-containers/lxc/files/lxc.service-5.0.0
@@ -0,0 +1,19 @@
+[Unit]
+Description=LXC Container Initialization and Autoboot Code
+After=network.target lxc-net.service remote-fs.target
+Wants=lxc-net.service
+Documentation=man:lxc-autostart man:lxc
+
+[Service]
+Type=oneshot
+RemainAfterExit=yes
+ExecStartPre=/usr/libexec/lxc/lxc-apparmor-load
+ExecStart=/usr/libexec//lxc/lxc-containers start
+ExecStop=/usr/libexec/lxc/lxc-containers stop
+ExecReload=/usr/libexec/lxc/lxc-apparmor-load
+# Environment=BOOTUP=serial
+# Environment=CONSOLETYPE=serial
+Delegate=yes
+
+[Install]
+WantedBy=multi-user.target
diff --git a/app-containers/lxc/files/lxc_at.service.5.0.0 b/app-containers/lxc/files/lxc_at.service.5.0.0
new file mode 100644
index 000000000000..447b6c87ec5d
--- /dev/null
+++ b/app-containers/lxc/files/lxc_at.service.5.0.0
@@ -0,0 +1,19 @@
+[Unit]
+Description=LXC Container: %i
+# This pulls in apparmor, dev-setup, lxc-net
+After=lxc.service
+Wants=lxc.service
+Documentation=man:lxc-start man:lxc
+
+[Service]
+Type=simple
+KillMode=mixed
+TimeoutStopSec=120s
+ExecStart=/usr/bin/lxc-start -F -n %i
+ExecStop=/usr/bin/lxc-stop -n %i
+# Environment=BOOTUP=serial
+# Environment=CONSOLETYPE=serial
+Delegate=yes
+
+[Install]
+WantedBy=multi-user.target