summaryrefslogtreecommitdiff
path: root/app-containers/podman-compose
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-08 06:41:21 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-08 06:41:21 +0000
commit9991465b0b90d77b2a8a2ae833b6ecd99e6b5101 (patch)
tree28adc48ed9c9af3eec4c870d7a7efc8da5e0d8f1 /app-containers/podman-compose
parentd69399c7befdd98cda62d6a1788ae2aa7f104c5e (diff)
gentoo auto-resync : 08:01:2025 - 06:41:21
Diffstat (limited to 'app-containers/podman-compose')
-rw-r--r--app-containers/podman-compose/Manifest2
-rw-r--r--app-containers/podman-compose/podman-compose-1.3.0.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/app-containers/podman-compose/Manifest b/app-containers/podman-compose/Manifest
index 8075698c4e06..1262cf1073af 100644
--- a/app-containers/podman-compose/Manifest
+++ b/app-containers/podman-compose/Manifest
@@ -1,3 +1,5 @@
DIST podman-compose-1.2.0.gh.tar.gz 84708 BLAKE2B ab1f458cef6db99c5727a6676cd1a15ccc58108a14763b9bf8e1093bc674e1adbee21c81744a0cb7798be6134e7b566a4ed9222be71bda0d8f7e4568b3d2fcb7 SHA512 2b45bcb331e334d362a0906563377e1514aca95f50c575e4b53039e58394b39af1ceeb606d90c652ef6d8cc5e8764a27edf11fc9782a89b186812a474b583579
+DIST podman-compose-1.3.0.gh.tar.gz 103006 BLAKE2B aa3202e23728d71cb7685ceeac5ba67d638477666ae5863d67ed36d404a84e897ffbf60c4188aedf5fda06b43db697baff338f43c8637981ffa3c4e62872f140 SHA512 7f7be6d0d230554f766aa9d7d2e4a8b16155780706859f6f0ee94b7e73bd6b095f20948ff168f5492690ee7e8f5acd7dd8d88219d8721c483214eba74575a582
EBUILD podman-compose-1.2.0.ebuild 790 BLAKE2B 76a151aafae24cb48a7ebc1e673b8f881db1eb8ee97cae27c8e55761ff23af22a473b6bd463fbdc3d0dde80e79dda95d5cf35cabe5f769e376e94acef02570a8 SHA512 9218e8cee42b89327e8274437aa8e50099383ff742b90532641fba50d97abd9e3741cc182e3140fc2f395fcbe18e4ee02920fcc5954f3bb6ba479b11a5014a63
+EBUILD podman-compose-1.3.0.ebuild 793 BLAKE2B 066918dcebc4ff5f309f0a44c92e34dc418ab5b9905c11a123ff58e1595872885571ab9d4adefa0bee44336c568621a763a8d3bd63170939b9a0bba2bbf804f7 SHA512 1eff9cf4ea8b8d7ddedbb51271375331fe4c797b0f67aeb08de8245e6f24a25926eb3d61b1f839d01c1f761082a7e5c02dc2857118c711456b3b5572c4902efb
MISC metadata.xml 387 BLAKE2B 9df848de1538d10b16425c1e8f4cb20eddc2f24c6472ff595fbb04904a2249d5e2e2283b3ce35cd9cd4d4a50ea51927d85c2ec4e9e2ede75ce8865db235e68d9 SHA512 f4cd09e8dec20ad6edaf43787522afccbbc8fecd9fb2ac8d0a805180856ec5e61528fc9a537714d8475e4fb2c019e160503c87a8ac2fa4fdc40ca54e84adb262
diff --git a/app-containers/podman-compose/podman-compose-1.3.0.ebuild b/app-containers/podman-compose/podman-compose-1.3.0.ebuild
new file mode 100644
index 000000000000..881806f6e2a1
--- /dev/null
+++ b/app-containers/podman-compose/podman-compose-1.3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2023-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+inherit distutils-r1
+
+DESCRIPTION="A script to run docker-compose.yml using Podman"
+HOMEPAGE="https://github.com/containers/podman-compose"
+SRC_URI="https://github.com/containers/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ app-containers/aardvark-dns
+ app-containers/netavark
+ app-containers/podman
+"
+
+RDEPEND="
+ ${DEPEND}
+ dev-python/pyaml[${PYTHON_USEDEP}]
+ dev-python/python-dotenv[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests/unit
+}